Big mistake to upgrade to OS 5

I made the big mistake to upgrade to OS 5.
WD, Welcome to the group of companies that, in the name of the safety of their customers, have made sure that customers are disgusted by the use of their new products.

In the name of “security”, WD has created thousands of nonsense on the new operating system and Internet access.
Problem 1
I can’t access the transmission interface if I haven’t logged in to the NAS. So what is this nonsense, do I have to log in to my user interface every time to be able to access the transmission interface? Why is this transmission for me when I don’t have quick and easy access to it. Especially over the internet. For years, I added files to my transmission during the day, and in the evening, when I got home, they were downloaded. Now this is impossible. I need to remotely turn on a computer on the local network (which consumes electricity for which harmful emissions are generated) and then enter the EX2 interface and only then access the transmission interface.
Western Digital programmers are idiots and you couldn’t do it any harder. It’s as if you’re suggesting that I go from Paris to London, it’s safer to go through Dubai and Cape Town.
Problem 2
I do not have access to the user interface via the Internet with a port forwarding thoght router.
My NAS has always been after a microtic router that has a good enough firewall. And to access the interface for just a moment, I redirected some ports to go to my NAS.

And many other problems …

After updating from version 3 to version 5 I saw 30 gigabytes more free space on my NAS. Where have these 30 gigabytes been so far? My trash was empty.

These are the problems I discovered only 1 hour after my biggest mistake in 2020 - updating to OS5.

I ask the WD moderators to review these issues and provide a quick solution for Internet access or downgrade to OS3. These problems are only mine and all users. Otherwise, I and my clients over 50 will have to switch to Sinology or QNAP, they are more expensive, but everything works and there are no such problems.

3 Likes

FYI - check out the updates from the My Cloud team here:

I updated directly to 5.06.115 firmware. Bla Bla bla

The indexing of 3 TB information has been going on for 15 hours. and it has reached 40% I use RAID 0.

Please decide how to restore the old OS, this new one is useless with this new security policy of yours

@jchen can you answer please:

1.) Folder download with browser does not work anymore! How to enable it again please?

2.) How to enable folder upload with browser?

3.) How to disable the upload restriction of maximum file size 5 GB?

24h after update - Indexing 45%…

generating a sharing link does not work in os5.mycloud.com

WD Stuff say something, do not hide behind your mistakes. You destroyed my good device!

hello,
like many users I switched from OS3 to OS5 (5.06.115), and since then I don’t see my MyCloud EX2 Ultra on my smart TV (LG 65NANO867NA and Grundig GRU43GFB6725) and on my BeeLink box. but the Cloud is perfectly recognized on my Fritzbox 7490 router and on my Windows 10 PC. is there a solution or should I go to the competition (sinology)?

@BukmopBG, Unfortunately content do need to be re-indexed for cloud access. You can turn off network shares that doesn’t need to have cloud access to try and reduce the index time. Here is a KBA you can check out - https://support-en.wd.com/app/answers/detail/a_id/30021/kw/indexing

@doumeng77731, Your Smart TV may require a DLNA server to be installed. You can refer to the following KBA:

Hello jchen,
i have installed now Twonky and the problem is solved, thanks for your answer

48h afert update. 2 restarts, Indexing reezes when it reaches 45%…

WD Stuf I expect you to give me a real solution to the problem and not default answers!!!

1 Like

Is there a way to revert back to previous garbage OS5?

@jchen I have the same issue.

1 Like

hahaha!
Good joke!

They are not software developers - they build hardware.

Right, which new hardware products (NAS) have they released in last 5 years?

I am so happy I saw this post and did not do the upgrade. Just got 2 new ex2 ultra for nas devices for my private network. Both are going back within the next 14 days unless they fix this. I bought a my home thinking it was going to be like the my cloud. I hated the my home software when I tested and returned it. If I would known they were going to do the same thing to the ex2 I would of never bought them. If i would of upgraded to OS5 I would of been in the same boat. I bought it because I want to manage it my self just like with the previous devices and not go through a website to access. What if the internet goes down. Just sit here twitting my thumbs. No. I bought this for a nas because 1) I love my old mycloud and 2) the price. I could of spent 20 bucks more and got a synology DiskStation DS220j and 2 4tb drives. I was loyal to wd but unless they fix this I will never by another wd product.

A fair point.

Well. . .in the last year. . .WD had the SMR drive debacle; which resulted in the “Red Plus” and “Red Pro” product lines. So there is that.

But frankly. . . how much new hardware do you need for a NAS? Frankly - - - the hardware that is in place NOW is pretty much “good enough”. If you crank up the CPU or RAM in these devices further. . . my view is that you may as well go a head and buy an I5 desktop and use it as a server :wink:

So in the NAS game. . .I think at this point it is ALL about the software. . . . which to be blunt has some serious issues.

WD’s flagship product PR4100 has internals similar to Synology 916. While Synology has introduced 918 and 920 and 922 next year, WD hasn’t refreshed its product lineup since PR4100. While I personally like build quality of WD over Synology, incremental updates to their product lineup do tilt the balance towards Synology. I see a lot of cost comparisons, WD’s 30% cheaper than Synology. Correct comparison would be PR4100 against DS916 (if you can find any).

Synology’s OS is obviously generations ahead of OS3 even before WD shot itself in the foot (and all its customers) with OS5. There’s something called beta testing, and no it doesn’t mean release a half-baked product to users and then grapple with the fallout, if that’s WD’s definition. At least Synology is taking its fair time with DSM7 testing before release.

Back to the original premise, if WD isn’t focused on new product/refreshes and given the legendary OS5 ■■■■-up, question is what are they really doing? Or have they simply outsourced their engineering teams to the cheapest service providers and mistaken technical support for actual development?

Is JOBD supported by OS5? I hade OS3 and it worked fine, after the upgrade no volumes are configured anymore, so I don’t access anymore my data!!! How such thing can be possible? And from the panel I don’t see JOBD option. I suppose and hope that my data are still in the disk because I dind’t recreated any RAID volume after the OS5 upgrade!

@lballetta yes JBOD is supported in My Cloud OS 5.
Are the drives used, shipped with the My Cloud EX2 Ultra or were they sourced from a different NAS and inserted into the My Cloud?

Either way, please collect the system logs, send to support and let me know your case number.

I bought a new WD NAS without disks.
I inserted the WD disks into it.
I setup by panel though the wizard of the OS3 application, and everything worked fine.
I used the NAS from Windows 10 and also moved some data into it.
After all this, I upgraded the firmware.
It worked fine and the OS3 still worked fine.
After I tried to discover the App mobile usage, and it was asked to upgrade to OS5.
I logged in the OS3 My cloud Panel, and clicked into the OS5 upgrade.
It was successful.
I’ve immediately seen the Volumes as not anymore configured.
From there here to search a resolution, but I see a lot of customer claims.
Even if I would create a Volume the panel as you can see doesn’t show the JOBD or Spinning options.