Transmission client isn't available

i setup a Transmission client on a Raspberry Pi.

i recovered config and stats from OS3 Transmission backup on the NAS with ssh:


and partially settings.json

then fstab to mount NAS directory on Raspberry.

@Jumbo333 can you make a YouTube video of this. :innocent:

Not a youtube video but i can explain in details here !

First a Raspberry with Raspbian (or other distrib) installed and setup it with ssh activated.

  • install on it Transmission :
    sudo apt-get install transmission

  • Stop the client Transmission :
    sudo /etc/init.d/transmission-daemon stop

  • Configure settings :
    sudo nano /etc/transmission-daemon/settings.json
    ( you can recover some settings from WD EX backup settings.json)
    Some settings to change :
    “download-dir”: “/mnt/Transmission”, ( for mounted share WD EX on Raspb )
    “rpc-authentication-required”: false, (if you don’t connect tu Transmission GUI with user/pass)
    “rpc-port”: 9091, (by default)

  • Mount WD EX folder into Raspberry with fstab
    sudo nano /etc/fstab

  • add a line for each folder in fstab (i user folder “Transmission” )
    //192.168.x.x/Transmission /mnt/Transmission cifs username=USER,password=PASS,uid=pi,gid=pi,x-systemd.automount, 0 0
    (change USER and PASS with your permission on the NAS)

  • (optional) - i use also openvpn for privacy when using Transmission
    sudo apt-get install openvpn

NAS WD with ssh activated to recover Transmission config files.
location of the file are explained in my previous post.

  • i used zip to archive the files (torrents and resume directories and file stats.json) and copy the zip on a shared folder on the NAS.

  • Copy the zip on a usb key for example and connect it to Raspberry.

  • unzip the files on raspberry and copy it into :

  • Change the permissions on the files copied :
    chown debian-transmission stats.json
    chgrp debian-transmission stats.json

  • Ditto for files in torrents/ and resume/

  • Now start the client :
    sudo /etc/init.d/transmission-daemon start

  • Go to :

Enjoy ! You have restored all the config of OS3 Transmission client !
The Raspberry client use the files on the NAS.

Thank you for explain.
Of course we can use addition servers for make some a solution.
In this way why we couldn’t use FreeNas?
We waiting solution from WD. ASAP!!!

1 Like

FreeNas is intended for x86 architecture, not Arm

1 Like

Your’e right. For Rasperry it can be OpenMediaVault.
It doesn’t matter.
Wer’e purchased solid sollution - WD MyCloud EX. And finaly I can’t use some services… It"s unacceptable.

1 Like

i’m agree

After I bought this EX2 Ultra, I wasn’t able to use Transmission until they updated the app because most of the trackers I use didn’t accept the only old version of Transmission the NAS was offering back then. If we have to wait so long… guys, start thinking about buying another brand NAS. I was waiting for WD to update the app almost a year.

1 Like

Everything work great until this update. I only check changelog and notice Transmission app 2.94 was on the list of supported apps so I done update. If i knew I never done system update to OS5. This is unfair! They cut out best application and live
I demand information when Transmission app will be available on Ex2 Ultra!


I agree

Yeah. I could read that Emule would not be supported anymore, but no specific information about transmission. What a failure!
Is there any email address for complaining or something like that? Maybe we should make some pressure on WD. I don’t think they read these posts.


i wait about 1 week, if not update for transmission, my ex2 ultra is warranty, i return it and i go to buy a synology !


so many views so many replies, but not even heard by WDmy cloud management, they just wasted the money of many people. Its really disguting. worst ever update by WD.

1 Like

any method for downgrading the update?

After the debacle of sql access to outside clients, I changed mine for the Synology. No regrets; have docker support, can now run deluge w/vpn, pihole, etc, and more configuration options that weren’t easily allowed on the EX2. Just saying.


Afraid there isn’t. Well not that I’ve uncovered so far. First bullet in support page, bold red letters says it’s a one-way option.

I spoke with WD support by chat abaut Transmission and “never ending flie indexing”. They promise update soon as possible. I think they aware of bugs.
My file indexing ends right abaut our conversation finish (4 days) :slightly_smiling_.
If I correct understand any interruption, disconnection, restart make file indexing strat over from begininng.
I wait few more days and see what that update brings in.


i wait 1week and if they’re not solve problems, i’ll backup my datas and return my ex2 ultra and i’ll buy a synology.


Just managed to get it up and running after a bit of research, whether or not it’s functioning as intended or not is another question but so far so good. Will update if I run into any issues.

I’m using the PR4100 and used the method suggested by @akanoodles ~ docker install and pulled latest image.

1 Like

So, I have successfully downgraded from OS 5, to OS 3. It took some hours of trial and error to find that nothing worked as easy as it should have. In the end, the resolution was to destroy the root file system, which makes the machine boot into safe mode. Once in safe mode, OS 3 installed and rebooted pretty as you please, and all functions have returned to normal while data remains intact on the NAS.

root@MyCloudEX2Ultra # cat /proc/mtd
[ 1.224605] 0x000000000000-0x000000500000 0: “U-Boot”
[ 1.230172] 0x000000500000-0x000000a00000 1: “uImage”
[ 1.235582] 0x000000a00000-0x000000f00000 2: “uRamdisk”
[ 1.241139] 0x000000f00000-0x00000c800000 3: “image.cfs”
[ 1.247693] 0x00000c800000-0x00000d700000 4: “rescue fw”
[ 1.253357] 0x00000d700000-0x00000eb00000 5: “config”
[ 1.258813] 0x00000eb00000-0x00000f500000 6: “reserve1”
[ 1.264386] 0x00000f500000-0x00000ff00000 7: “reserve2”
root@MyCloudEX2Ultra # nandwrite /dev/mtd3 rootfs.cfs (extracted from OS 3 bin file)
Writing data to block 0 at offset 0x0
Writing data to block 1 at offset 0x20000
Writing data to block 2 at offset 0x40000
Writing data to block 3 at offset 0x60000
Writing data to block 4 at offset 0x80000
Writing data to block 5 at offset 0xa0000
Writing data to block 6 at offset 0xc0000
Writing data to block 7 at offset 0xe0000
Writing data to block 8 at offset 0x100000
Writing data to block 9 at offset 0x120000
Writing data to block 10 at offset 0x140000

[ Truncated to save space ]

Writing data to block 790 at offset 0x62c0000
Writing data to block 791 at offset 0x62e0000
Writing data to block 792 at offset 0x6300000
Writing data to block 793 at offset 0x6320000
Writing data to block 794 at offset 0x6340000
Writing data to block 795 at offset 0x6360000
Writing data to block 796 at offset 0x6380000
Writing data to block 797 at offset 0x63a0000
root@MyCloudEX2Ultra # reboot

After rebooting, the status light was flashing blue, and the HDD lights flashing red and blue. Loading the webui, shows the device is in safe mode and request the fw file to be loaded. At this point, it does not check to see that the fw is at least OS 5, which allows for the downgrade of the OS back to OS 3.

After initial setup and enabling SSH, I am now prompted with the following:
BusyBox v1.20.2 (2019-07-04 10:46:34 CST) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.
root@MyCloudEX2Ultra sbin # chk_fw_ver
old firmware ver:
new firmware ver:
—tok_old:[1] tok_new:[2]
model name:MyCloudEX2Ultra
chk_fw_ver: flag=[1] cmd=[ -p]
Orion is set for the Production Server::
root: hostname=MyCloudEX2Ultra

root@MyCloudEX2Ultra sbin # read_version -a
firmware version: 2.40.157(
u-boot version : U-Boot 2013.01_v1.04 (Aug 20 2015 - 11:11:32) Marvell version: 2014_T3.0p6
mcu version: 1.06

root@MyCloudEX2Ultra root # dmesg | grep mtd
[ 7.857491] UBI: attaching mtd5 to ubi0
[ 7.918004] UBI: attached mtd5 (name “config”, size 20 MiB) to ubi0
[ 29.432354] UBI: attaching mtd6 to ubi1
[ 29.525170] UBI: attached mtd6 (name “reserve1”, size 10 MiB) to ubi1
[ 30.737081] UBI: attaching mtd7 to ubi2
[ 30.772039] UBI: attached mtd7 (name “reserve2”, size 10 MiB) to ubi2

root@MyCloudEX2Ultra root # cat /proc/mtd
dev: size erasesize name
mtd0: 00500000 00020000 “U-Boot”
mtd1: 00500000 00020000 “uImage”
mtd2: 00500000 00020000 “uRamdisk”
mtd3: 0b900000 00020000 “image.cfs”
mtd4: 00f00000 00020000 “rescue fw”
mtd5: 01400000 00020000 “config”
mtd6: 00a00000 00020000 “reserve1”
mtd7: 00a00000 00020000 “reserve2”