[GUIDE] Upgrade a working My Cloud to a bigger HDD (easy steps)

Hello!

I just upgraded My Cloud (1st gen) from 2TB to 4TB and it worked flawless.
Let me share here. Someone might want do the same process :slight_smile:

Important: If your device is dead or with failure this guide is not for you. In this cases search for “unbrick” or take a look at this folder: GDrive WDMyCloud posted by @Fox_exe

:nerd_face: Important Note: It has no guarantees. Do it at your own risk :nerd_face:

Ok. What you need before you get started:

  • 2 usb sticks (you can use 1 if you reuse it - gonna take more effort)
  • working My Cloud
  • new bigger hdd
  • working PC with 2 SATA ports
  1. Download Clonezilla: alternative stable (Ubuntu-based)
    Select: file type iso
  2. Burn Clonezilla iso to your usb stick. I have used Rufus 3.8
  3. Use your second usb stick to create a Ubuntu Live USB
  4. Remove HDD from your My Cloud
  5. Remove all HDD SATA connections from your PC (to avoid data loss)
  6. Connect your original hdd and your new bigger hdd to your PC (sata connections)
  7. Plug your Clonezilla USB Stick and boot your PC.

On Clonezilla Menu Select:

  1. Clonezilla Live (Default settings)
  2. Your language and keyboard
  3. Start_Clonezilla
  4. device-device work directly from a disk
  5. Beginner Beginner mode
  6. disk_to_local_disk local_disk_to_local_disk_clone
  7. Choose your SOURCE as your original My Cloud HDD (Caution: DOUBLE CHECK this STEP!)
  8. Choose your TARGET as your new bigger HDD (Caution: DOUBLE CHECK this STEP!)
  9. Start clonning (confirm yes twice)
  10. Go take a coffee. In my case it took 3hours to copy 2TB to a 4TB hdd
  11. After finish turn off your PC

.

  1. Unplug your USB Stick and remove your old hdd from your PC (keep your new hdd plugged)
  2. Plug your Ubuntu USB Stick and boot your PC

.

Open Gparted

  1. Select your HDD (should be something like: /dev/sda or /dev/sdb). Take a look at the hdd size as reference
  2. Right click on your 4th partition (should be /dev/sda4 or /dev/sdb4)
  3. Select resize
  4. Expand your partition to use all “unallocated” space
  5. Apply settings (Say “yes” if gparted asks to fix anything)

Finals steps:

  1. Shutdown your PC and remove your usb stick and your new hdd (now you can reattach your SATA connections from your PC)
  2. Reassembly your My Cloud with the new big HDD
  3. Turn it ON and wait for blue light.

Note: your original My Cloud HDD is untouched, so your can reassembly it back if your new big HDD didn’t work

Have fun! :four_leaf_clover:

2 Likes

Thanks for the Guide … i have an older 2TB WD My Cloud which i was thinking about doing this to one day :slight_smile:

1 Like

Going to give this a try on a shucked 12TB white label WD Elements drive from Best Buy’s US Black Friday $179.99 sale. :grinning:

Finally got CloneZilla to work at cloning to a new larger drive. In my case I wound up having to put the existing My Cloud drive and the new one in USB to SATA enclosures then perform the clone. For some reason if I used my PC’s SATA ports CloneZilla would throw errors.

Yeah that’s right. That is not a typo. 22 TB’s of free space.:grinning:

The My Cloud has an internal 12 TB drive and a second 12 TB drive attached via USB. These two drives will be going into a better NAS enclosure hopefully soon if Synology enclosures go on sale during Black Friday/Cyber Monday.

3 Likes

Thanks for sharing the process. Good Job @Proglin !

I had been procrastinating on upgrading my measly 8TB My Clouds to 12TB for ages and now I can begin anew on knowing that it is that much easier and it is just taking the time to do it. I’ll begin my new procrastination today and perhaps one day… bookmarked for some future endeavour :stuck_out_tongue:

Well that answers the question whether or not a 12TB drive will work on a My Cloud!

Good job @Bennor!!

1 Like

@Ralphael
These 12 TB WD White Label drive came from a shucked WD Easystore enclosure. The 12 TB WD Easystores are currently $179.99 at Best Buy (Black Friday deal).

https://www.bestbuy.com/site/wd-easystore-12tb-external-usb-3-0-hard-drive-black/6364259.p?skuId=6364259

Not sure what exactly these drives are though (WD Red, WD Green, WD Blue, etc.) as there isn’t much specification information out there (basically none) about these White Label drives. Best Buy’s website claims these are 7200 RPM drives, yet Crystal Disk Info shows them as 5400 RPM drives.

you lucky US dawgs! we don’t have those 12TB WD Easystores up here in Canada. The best I can do to get some 12TB drives is through ebay and those are currently retailing at $329 Cdn.

They use to have Hitachi drives in those WDs and it might just be a rebranded hitachi since there are not too many 12TB drives around or maybe its a rebranded Green drive with extra platters since it is a 5400 rpm drive. Best Buy info is always wrong or at least copied from another WD drive. I doubt that WD would put a 7200 rpm drive in any USB unit simply for the reason of heat; my guess.

Nice though. 12TB is 12TB period no matter what colour drive it might be and those USB 3.0 read writes are pretty sweet.

Wow! Nice work @Bennor: 24TB a huge upgrade :slight_smile:

I know this is an old topic. but need some help.

I upgraded my WD Mycloud with an 8Tb drive following these instructions. All went well, and I can access files and shares over the network. I can even ssh in. However the web UI isn’t working. Upon reboot I can log in and see an “initializing…” popup that never goes away. After a while the UI is unreachable. It’s like the server crashes, but I don’t know what log file will have any relevant info to see the error. Again, all else works perfectly, including share or ssh access once the UI is down, so I know it’s not a network issue.

One troubleshooting step if you haven’t done it already, try performing a 40 second reset.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

1 Like

I follow your steps (My Cloud Gen 2, 2TB to 4TB), but every time I boot with my new 4TB expanded HDD, it begins with blue light and after some minutes, ends with red light. [This part is solved: Ethernet cable was not connected, that is why it blinked red]
The only difference I see is that my partition 4TH is not the one to expand, but the 2ND of SEVEN partitions (showed as my last partition on HDD).

After accessing to web interface, it shows “no RAID devices” and lately “Convert to JBOD”. What’s happening?

As a troubleshooting step. Have you tried a 40 second reset?

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

Many, many thanks!!! It worked. I had Thank you very much. It worked after doing what you suggested. I had read the method, but I was afraid of losing the NAS configuration and then not being able to access it. After a while, the light was blue and I located the IP of the NAS.

I accessed it and instead of RAID, I chose JBOD (I think that for my use as a media centre it is the most suitable).

However, it has been formatting for more than 10 minutes (it is a 4TB disk) and it does not go beyond 10%, although the light is still blue …

I’ll wait a few hours to see if everything is OK :confused:

No way. After cloning, fixing GPT and resizing partition, I access log in Web application of my My Cloud. It ask me about language, set password, timezone, analytics privacy, etc and then, in a page that tells:

" Almost finished - setup RAID volume
Lastly, your device does not have a RAID volume set up yet. We’ll guide you to setup a RAID volume for your device.

Your setup will be completed after this. Enjoy your My Cloud!"

I click on “Next” (the only one button) and then a new page appear with:
" Configure RAID Mode

  • JBOD
    JBOD Configuration

The use of one or more drives not in a RAID configuration but managed as separate logical volumes.

Switch to JBOD"

If I do not select JBOD, then I can’t continue (“Next” button is not enabled). But once I enable “Switch to JBOB” and then click on “Next”, the process seems to go well:

" Configure RAID Mode

Warning:

  1. Changing the RAID mode will erase all of the data on the drives listed below.
  2. These drives will not be accessible while the RAID array is being created.
  3. Drive Self Test (DST) is performed prior to creating the volume(s).

Drive1 4 TB Drive Self Test 10% …"
And the test continues to 100% without issues, showing “Good”
“Next” button again, only with information:
“Configure RAID Mode
This section provides a summary of the configuration you just created. It will show the volume name, file format, disk size and disk array number.
Volume_1 JBOD EXT 4 3996 GB Drive1”
“Next” again
" Configure RAID Mode
Switch to JBOD|
||You are about to re-format the hard drive(s). All data will be erased. Do you want to continue?|"
“Next” again
And a last page showing:
" Configure RAID Mode

Be patient while the WD My Cloud device partitions your drive. Do not turn off the NAS at this stage.

Partitioning"

But it’s the 5th time I tried I repeat ALL steps (including cloning) and always stayed stucked at “10%” or “18%”.

Any idea?
Thank you

Perhaps try using Fox_exe’s directions for unbricking your My Cloud if you haven’t done so already. I assume it’s a second gen v2.x single bay My Cloud. If it is not a second gen v2.x single bay unit the following directions likely won’t work. Start from scratch with the new/larger hard drive. And as another troubleshooting step, one may also want to check the hard drive in another computer to ensure it doesn’t have any issues (SMART errors or bad sectors).

User Fox_exe repositories:
Main Repository: https://fox-exe.ru/WDMyCloud/
Second Gen: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
usbrecovery.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate method files:
uImage-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery
Latest second gen firmware: http://support.wdc.com/downloads.aspx?g=904

The HDD is a brand new disk. Has no errors. Never used. I buyed it for this.

Yes, it’s a second gen one.

But I have a question. My NAS works fine, is not bricked. I can use it with my default 2TB. Issue is just when trying to use a new one (4TB) HD following steps of cloning, etc. So, therefore, I am hesitant to apply the alternative methods you kindly suggest in the links. I suppose that these methods involve changing the firmware on the board, and that if it fails, it won’t be so easy to return to the “normal state”, as it is now, that I just plug in the original disk, and everything keeps working.

Am I wrong in thinking that these alternative methods can effectively make my NAS stop working for good?

Yes. The firmware is installed to the hard drive not to internal memory of the My Cloud backplane/motherboard. If you have any issues just put the old/original working drive back in and the single bay/single drive My Cloud should boot up.

Unbricking or cloning is just two methods to accomplish a similar end goal, putting a different drive (with the My Cloud firmware and proper partition/format structure) in the My Cloud enclosure. It is possible the unbrick procedure will fix issues that are introduced by cloning a smaller drive to a larger one.

Hi Rafael. You may try as troubleshooting:

Redo all the steps until step 18.

Than skip to step 27 to check if you “new HD” can perform as the same as the old one.
Your mycloud should boot up and show exactly the same infos as the old one in the dashboard.

If this is working you just have to go back to step 18 and continue to Gparted and expand the biggest one partition to the unallocated space.

Good luck :slight_smile:

Fantastic! Knowing what you’ve told me, I can experiment with the options you’ve told me about without fear of losing the possibility of having a functional NAS again (albeit a 2TB original one). I think I tried one of those options (partitioning with “mkpart”) but it didn’t work. I’ll try again.

Thank you Proglin

I think, by accident and being sick of trying, I once did the cloning and put the hard disk in directly, with the difference that I did the 40second reset, and the boot ended up with the LED flashing red.

I will try as you say (without doing the 40 seconds reset) to see what happens, but after trying the alternative methods of “unbrick” (cloning takes me more hours than trying the “unbrick” mentioned by Bennor :wink: