DLNA media serving: Why have all my WD Mycloud external shares disappeared from my smart TV?

Hey guys.

Anyone else find that after the firmware upgrade you have lost all access to any additional shares added per usb?

All was working fine up until the recent FW upgrade. Works fine on my Androif devices and windows PC’s using the WD App, however I used to be able to pick up all my media from the 4 drives connected via  USB powered hub on my Samsung Smart TV. Then today after the FW upgrade had taken hold, zippo, nada except for the preset public shares in the WD.

Am I the only one with this mischied about? Any thoughts on it?

I have rebooted, powered down, reset the shares, turned off media sharing at the share level and at the system settings levels and then turn back on. Nothing! Very disappointing WD, it was working and i even got around the network dropping out with static IP in my router outside of the DHCP range. I’ve only had mine three weeks and you are making me wish I had gone for the Seagate option instead.


As a recommendation, try performing a system only restore following the steps on the link below.


Please note that the system only restore wont erase the information.

I tried.
Waste of time!
More work than you need, and the effect is the same. My Sony Bravia W8, does not see connected to the WD My Cloud portable usb drive.
Any solution, hint?
The biggest mistake was “the great” upgrade.

Thanks for the thoughts, I’m prepared to remain positive that it can be solved and that WD will come through with a fix.

Some other thoguhts as I’ve been trying to understand why it is that when I use the WD apps and when I access the WDMycloud through my network I can pick up all the attached drives, though when I try to picke them up using the DLNA media server functionality, as soon as I attach anymore than one external drive to my powered hub, they just drop out completely.

Then it struck me that the media serving is undertaken by Twonky Media Server rather than it seems the WD interface stuff. So that has me now thinking it is something to do with how the Twonky MS is identifying the shares and it seems just having a meltdown as soon as you try to attach more than one external share. I’ve done little more than access the WDMC Twonky Media Server and had a quick browse at settings, though I’m new to it and will have to play around to see if my limited ability can figure something out.

WD would be real happy if you could fix this as I’m still hanging onto hope and putting my trust in you guys coming through.

I must add, how ridiculous behaves Cloud.
I have a 1TB WD Elements connected to the USB port in the Cloud.
I have two partitions on it, about half the disk capacity each.
My computers see them correctly.
UI WD Cloud sees them as 180GB and 32GB. Is not that interesting?
My Sony W8 does not see them at al !!!.
After spending five hours and a total waste of time, the following of instructions WD staff , the situation has not changed.

God bless the new firmware!
Yes! I’m sarcastic and angry that I trusted suggestions sent to me! 

People from WD, read and think about those who pay your salaries by buying equipment and trust the information that you send to them.
Solve problems that you have created!!!

I got the same problem. Media streaming only works when i connect only one drive. Does not work when connecting more than one drive. Tried everything in the last 2 days (system restore, reboot, tweaked Twonky media sever settings). Nothing works. Wasted my weekend trying to fix it. Very frustrating.

Clearly the upgraded firmware is unable to handle multiple external (USB) volumes/disks.

If it worked in the last firmware and not in the new firmware, then the only real option to you is

downgrade the firmware to the previous version, WD should of provided you with this information.

Or wait for WD to release a fixed firmware (think month(s) away).

Hi rubikcubic - Does WD allow downgrading or do we need SSH to downgrade? I am a noob at this, not very sure of the process. Any help is much appreciated.

This is discussed in earlier thread so look down the forum. There is mention of download the previous FW and renameing it to a higher firmware version, then use the WD dashboard to manually apply firmware in the settings section.

The ssh method is a little involved, but is outline in a previous thread as well. …search for firmware downgrade message thread or transmission guide for ssh method towards the end of that thread.


Hi PVS0705.

Did you manage to get that FW rolled back? If so has that sorted your issues with volume recognition?

I’m a bit hesitant to try.

I have the same problem. I have two USB drives connected via a USB 3.0 hub. I usually connect by Windows shares with my WDTV boxes, this still works. I tried connecting my TV using media server and both drives were missing. I guessed it was the recent firmware update, now I’m sure. I can connect one drive it works fine. I can tell by the number of files that the DLNA scan finds but If I connect the second drive the first one disappears. Windows shares still works so I’m not dead in the water but I would sure like it to work as it was advertised. I’ve been using WD products for years, I love the WDTV boxes, but this product has disappointed me. I’m looking for a way to down grade the firmware. I usually turn off auto updates for this reason but didn’t think there would be a problem like this.

Hi all.

Just thought I’d provide update, that whilst I’m still no closer to a solution, I have been contacted by WD support to try to sort it out. Latest is that an attempt will be made to replicate the issue we are having with the DLNA media serving to smart TV’s and the dropping out with more than one external drive or volume.

Shouldn’t be hard really, so hopefully we are on a path to a solution.

Good on ya WD for following up. Now if we can have a solution asap, that would be even better.

Zooloo (Australia)

Hi Zooloo - I tried to downgrade by renaming the previous version to version 4.0… and do a manual firmware upgrade as mentioned in one of the posts but it did not work.
I also received a email from WD support team but I did not respond back to them yet. I was very busy the last couple of days. I will reply today after work and see how it goes.

When you go to the Twonky server settings, under sharing, can you see that the server is listing the shares correctly? If not, can you add them manually?

To access the settings, add :9000 at the end of the IP address of your NAS. eg:

Hi Etupes - I did have a look at the Twonkey settings. The shares were listed correctly. I tried unchecking the shares and recheck them again but it made no difference.

The firmware is terribly buggy so that everything is possible.

Some fans (or employees) of WD will tell you that their MyCloud is fast and does perfectly work, even with the latest firmware :flushed:

Others will tell you to try this and that, and in rare cases it might help, sometimes only for a few days.

You could as well do more morning gymnastics because this will reduce your frustration.

The only fast solution: Give it back for a refund and buy a product from dedicated NAS manufacturers:



Well I’m very happy to Ignore Max Miller or whoever you are…same message from your pseudonym LinAdmin45 per private message on Friday…not the smartest troll under the bridge you’d think.

The rest of us choose not to be victims and rather work towards a solution, not worth your while to spend time here, you’ll get no traction as this will be the only reply I will give.

1 Like

Taking time but had call from support and have sent on log file for analysis. I had a look at the Twonky sharing again and when I have 2 externals they show as shares in twonky. Sounds fine. However when I had the server rebuild the database it chugged through the mycloud shares quite fine though did not recognise the two external shares. I tried the same with only one external. This time it chygged through the mycloud shares and sweetly continued with single external. I don’t know enough about how this all works. Though seems to me that the issue is narrowing down to the Twonky MS not being able to scan more than one external.
WD this surely cannor be that challenging.

Ok WD, I have been patient I have provided you with what I am seeing and a copy of my log. Yet the silence at getting a solution is astounding.

When I paid good money for your promised produst, thats what I expected a product that delivered what was promised.

Yet now almost one month form when I purchased it, I’m still trying to troubleshoot and you seem not to be that interested in helping yoru users. I tried yesterday to copy a large amount of data using the usb3 port, started at about 40mbs then dropped to a stable 2mbps!!! What the heck is that about guys. I tried again using my PC and the USb3, then it dropped to 1mbps!!!

Today I started a full factory reset, that was some 11 hours ago, I get home and…its got to only 32%…you have got to be kidding guys!!

It’s going back tomorrow due to false advertising and an oveprromise on what it can do. It should work perfectly out of the box, no troubleshhoting required. I’m not a complete techie, but I do know a few things more than most and the effort this is taking is just so uncalled for.

Sorry guys, I have the rest of my life that I need to get on with.