503 Service Temporarily Unavailable

Help! i woke up this morning with this message (503 Service Temporarily Unavailable) and i cant sing in to my cloud.


All My Cloud Home and My Cloud OS 5 Services are DOWN

you can check it here



looks like a global issue … this is happening since at least 20 hours


Same here too. I thought is my network problem. After i reset all my network still same.


This does not affect accessing the files locally. One alternative is installing GoodSync for free in the NAS so you can use explorer in your cellphone remotely.-

1 Like


I’m experiencing this issue as well. Could you elaborate more on how to use good sync to see my files? I’ve installed it on pc and OS but I don’t see anything coming up. I’ve been using the iphone app, mac app and local server/app access on my PC for years and have never had issues until now. I get it this is a WD issue right now but just want to be able to access files as I don’t have a male to male usb cable available right now if that would even work? Thanks.

Update so after writing this is showed up on my iphone goodsync app but I tried to load it and it said timed out?

Have you installed the app on the NAS?

I am having the same problem and hopefully it will be worked out by todady. I am traveling and I will need to get into my files from the app on the phone.

Same here too since yesterday noon.

Of all the days this could be down today is not the best ;(

On the upside, my files are still being uploaded to my NAS drive.

Using my NAS for a timelapse camera so all good for that.

Anyone have any idea why or when is gonna be back on?

Only got the NAS drive last week, not a great start.

At first I though the service was discontinued but going by these posts it’s not

I’m need the file. How can I access the device If
503 Service Temporarily Unavailable

I will have to use teamviewer on a PC on the network. thankfully I always have a TV pc on.

Do you guys know when can this be solved?

I guess I’m lost at NAS? What does that mean and where do I install it? Thanks.

I also lost my network connetion to mycloud. Any ides, how to solve this?

Please tell me , when the problem will be solved? I have important data on cloud

WD under cyber attack…


1 Like

you can access it only if your using same network by typing the ip address or hostname in
(run) like double back slash (\ \ ) your ip or hostname then it will open for you all the folders

1 Like

worst cloud EVER , totally regret for pay a single pound on it :sleepy: :sleepy: :sleepy:

if u know how to login to it for all my data please tell me, or how to login remotely without app or maping network please tell me, i want to login as a network source with IP , once i write the ip address its login with username and password admin admin BUT not to my files , its for public files ONLY, i hate this device