Windows 7 unable to see WDMyCloud on network share

Hi everyone,

I’m new to this forum. I just purchased a 3TB MyCloud drive but I’m having a tough time getting my laptop to see the device. The problem is EXACTLY like  http://community.wd.com/t5/WD-My-Cloud/Windows-Cannot-Access-WDMyCloud/td-p/697802

However, the solution mentioned in that thread did not work! Here is what I’ve tried:

  1. Confirmed that network discovery is turned on

  2. Changed the Network Provider Order so that Microsoft Windows Network is at the top of the order (I confirmed this in the registry)

  3. Rebooted my PC, router, and MyCloud device

  4. Disabled my firewall (using AVG Internet Security paid version)

  5. Updated the latest firmware

  6. Confirmed that my network is set to Home Network

  7. Both MyCloud and my laptop are connected to WORKGROUP

I’m not sure why I have two “WDMyCloud” entries when i right click on it but in either case, there is No option to “Open”. I can see the MyCloud dashboard so I know it’s connected.

Ive been working on this for hours and have not come up with anything helpful. Any help would be appreciated.

Thanks.

GC

  MyImage.png

Welcome to the Community.

Can you access your WD My Cloud by using \wdmycloud or \itsIPaddress?

I have not used the network map but in file explorer 2 is normal, 1 shares & 1 DLNA

since you see it here it is on the network

what are you trying to do to access it?

in the address bar in file explorer enter \wdmcould or better yet check the IP that your router assigned thin ender \IPAddress see what you get

Hi Trancer, Yes, I tried connecting by name and ip and it did not work. I also did these:

uninstalled / reinstalled my Network Adapter

Reset MyCloud

Reboot MyCloud

No luck yet!!

Hi Larryg0,

Yes I tried connecting by name and IP without success.

I can ping the ip successfully!

I can access MyCloud through the dash board!

I can also acces MyCloud through the management console to create folders, create folders, add files, etc …

But I cannot connect to the share through file explorer.

AArrrgg!

weird.  Did you check if print and file sharing enabled? Do you have a firewall?

http://windows.microsoft.com/en-us/windows/file-sharing-essentials#1TC=windows-7

Yes, I did both. Print/file share is enabled according to Network Sharing page.

I have AVG (paid version) and it’s enabled there as well. Bonjour Services is an allowed app. I also added the WDMyCloud IP address to the AVG white list. I’ve also disabled AVG firewall through this whole thing with no success.

The ONLY thing I can imagine is that AVG  is preventing access to the share … because when I disable the AVG firewall and refresh my network, I will SEE \WDMYCLOUD show up as a share! The bad news is that I still can’t connect. I just can’t seem to prove my theory, short of uninstalling AVG completely in the hopes that this will work.

Grrrr.

AVG by defautl blocks these services. Probably you did this already AVG Control Center->AVG Firewall->Configure->System tab->" Microsoft file sharing and printing

I have AVG as well, althogu I dont use Wiondow much, here what I used to

* Open AVG User Interface.
* Choose the Firewall settings option from the Tools menu.
* Select Profiles -> your default profile (e.g. Standalone computer ) -> System services.
* Choose the Microsoft file sharing and printing service.
* Switch the System rule details from Block to Allow for all.
* Confirm changes by clicking on the OK button.

Im using AVG 2015 Internet security. I think the UI is a little different than what you outined but I think I got to system servcies (see attached image)

At this point, I’m not sure what to do. I dont see a Block or Allow setting and I’m hesitant to do anything here since I’m not sure what I’m doing…

thanks for any help!

click on this and see what options it gives you. It might say allow. To use it you have to allow it.

Alternatively you can temporary disable the firwall, just to see if it is blocking.

By deault firewalls and Windows itself block these services.

There seem to be a number of rules. No allow setting although the rule details say that the are allowed. But if the firewall is disabled, this should not matter right?

Here is a screenshot of what it looks like:

avg2.png

And WD support still has me resetting the router, MyCloud device after 3 days. I finally had to tell them I’m no longer going to reboot, restart, reset, power off any more devices. Very frustrating.

In the ‘AVG Internet Security’ screen shot on the first page, you highlighted ‘System Services’.  But I notice that, above that in the menu, there’s a ‘File and Printer Sharing’ menu item.  What options are available under that?

Excuse the daft questions: I don’t run AVG, and haven’t had network connection problems.  I’ve looked through my system notes, and the only time I’ve had to set file and printer sharing was to enable devices on my local network so see my PC’s disk.  The MC and PC are set to the same workgroup.

Your questions aren’t daft. The File Printing & Sharing allows you to enable/disable it. Here is the screenshot:

I’ve also confirmed that MyCloud and my laptop are using the same workgroup.

Try this:

press Windows key + R

type

services.msc

when it launches find at the bottom of the list the workstation service. This service maintains client network connection to remote server  using the SMB protocol.

Check the Status and Startup columns.

If iis not already running then run it, if it is restart it. see what happens.

Hi jamalaya,

Thanks for the suggestions. Didn’t work though. Workstation services says Started/Automatic.

Didn’t have IIS running but I added the feature.

Seriously, my 3 other laptops (2x Windows 8 and 1x WinXP) can see the share. They all have AVG installed and running. I can see all of the other laptop on the network.

This is purplexing!

Indeed Weird, one last thing … :slight_smile:

control Panel, network-sharing center, change adapter settings, clik on it and go to property, is the Web  Client installed and running (check services again)?

Are you saying that on your laptop your are unable to see this. See image below.

Does the WD My Cloud desktop app work on your laptop?

What computer were you on when you captured the image you are showing in your first post?

Posted by,
cat0w (USA)

Web client is installed. I’ve confirmed that the Webclient service is running (started/manual)

avg5.png

Hi Cat0w, yes. It’s strange. When I disable my FW, I can see WDMyCloud as a network share it acts as if it’s not there … I’m not able to connect when I connect by share name or IP address.

When FW is enabled, I’m no longer able to see WDMyCloud as a share. But I can still see my other computers on the network. I’ve been on the same computer through this entire post.

avg4.png