Troubelshooting My cloud doesn't appear on local network

Hello guys

I replace my laptop and I cant find again my WD Mucloud 8T on my local network in my place.
It’s happear as connected in the page but before with my previous laptop I can connect on it as HDD on network. I can’t anymore.
Now I’m on Win 10 pro. Before I was on Win 7.

Any tips ?

Check to ensure NetBIOS over TCP/IP is enabled, that the network is set to Private, ensure Network Discovery and File Sharing is enabled, and ensure the computer is connected to the same router as the My Cloud. See the following post, in particular Windows 10 Specific Method 1 through 6 for additional steps that may be needed.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

Did you place your new laptop in the same workgroup?

Have you tried rebooting your router and then your new laptop?

What is showing when you click on network? See image below. Click on, tap or activate image to enlarge it.

For more information about My Cloud use this link.

https://support.wdc.com/product.aspx?ID=904&lang=en

Dear Cat

yes it’s in the same workgroup
No I didn’t try to reboot everything but I can try.
Unfortunatly the icon of WDMyCloud doens’t appear when I click on network. It’s exactly my problem. :frowning:

Dear Cat
i already relaunch the My Cloud + the router + laptop. Still not working. This is how it is appearing on my laptop.

On the Icon frcjordan it’s just giving me the possibility to open the website or to connect on the Mycloud as Admin

Ant tips ?

Which My Cloud do you have, does it look like this ?

If not, and it is black then you need to go back to the WD Community and post your topic under Network Attached Storage for the device you have.

Yes sure
But we have also another one (DL4100) as it’s showing up :slight_smile: on my laptop.
Before I change my laptop I was able to use both and have access to both.

The Windows File Explorer View > Group By layout looks different than the default. Try changing the Windows File Explorer View > Group By to Category. It should then structure the icons by categories. For example the categories should be: Computer, Media Device, Other Device, Storage. One then double clicks on the My Cloud entry under Computer. Here is an example:

If you do not see any entries for the My Cloud devices under Computer then double check that; the My Cloud units each have a unique name, that each device on the local network are using the same local IP address range, that if using WiFi that it isn’t isolating the wireless network from the wired network, that each My Cloud has a static or reserved IP address, that NetBIOS over TCP/IP is enabled on the laptop, that the local network group for the laptop is set to Private, that File and Print Sharing is enabled on the laptop.

Try accessing the My Cloud using the My Cloud IP address rather than its text name. Sometimes one has to hit the “refresh” button in Windows File Explorer to trigger a refresh and have the My Cloud(s) show up correctly under the Computer category.

Also if using certain broadband provider routers one may have issues. The workaround is to connect the My Cloud to a switch. See the following WD Support document for more information:

https://support.wdc.com/knowledgebase/answer.aspx?ID=15086

And some have reported issues with their my Cloud using home mesh WiFi systems like; Google WiFi, Netgear Orbi and Ubiquiti.

I had the same issue when my Windows 10 did an upgrade. Contacted WD support and they sent me a link to WD support which solved the issue immediately: How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10:

Hope this helps others save a bunch of time. Costs me a few hours trying to figure this out!

Official Western Digital Representative

Hey there again, @glcaan99!

Actually, you could also try to configure the Max SMB Protocol to SMB3 as the WD My Cloud EX2 Ultra series should be supporting it and it’s backwards compatible with SMB2. In terms of data transport, it should give you a much better performance. Moreover, it could prevent any more issues with the file access locally or remotely.
Here’s an article from our knowledge base that can assist you with this configuration.
Here are some additional links that might help you get more info about the Samba protocols:

  1. Which version of the SMB protocol
  2. Samba3/SMB2

Good luck! Hope it helps.
SuperSoph_WD

I’ve tried everything, possibly and imaginable,I’ve tried everything I’ve googled. Even Microsoft Level 2 Tech, couldn’t find a solution. I was able to get it working by changing the SMB1 to SMB3 under the network settings. for MycloudEX2ultra. Thank you so much for your help!!!

We purchased new computers for our office and our WDMYCLOUD drive wouldn’t come up either. Did all of the suggestions above, nothing worked. Called and talked to “IT” support but after hours of phone calls, nothing. On a hunch, I went to DEVICE MANAGER and found where the WDMYCLOUD was. Right click on it and UPDATE THE DRIVER from online. Boom, it showed up immediately after the update. Hope this helps someone else!

1 Like

I have registered to say THANK YOU! Purchased a new computer and was unable to find my MyCloud on the Network, although it worked fine on other devices. Such a simple solution, but yours was the only place I could find it.

Thank you, CoastCash. Thank you from the bottom of my soul.

This is definitely the issue people!! I had the same problem… Went through every option trying to figure out why my Network icons were not what they should be for the My Cloud Device… Sure enough, it was just so simple… I went to the Device Manager in the Control Panel, Found the My Cloud Device, right clicked and selected Update Driver, Restarted my PC… and Whala. PERFECT NOW!!!

Ignore all this other mumbo jumbo and skip right to this and you will save yourself some aggravation and time! Good Luck. I know it’s frustrating!

Disabling MU-MIMO (Advanced -> Advanced Setup -> Wireless Settings -> Enable MU-MIMO) on Netgear Orbi fixed the issue for me.

Hello,

I have a strange issue. After following and configuring exactly same settings on my three pc in same lan (same workgroup, enable smb feature, enable netbios over tcp/ip v4, driver update in devmgmt.msc) my wd mycloud ex2 is visible on only one system at a time under Networks while its not visible on other systems. After I shutdown that system where it was showing earlier, my cloud ex2 start to show on another random system but not on another powered up machine. When the shutdown second system it start showing on third system. I rebooted all my systems, my cloud ex2 as well as my router but issue remain the same. Has anyone using multiple system in LAN has seen or faced similar issue. If yes we’re you able to resolve it.

Please note wd mycloud ex2 is also configured in same workgroup as the three systems.

Kindly advise.

Note, there is a dedicated subforum for the My Cloud EX2 where users more familiar with that device may be able to assist.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2/109

Couple of things to check. Make sure the network type in Windows is set to Private. Make sure to set a static IP or reserve an IP address for the My Cloud. As a troubleshooting test disable any security/antivirus software. Depending on those software settings they may interfere with local network access to other devices. As a troubleshooting test put a network switch between the My Cloud and the network router. Check the local network configuration. Are all the computers using Ethernet or WiFi? Or is it a mix of wired and wireless. If a mix does the issue present across both wired and wireless devices? If using WiFi ensure Client Isolation isn’t enabled within the router’s WiFi settings. Ensure all devices, including the My Cloud, are using the same WorkGroup name and are all within the same IP address subnet.

Thank you Bennor for replying. All Machine network type is set to Private and File sharing is enabled. WD My cloud IP is reserved on Internet router config. I am only using default Windows Defender Antivirus. tried disabling it but still the same. Unfortunately don’t have a separate network switch device to place between mycloud and internet router however my Router is also acting as switch and has 4 network ports connected to two of my machines as wired and third port to wd mycloud EX2. Only one system is connected using WiFi. All machines and mycloud is in same workgroup and in same IP subnet. It appears on only one system at a time and after I power down that machine it appears on another one system but not on another powered up system.

The only thing I see missing in your list is, reboot the router. Try that and see if it shows under Network. If that does not work.

Tried rebooting router as well. No luck. I can see mycloud ex2 under Network on only one LAN system at a time. Only after shutting down that system it appears on another LAN system.