Windows 10 Network Doesn't See My Cloud

Just did a clean install of Windows 10 but for whatever reason, My Cloud doesn’t appear in the network listing.

Check The Windows 10 Network and Sharing settings. Sometimes Windows will set the network to Public which blocks local devices, if this is the case change it to Private. Also make sure Network Discovery is turned on

Do a restart of your computer and then see if it shows up under This PC. See image below. Click/Tap or activate image to enlarge it.


For the cloud to show up you need to be on the same work group. Windows 10 default work group is “workgroup”. What work group is the Cloud on?


It’s set to Private and Network Discovery is turn on.

Both are on workgroup.

Tried everything but still no joy. Because the W10 was a clean install, I had nothing to lose by doing a reinstall. Oddly, enough My Cloud is listed in the Network page after the reinstall.

Can you access the My Cloud via it’s IP address?

Every once in a while on both my Windows 7 machine and Windows 10 machine I have to hit the “refresh” button within Windows/File Explorer after selecting Network to get the My Cloud icon to show up.

I had that also after updating to W10 Pro version 1511, build 10586 or the just released update but I lost my whole network. Turned out to be the fact that I had Hyper-V enabled which I don’t use anymore causing the issue. Removed the feature, etc. and all is back to normal.

I wish I could figure out why all sudden I have this problem on one computer. Network discover is on it was working before the Fall update for Windows. I thought maybe the Fall update install went bad but I tried a clean install and the problem is still there. My other computer that also updated seems to be able to see the my cloud. If I map the drive either using the ip or its name it maps and works. But in network under computers it never shows up.

I’m running into the same issue following the November update for Win10. I have a specific folder on MyCloud mapped - that hasn’t been broken. A quick search shows that the update has affected the ability to “see” other NAS drives.

I did find one possible solution - launch Credential Manager and delete the related credentials for the NAS, and search for the drive again. Haven’t tried this yet (I’m at work), but will when I get home.

Have you tried to troubleshoot your My Cloud. Click in the Cortana box and type in devices and printers. If your My Cloud shows up do a right click on it and then troubleshoot… Maybe this will help. See image below. Click/tap image to enlarge it.


Windows 10 with November update (10586.3) is unable to see samba devices in the local network. It’s because it is using SMB 3.11 protocol by default. This problem is described here:

SMB 3 cloud be disabled by following commands (in elevated command prompt):

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

Then reboot

This fixed system Error 1231 when I attempted to run a “net view” from the command line, but disablig SMB 3.11 also disables opportunity to make windows image backup to My Cloud NAS.

Or you could self upgrade the My Cloud samba? :stuck_out_tongue:

SSH into and:
sed -i 's/max protocol = SMB2/max protocol = SMB3/' /etc/samba/smb-global.conf; service samba restart;

Then refresh your explorer wait till the shares can be populated. Or review in elevated prompt:
net view

To: Mcube

Are you saying mine should not be seeing it, because I have the November update. I haven’t had any problems with my My Cloud.


Just to add, mine completely disappeared from the Network view (Explorer->Network) right after the 1st Insider Preview builds.

Thanks for proposition Nazar78.
I’ve tried upgrading samba but it didn’t change anything in my case, netiher max protocol = SMB3 nor max protocol = SMB3_11 (this value is invaild).

Still net view ends with an error 1231 and My Cloud is not recognized but accessible after typing address.

To cat0w: Do you have windwows 10586.3?

I just noticed the same problem. None of my computers or NAS device were in the network section on file explorer. So what I did was open network and sharing section. go to change advanced sharing settings. Turn on network discovery was checked. Turn on file and print sharing was not checked. So I check file and print sharing. I also unchecked turn on network discovery and then checked it. saved the changes and now all of my devices are visible in the network section of file explorer.


Edit: Worked for a while. Now gone again.

I found this on the web. The following web site has a possible fix. I tried it and after the reboot my devices were visible. The netcfg -d seems to help.

@Mcube I’ve checked the logs. Yes you’re right SMB3_11 is an invalid value, only possible highest value is SMB3 for smbd. Think I set to SM3_11 out of curiosity but never double checked since My Cloud is showing in the Network area. But SMB3 value is still invalid for winbindd. However with mine set to SMB3, after all my network devices including MyCloud rebooted, I can now see My Cloud in the Network area. Previously with SMB2 it disappeared which initially I though because of NetBIOS. Mine is Windows 10 Pro 10.0.10586. You could try @rac8006 findings if it helps.