MyCloud Home not visible on network to Windows 10 computers

I’ve installed a WD MyCloud Home device on my network, but I can’t see it in the Network folder or when I try to map a network drive on any of my Windows 10 machines. I’ve given it a fixed IP address and it is visible to the router and to Androids Cx File Explorer app. I can map a drive if I give the fill name (e.g. \MYCLOUD-xxxxxx\Public. I’ve tried rebooting the computers, the router and the WD MyCloud home drive, but no luck

I’m running the latest Windows 10 with all updates installed.

Anyone have any ideas please

User Manual: My Cloud Home and My Cloud Home Duo (westerndigital.com)

Got that - doesn’t help at all. I say again, I can’t see the device when opening the Network Folder on a Windows computer.

Also - the app only shows my personal space, not the public area

Opposite here, can see public share in Windows 10
but nothing else, nor can I log in to my account as password changes fail. tried 30 times today.

You probably need to turn on Windows network discovery and turn on Windows features options of SMB1 support.

You probably need a successful update to the latest firmware update from your local WD server.

Tekram - already done that - I can happily see an older NAS which needs SMB 1.0

How do I get the latest firmware update - I’m in the UK. Does it happen automatically? WHat is the latest version so I can check

OK further to this. I’ve just reinstalled Windows 10 home on an old laptop and applied all the updates through to feature update 21H1 (which is what my current PC is at) and the WD device is visible on the network. SMB 1.0 is enabled, although the network network windows says “File sharing is turned off”. Turning on File and network discovery doesn’t change anything.

On the PC where I can’t see the WD drive on the network I have the same settings - SMB 1.0 enabled, network discovery on.

Any further ideas or help would be greatly appreciated.

I see from the support page (WD Support) that I have the latest firmware version 7.15.1-101 which says “Fixed an issue that may have caused some devices to appear offline”

I’ve rebooted the device, however, I still can’t see it. What else do I need to do?

You would need to change lmcompatibilitylevel. There is a simple 4 line registry fix.

And I do that how?

And let me chuck one more thing in here
I’ve just reinstalled Windows 10 Pro on a laptop and I can’t see the WD device on the network - so it seems like there’s something with Windows 10 Pro that is causing the issue as Windows 10 Home sees the device fine.

Does that help and of you WD techies?

I just installed the WD EX4100 on my home network along side a nice D-Link 4-drive NAS that is no longer available to buy and has more limited capacity in the BIOS, and have found that the documentation and setup process from WD are not a lot of help. Even with my 50+ years working with computers, it took two support calls, the first being an hour 45 minutes to get the device working and twice allowing them remote access from Delhi, India . We’re using Win 10 Pro and Win 7. I haven’t tried mapping from Wind 7 yet.

The net-net for me is that this device is maybe overly complicated if you just want local network sharable data storage. The support software used to configure is not intuitive, and the 120-page manual is not easy to use.

There is some misunderstanding here. The WD EX4100 NAS you have has nothing to do with My Cloud Home (MCH) that is the topic of this subforum, you should probably head over and concentrate on the OS 5 subforum. In contrast to the OS 5, the MCH is still using OS 4 which is a hybrid Android and WD proprietary file system OS and functions very differently from the OS 5 in that there is no OS 4 share level security on the LAN samba access which is unavailable to share files on the internet. The OS 4 proprietary file system (kddfs) is available for sharing on the internet but has file level security such that every file access required authentication with the WDC authentication server. That is one reason why the kddfs is slow and the MCH will not function without a working internet.

Many of the functionality of the MCH can be set up in 10 minutes in most home network without reading much of the manual and that works for 95% of the owners, at least for a while. It is when complications inevitably arise with the network that home owners throw in the towel, throw a fit and threatened legal action - in some cases justifiably.

Well, I beg your pardon. But the documentation for this device does in fact call it WD My Cloud EX4100. It’s possibly not a good name for it, because the term ‘cloud’ implies a relationship to the buzzwords ‘cloud computing’ usually indicating off-premises storage, that really has nothing to do with your local network device, but I didn’t name it.

Rick Coffman

Ó¿Õ¬

“Fact-checking” is the process of finding

someone who agrees with you.