Western Digital, Please get your act together!

Just got a notification from WD that a new firmware version (2.31.195) is available for my 2nd gen MyCloudand that I should update my device. Checked to see what firmware is currently (auto)installed - 2.31.204!

Is it really that difficult to get these things right? My other electronic devices never get their BIOS/firmware updates out of sync.

Be warned, check your current firmware version before (down?)grading.

How were you notified that there was new firmware?

Also note that this is mostly a user to user support forum WD rarely interacts with the users here. There are many comments directed at WD that almost always goes unanswered or fixed in the firmware.

This is the e-mail:

(noreply@mycloud.com)
To:you + 1 more Details
Following events are generated on your WDMyCloud .
Event title:New Firmware Available
Event description:A new version of firmware has been released. Update your system.
Severity:Info
Event code:1011
Event time:07-31-2020 05:23:12 PM
Firmware version: 2.31.195

Yes, I know it’s a user community but HP staff do monitor the forum and occasionally grace us with a response (or non-response).

Was the My Cloud restarted recently? If you received an email that means email notifications is enabled in the Dashboard > Settings > Notifications page.

I’ve seen weird things happen with my first gen when I enable notifications in the Dashboard (and have the notification level set to All) and the device is rebooted. It sometimes sends emails about past events. Almost like a a notification queue is resent even though it was previously sent. I chalk it up to more firmware coding issues of which there are many with this device.

It’s always connected and on but we do have intermittent power outages. However, this message I got today was not due to a reboot as I’ve been sitting in front of the computer for all of the afternoon. Yes, I do have notifications set to “On” which is why I got this (erroneous) message. Having said that, I don’t think the MyCloud just sends out random messages - it polls the WD servers for firmware update information and when one exists, it triggers the notification.

Maybe because it’s the v2.x firmware, it triggered on this from a day or two ago even though the single bay/single drive isn’t included and then goofed and indicated the older firmware.

New Release - My Cloud Firmware Version 2.40.155 (07/29/2020)

The only update I am aware of is this,

and it’s not for the single bay My Cloud.