New Release - My Cloud Firmware Versions 2.31.163 (01/08/2019)

WD is happy to announce the release of My Cloud Firmware 2.31.163 for manual download at [https://support.wdc.com/downloads.aspx?g=904&lang=en) for the following My Cloud products.

· My Cloud
· My Cloud Mirror Gen2
· My Cloud EX2 Ultra
· My Cloud EX2100
· My Cloud EX4100
· My Cloud DL2100
· My Cloud DL4100
· My Cloud PR2100
· My Cloud PR4100

2.31.163 Release Notes

Security Fixes

  • Added brute force attack mitigation.
  • Removed non-production testing information.

Components Updated

  • Rsync – v3.0.

Other Bug Fixes

  • Added warnings when enabling remote dashboard.

2.31.149 release notes

Security Fixes

• Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 2016-10107.
• Resolved multiple cross site request forgery (CSRF) vulnerabilities.
• Resolved a Linux kernel Dirty Cow vulnerability (CVE-2016-5195).
• Resolved multiple denial-of-service vulnerabilities.
• Improved security by disabling SSH shadow information.
• Resolved a buffer overflow issue that could lead to unauthenticated access.
• Resolved a click-jacking vulnerability in the web interface.
• Resolved multiple security issues in the Webfile viewer on-device app.
• Improved the security of volume mount options.
• Resolved multiple security issues in the EULA onboarding flow.
• Resolved leakage of debug messages in the web interface.
• Improved credential handling for the remote MyCloud-to-MyCloud backup feature.
• Improved credential handling for upload-logs-to-support option.

Components Updated

• Apache -v2.4.34
• PHP -v5.4.45
• OpenSSH -v7.5p1
• OpenSSL -v1.0.1u
• libupnp -v1.6.25 (CVE-2012-5958)
• jQuery -v3.3.1 (CVE-2010-5312)

Other Bug Fixes

• Resolved high CPU utilization with ufraw-batch process.
• Improved remote host port handling

1 Like

I installed the update without any problems.

image

1 Like

Hi, I assume it is for the Gen 2 MyCloud (not the ones running Gen 3/4 f-w)?

The V2.x firmware is ONLY for the second generation single drive My Cloud. It will not work, and cannot be flashed/installed on the first generation V3.x/V4.x single drive My Cloud.

Is there any plan to release f-w for Gen 1 (4.x) devices? Or are they EOL?

Apparently the first gen v4.x My Cloud units do not have the same security vulnerabilities present in the second gen v2.x firmware. It appears this update was just to fix (some/many of) the security vulnerabilities present in the v2.x firmware. Its been over year since any new firmware was introduced for the first gen v4.x My Clouds. And apparently, for some time now, the single bay My Cloud units are no longer being sold at retail in the United States.

Hi

Thanks.

I just got my brand new PR4100 and installed the latest firmware after setup. Now, when I try to install an app manually it does nothing.

Tried a manual install using WD guidelines for issues and downloaded the binary file.
After downloading the .bin file I loaded that to install and then it said installation failed!!
Please help WD!

I have MyCloud v2… . Automatic update don’t finding this update. After downloading, and trying to update manually, everything is ok till the updating process - it’s freezing at 0% and nothing happening. Restarts etc don’t help.

Be careful this new firmware disabled your ssh, and doesn’t possible enable again. Secure issues :frowning:

1 Like

Same for me, automatic update is not finding the firm and Im not sure to make the manual update really…

I found that, WD cloud desktop for window cannot be use anymore after the firmware upgrade.

Others have complained about that issue of the Desktop program not working after updating to the latest firmware. Bottom line is, unfortunately, WD Desktop has been end of life for a while now (couple of years). It appears WD wants we users to use MyCloud.com/

The WD cloud desktop app for windows did allow me to login, it finds my drive but then says that it has an error connecting, gives another login prompt without the ability to type in a user id and does not recognize my password, then it shows that it finds my drive on the network, and repeat same error.
I really wish they would support this app it worked great previously and faster than using an old internet explorer program since it’s not compatible with Microsoft Edge.

The WD Desktop software if end of life, WD apparently won’t support it any more.

The workaround is to use a supported web browser with the MyCloud.com web portal.

MyCloud.com supports the following web browsers:

  • Internet Explorer
    
  • FireFox
    
  • Safari
    
  • Google Chrome

Hi,

I am on firmaware 2.30.181 (2.Gen. device) and my desktop app on Windows 7 works. I can login and access my files? Why?