WD My Cloud Unable to access device (0)

I installed WD My Cloud app on my Nexus 4 and I was able to connect to the cloud on Wi-Fi, but I’m getting “Unable to access device (0)” error when I try to connect on 3G/4G. Anyone knows what the problem is?

Hello,

Did you created your account to access remotely?

Check the link below on page 54

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf

Yes, I did. I was able to Add Device on my phone, but when I click on WDMyCloud, I still get the same error.

2013-10-12 01.56.22.png

Before I re-added the device on my phone, I deleted the cloud device from the web site app, 192.168.1.69/UI, and now it says “New Unregistered Device” instead of showing my phone as if I didn’t use the code, but I did use it on my phone when it asked to activate it and it actived it successfully. I tried this many time, still no luck.

website.png

Under Settings / General / Cloud Access, what is the “Connection Status?”

It says “Connected”.

virtz wrote:

It says “Connected”.

Under that, it should say HOW it’s connected.

Mine says “Port Forwarding connection established.”

How about yours?

It says “Port forwarding connection established.” on mine as well. Any clues?

Try deleting the app and the unregistered device on the mycloud page. Now reinstall the app and re-register it.

I deleted the app and the device (by the way, I was able to get rid of “unregistered” when I added the device via Wi-Fi), and re-installed the app and re-added the device successfully, but I still get the same error when I am on 3G/4G. It works fine when I’m connected via Wi-Fi though.

I talked to the WD My Cloud support just now and the guy told me that I need to call my ISP and ask them to open ports 80 and 443. I have Comcast internet and based on www.grc.com web site, all the ports have status set to Stealth. I can’t believe that this is what every person who purchases WD My Cloud does to access the cloud outside home network. I’m not feeling safe opening those ports to my network either. Can anyone confirm that this is normal?

My ports being used for remote access don’t show Stealth mode…they show “open.”

Do you have another device on a different carrier that you can try?

The carrier would be the home ISP, wouldn’t it? I’m with CenturyLink/Qwest (for now) so I may have to look into this too. I had trouble with File Transporter earlier and ended up sendin it back because it wasn’t consistent. Never looked in the direction of the ISP for help. Any ideas on how to check which ports are open before contacting the ISP?

dbourne wrote:

 Any ideas on how to check which ports are open before contacting the ISP?

The link mentioned on post 10 of this thread will do it…

I had to return the device because of awful WD support. I called them several times during last two weeks, but they would either give wrong solution telling me that it’s guaranteed to work or transfer me to the wrong person where I get disconnected in between the calls and they would never call back, though they ask my number every time before talking about the issue. Once, they closed my case without resolving the issue and I had to open a new case for the same. Then, they figured out that I need “level 2” assistance, it took a week before they contacted me after I let them know of the hours they can call me, but it was too late as I asked for a return. I’m sure they could resolve the issue as I didn’t see many people complaining about the same issue, but I hate being treated like this.

Good luck WD!

I had to go into my router and forward port 80 and 443 and then it would allow me to remotely access the drive away from home.

Can you tell us how you enabled them please

Did you solve the problem? i have the same situation here.

Ok, first post, I had the same problem, 4 days with the WD My Cloud, just problems and learning…any way, I was having the same problem, everything set up, I could access the drive over wifi without problems, but when I tried accessing it from the android app of my galaxy S4 over 4G I couldn’t access and the app showed me 'unable to access device (0)´

So here it is how I made it work, first you obviously have to add the user from de WD web UI; second, the problem is with your router, as someone mentioned above you need to forward port 80 and 443 and the most important part to do this is to enable UPnP from your router settings, Im not an expert in this but I managed to make it work. It depends on your router and its menu, I have a Linksys wrt400n, you access to the settings typing 192.168.1.1. Search for something like UPnP and make sure it is enabled (this was part of my problem).

Now search in your router settings something saying port or port forwarding and add those 2 ports (80 and 443, just select something like ‘from 80’ ‘to 80’, add the other one with ‘from 443’ ‘to 443’), on IP address use you WD my cloud IP address (the one you type to access to you web UI). Apply settings and wait 30 seconds your router reconnects. (im not sure if these step is necessary or if only enabling UPnP solves the problem, for me it worked like these)

Before doing these 2 steps I could get the code to pair the devices, use it in my phone and see my drive´s name on the phone but couldn´t access it and my cell phone appeared as an unregistered device on WD My Cloud UI, but after doing these my phone says connected (instead of showing a green symbol) and displays my email address (on My Cloud Web UI).

Now it works from wifi and from any device through 4G, it is a router problem, just enable the ports so that you can access your NAS from everywhere with an internet connection.

Sorry for my English, it is not my native language. 

1 Like

I was hoping to get it working after opening the ports, but it didn’t help. That’s why I was trying to contact WD so many times after that and not returning the device immediately. At the time, I checked if the ports were open by going to sites that check port status and they were open. Also, I has Asus RT-N66U router. I’m pretty sure it was some settings problem, which I will never know now.