Files.mycloud login down?

Does anyone else having blank page problem? I try to connect My Cloud via regular link but I see nothing but blank page. With different browser, same. Any suggestions? Thx

Yup, same where. Couldt’t happen in a worse moment: our office is closed due to covid outbreak and we need to access remotely the company NAS

perfect. yesterday I renamed a folder now it is gone. today since morning I can not login. What else? Still no connection. I reset everything modem internet connection laptop, 3 different browsers and still can not reach. Perfect…

Same results here for the past hour after attempts with multiple browsers

Nothing to add other than I am down as well, just getting the blank screen. I did manage to get the login page to show for a moment, but was kicked out once when trying to login and the second attempt I got a 504 Gateway Time-out error.

Attempts to login were tried via Chrome, Safari, Firefox, and Firefox Developer Edition.

As of 17:18 CET I manage to open login page however after my credentials I can not reach my cloud. same error mentioned above: 504 Gateway Time-out

Spoke to tech support and they are aware of the server issue. They did not give me an ETA on when it would be fixed.

2 Likes

could you please give me advice how I can contact with tech support. I renamed a folder. Now the folder is gone. I need to know how I can get it back?

WD’s customer support number is 1 (800) 275-4932 for the USA.
International numbers can be found at the following link.

Same problem here. If I can get to the login screen it just goes to a blank screen after I enter in my credentials.

I just got off the phone and they quoted me 2-3 business days.
I did manage to get one of my users in remotely, but it took like two and a half hours of constant refreshing. However, no other users have been able to get past the gateway issue.

I have the same problem. Also visible in MyCloud -> Access to the Cloud tab, I have: Connection status: unsuccessful. :frowning:
This is global problem. 2-3 business days??? Great !

If possible try using the My Cloud mobile app for Android/iOS. That should allow one to access their My Cloud remotely even though the MyCloud.com web portal is down/not working properly.

It works only if you are in the same network as a server, but remotely it also doesn’t works.

Am able to use the Android app on my cell phone using cellular data to access my first gen My Cloud. Could be because I have the My Cloud remote access manually configured (with router port forwarding).

My Cloud Dashboard:

My Cloud App on Android cell phone with no wifi connection, using cellular data:

Right, if (I suppose) you have static IP address.
In this case you do not require MyCloud services which are down actually.

It is down PC and Android. I just saw that WD techs are working on it, " MyCloud.com Disruption".

At this point (03/09/2020-21:53:00 e.s.t.) its been down for more then a day. this ■■■■■
I should have picked the other guy “Synology”

Look at this: http://status.mycloud.com/os4
ALL SERVICES UP AND RUNNING :slight_smile:
And time is going on…

I’m now getting this,