Access nil

I can access everything on my cloud from PC’s in my house, using finder on mac, it just appears on the left side of the mac. I can get onto the dashboard and see the drive.
But I cannot go to wd2go and see anything. I use the email address I used to setup, I have reset the password, but all I get is " No devices available " " Please notify the device’s owner, ( or admin user )
I can’t access it from outside my house, anywhere I try to access it gives me the above message.
The bumph said it was an easy setup - Sorry Albert Einstein is dead, he’s the only person who could figure it out, there are no instructions with it, it’s basically a 4Gb HDD and not a NAS

Sorry mis-read it at first…

For remote, make sure you set it up for remote access, refer to manual.

Manual ? what manual, it didn’t come with one !
It has now stopped letting me access it from anywhere, it appears in the side bar in finder, if I Cmd + Shift + K, it appears in finder, when I click on it it says connection failed…
Have now pressed the reset button for 40 seconds to do a system reset, rebooted mac & router, clicked the downloaded software short cut, and for the last 15 minutes I have had a spinning line with the words "Sit back while we connect to the device "

Google is a wonderful friend…

For access…
I do not use any of the WD software, so here is what works for me:

  • internet browser for dashboard access (http://my-devce-ip)
  • Windows File Explorer for accessing or map the share: \\my-devce-ip\
  • OS x Finder for accessing the share: Finder > Go > Connect to Server > smb://my-device-ip
    The above applies to just about any NAS from any vendor/brand.

You can also try it replacing my-device-ip by the name of the device.

If you learn to depend on the OS build-in tools, you will be efficient on any NAS.
Windows build-in backup software and/or robocopy command
OS x, rsync and/or timemachine

1 Like

new day, same problem…
Have now managed to get into the dashboard by typing the cloud ip address into google search bar. (needed google to figure that out)
Have done another complete system reset. gone through all the rigmarole of setting up again, only to be told I am already there…
Can see all my files through the dashboard,
However when I try to access from any mac through finder it says “Connection failed” and this is at home. I know that when I leave home and try on another internet connection I will not be able to connect there either, I never have been able to…
Wouldn’t it be nice if the manual actually came with the piece of junk, and in it were pretty pictures showing none techy people how to do it ! Save all these problems, and maybe the forums would be full of compliments, not headaches !!!

Did you follow my suggestion for OS x?

Look at the following link. http://www.mycloud.com/Learn/?language=en

cat0w
USA

That is described on the Quick Start Guide that is supplied with the device. It even distinguishes between the URL you need for Windows, and the URL you need for MacOS.

http://lmgtfy.com/?q=wd+my+cloud+user+manual

It would be nice if the Quick Start Guide pointed out that the User Manual exists, and provided a simple link to it, with the suggestion that users read it.

That probably isn’t the Dashboard. The Dashboard is the control interface for the MyCloud. You can see the Shares (folders) that are present on the device, but it does not provide a file browser.

OS x, rsync and/or timemachine
That was your suggestion ! What on earth does that mean ?
I bought this because it said it was easy !
I am no techy or savvy with code !
Please speak English, not gibberish !
No I didn’t follow your suggestion !

Yep ! Sorry that isn’t the dashboard. I downloaded the WD software, if I click on the short cut on my desktop I can access the drive, however I cannot access it from finder side bar or from anywhere other than this imac…
It sits in the corner a 4Tb piece of junk… I could of bought a 4Tb HDD that worked exactly the same as this because the only place I can access it from is this imac.
I downloaded the manual, went through everything in it ! Nothing works ! I can access it from the imac I used to set it up, but nowhere else !
Have raised the question with WD support, not holding my breath though as everything I read says they are useless…
thnx for any advice

Read every page, nothing that says helps. I can access from the WD software on my desktop on one computer and one computer only. No access from anywhere except the imac I used in the first place.

Watch this video and see if it helps any. https://www.youtube.com/watch?v=078xdmH1DiM

You are seeing only what you want to see and/or don’t understand. Yes I provided multiple options, if they are not familiar to you, google them. At the same time, I provided how to access the shares, which is what I thought you were looking for.

If you are mad at WD, fair enough. Just take into consideration all of us here, are not WD employees. We are end users just like you trying to help you. Forums are end user to end user assistance.
If you are looking for actual tech support, contact WD directly.

I watched this before I bought it, now it means less than before, bit of a motor mouth, says a loit but doesn’t explain how to do anything !

I am seeing what I want to see and/or don’t understand !
I see your reply but I don’t understand ! That is the problem I DON’T UNDERSTAND
I have googled the problem, that brought me here and the above statement is no help at all !
You provided how to access the shares, sorry I must of missed that post, I wouldn’t still be here if I’d seen it.
I am not mad at you, I am mad at myself because it is probably simple to Albert Einstein, but I am not Albert Einstein ! some people need it spelling out in plain English, that is what these forums are for, not riddles that only the writer can understand.
I have tried to contact WD, they haven’t replied, that is another reason I am here.
If you cannot offer reasonable understandable help to someone who cannot do it themselves, then don’t bother at all !
I am at the end of my tether with this heap of junk and considering taking it back to the shop it came from for a refund.
It is at present a hard drive, nothing more nothing less ! a NAS it certainly is not as I cannot access it from anywhere except the imac it first connected to.
Sorry but thanks for nothing !

If you can access the WD My Cloud Dashboard then try the following:

Log into your My Cloud with your web browser (eg. http://wdmycloud)
Select Settings from the home Dashboard page.
Scroll down the General Settings page till you see the section called Cloud Access.
Under Cloud Access, make sure Remote Access is toggled to On.
Click on Configure to the right of the toggle switch and select Auto if it is not already selected, then click the Save button to save that setting.
Next look at the line titled “Connection Status”. It should indicate if the My Cloud is connected or not and if connected it may list the type of connection (relay, port forward, etc.).
If it shows connected then continue, if it does not show connected then you typically have a problem with your router or broadband connection.
Next, click on the Cloud Access mention option at the top of the Dashboard page.
Check the Cloud Status section and ensure it indicates “Connected”.
Next while still on the Cloud Access page, select a User from the list on the left hand side.
Ensure the User is listed as having a MyCloud.com account. If not, select the Sign Up button and follow the on screen direction if any.
Next, using your web browser navigate to http://mycloud.com and enter in the email address and password you created when you signed up on the MyCloud.com.
Then, once logged into Mycloud.com it should list the shares on your My Cloud.

If you have any problems, start by accessing the Dashboard and disable Remote Access under Settings. Wait five to ten minutes, then re-enable it. If the Remote Access section indicates the My Cloud is connected, next try resending the registration email to the user’s email account and use the link in that email.

If you continue to have trouble with remote access, post specifically what the connection status indicates. For others to help they will need as much information as possible. For example:
Connection Status Connected
Port forwarding connection established.

In certain instances one may have to change the Remote Access Configure option from Auto to Manual, then access their broadband router’s administration screen and enable port forwarding of ports 80 and 443 to the IP Address of their My Cloud. For more information on how to port forward with your router, do a Google search of your router’s model + port forwarding, or see your router’s user manual.

You welcome!

Hi & thnx for replying
OK if I go to wd2go it asks for email & password, I enter this and it says no devices available. I have done a full reset and know my email address is correct, as it told me I already exist when I tried to re enter the info after the reset. have reset my password as well so I know that is correct.
if I enter the ip address I get to the dashboard.
In settings there is no “remote access” there is a cloud access, this is on, go to configure it is in auto…
I don’t have anything that says connection status, been through every page in the dash, nope not there !
Gone to cloud access at the top, nothing there to say connected or not.
There is and always has been only one user, and that is admin with no password. So let’s add a user. entered my email and password and now it let’s me log in to access the cloud, there is nothing in my shared folder but I can click on public and see the files now.
now rebooted macbook and logged in again, now have a connected notification when signed in as admin to the ip. However if I sign in as the user I just created all I can see is twonky, me. public & wdsync, not the full dashboard.
should I sack off the admin and make my email and password the only log in ? or can I do it first, make sure it works, then remove admin ?
Feel we are getting somewhere now, thanks for this, this is the kind of help non techy people need

What model/version My Cloud are you using and what is the firmware version? The firmware version is typically listed on the main home Dashboard page under Firmware.

On a v04.04.02-105 firmware single bay My Cloud below in the red box is what appears for the Cloud Access section under the Dashboard > Settings > General page. Note the Connection Status line which shows how or if the My Cloud remote access is connected and working.

Below is how the Dashboard > Cloud Access page looks and where it indicates its connection status.

When one connects through the Mycloud.com web portal they DO NOT access the Dashboard, rather they see a listing of the Shares on their My Cloud that they can access remotely. When one connects to the My Cloud using Mac Finder or Windows File Manager they are generally accessing the Shares of the My Cloud NOT the Dashboard.

If the My Cloud remote access isn’t indicating connected for a status then remote access through the MyCloud.com web portal most likely will not be able to access the My Cloud.

Hi,
It’s a my cloud, 4tb single disc, Firmware I updated last week when I got it, it is 2.11.140 and says it is up to date.

and here is what the connection status looks like

Now on my imac if I go to finder and click the WD it signs me in as a guest. Don’t know why but I seem to be able to access my cloud as a guest, but not myself… Weird