Cannot establish remote access

I have been having a great deal of trouble getting and keeping my devices and WD MyCloud to work properly.  I am hoping someone will be able to help. 

My network setup:

I have cable broadband service that has been providing me 27 Mbps (wirelessly) and 59 Mbps (if hard wired directly to the router).  From the modem, I connect to the router (Cat 5e). 

Router: Linksys WRT120n:

http://www.amazon.com/Cisco-Linksys-WRT120N-Wireless-N-Home-Router/dp/B0028N6VNW

From the router, I have my WD MyCloud attached to one of the Ethernet ports.  Attached to the MyCloud via USB is a portable hard drive I use to backup my WD MyCloud.

Since I have a two-level home, I also have the following to make sure I have connectivity throughout my home, including the garage since I have a treadmill that connects to the Internet:   

Engenius Outdoor Access Point:

http://www.engeniustech.com/business-networking/outdoor-access-points-client-bridges/16751-ens202ext

I use the Engenius as an access point to rebroadcast my Internet signal on the lower level of the home.  It is actually designed for external use, but the guy at the electronics store sold it to me anyway.  I have it connected to a Netgear Powerline 200 Mbps Adapter that plugs into the wall.

Netgear Powerline 200Mbps Adapter:

http://www.amazon.com/NETGEAR-Powerline-200Mbps-Nano-Adapter/dp/B006OOKT3Y/ref=sr_1_1?s=pc&ie=UTF8&qid=1409408099&sr=1-1&keywords=netgear+powerline+200

When I connect to the Internet at home on any device, I connect through my Engenius access point since the signal is the strongest.  However, when I am trying to transfer large files I cannot through my router via Ethernet for best transfer speeds.  My wireless network works great.  I can stream video on multiple devices at a time with no problems. 

Now for the WD MyCloud. 

When I try and access the Dashboard UI, it takes anywhere from a minute to several minutes to even view.  More time is usually required to allow all information to populate all fields of the UI (e.g. firmware, number of users, cloud access, etc.).  I currently have about 800 GB of data on the drive.  When trying to make a Safepoint, it takes literally 1.5 –

2 days to complete!  As far as Cloud Access from outside my network, I have been able to connect maybe 20% of the time.  The rest of the time it has displayed “Device Offline” errors.  In the past, the Dashboard has shown that I successfully established a connection through port forwarding and I am able to access my files without my network through cellular service (although usually slow).  Later on, my devices will again show “device offline” again! 

Below are some screen shots of my user interface of my WD MyCloud Dashboard:

OK, NOW FOR MY ROUTER SCREEN SHOTS

Hello, 

Are you able to test the unit using an static IP? this will improve your connectivity with the drive.

Another thing that you can check is the firewall of the computer or router to see if the connection is being partially blocked.

Hi there,

I’m new here and have the same problem as the main post, I bought my WD cloud 4TB a couple of weeks ago and I have it plugged in at home. I downloaded the desktop app in my computer at work and was able to access the drive without problems until earlier this week when I got a message saying there is a new version of the app which I downloaded and updated and I have not been able to connect since. Below is the message I get. I’m not sure what the settings on my router are but nothing at all has changed since the moment the cloud was set up to today. In my home computer I set up all the accounts, email addresses, etc, and all necessary settings for remote access are there… As I said, I was able to access this just fine before the update. 

I checked the device last night at home and it has the solid blue light (which according to the manual is how its supposed to be) and I can access the device from my two computers at home as well as my iphone when I’m joined to my home network. 

Hope anyone can give me a hand with this. Also, I am not an expert so would appreciate any answer/assistance to be given in basic terms (I’ve seen a lot of related posts talk about forwarding ports on the router and I have no idea how to do that). Sorry if you have to dumb down the answer for me.

Thanks in advance! 

I would not setup static port farwarding to a DHCP device, use upnp

the UI and possiably remote connection issues sound like load, if you are comfortable enable SSH and enter the commands below:

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

To put it in other words, assign a static IP address to your NAS using your router settings (typically in the DHCP section), then fortward the ports if you need to.

I forwarded ports for a while, then I simply relied on UPnP on the router and the auto settings on the NAS.

Hello ERmorel,

I am somewhat a novice to computers, generally speaking.  I am not really sure how to test using a static IP.  

I have a Macbook Pro.  Currently, my firewall is turned off.  

Hello larryg0,

I am not familiar with SSH and not comfortable with entering the codes in.  Besides, it gives a warning that it could void the warrantee.  There must be a better way.  The MyCloud has been basically plug-n-play for a lot of people, with minimal tweaking.  

in the network service screen shoot above change from DHCP to static

then it will either open a settings window or enable an option for settings

from the screen shoots above I can give you most of the parameters

IP address 192.168.1.160 (or anything outside of the DHCP range)

gateway 192.168.1.1 

netmask 255.255.255.0

DNS server, you need to determine this possiably from your router or from your mac, in windows it would be ipconfig -all, no idea for mac

I would also turn off the port forwarding in the router, upnp is already enabled. you could adjust it to the new mycloud address if you really want to use it

the commands I gave are pretty simple and completly reversable but I understand if you are not comfortable with it

if you do deside to try it changing stop to start & disable to enable completly reverses the change

stop & start do the running system, enable and disable controls the startup.

Thanks, Larry!

I was able to establish a remote connection using your advice.  I think what really helped was just specifying an IP address OUTSIDE of the DHCP range.  

I was able to connect with my iPhone with wi-fi turned off and only using cellular.  It should continue to work away from home  and in the future.  If not, I will continue to trouble shoot.

Thanks again,

Dave

Ok, I spoke too soon. It worked this morning. Later I left the house and it isn’t working. When I got home, it isn’t even working on my network.  

Back to the drawing board.

what is the exact status

front & back LEDs?

what are you trying to access it with on the home network?

can you ping the IP address you set?

1 Like

The LEDs on the MyCloud are:  Blue non-flashing LED on front, Green flashing and yellow on the back where the ethernet port is.  

I have been trying to access it using my 2014 Macbook Pro, which is hardwired directly into the router (also have tried wirelessly).  I am able to ping my own computer (Macbook) as well as the MyCloud IP I have set (which is set outside the DHCP range). 

I wonder if it is some settings in my router or MyCloud (or both)?  On the MyCloud, I have it set to Static IP and have it configured to an IP that is outside of the DHCP range.  On the router, I have it port forwarded to the same IP address as the MyCloud (TCP protocol).  At least that is as far as I know. I am no expert in networking!  

I am currently able to use my iPhone and the MyCloud app to access my files if I am on my network, but remote access is still denied “device is offline.”  

Your earlier post said it wasn’t working local or remote

did you do anything to fix the local access? please clarify

the lights indicate a good status and on a 100Mbps network

can you get into tha dashboard? if not reboot and try again then double check the IP settings. if local was always working ignore this.

the port forwarding could be causing remote issues, but not local

The local access wasn’t working and was not able to log fully into the dashboard last night, but a reboot of the WD MyCloud seemed to take care of that.  The vast majority of time local access works.  

The strange thing is that remote access was working (through cellular only) for a while, then stopped working.  Strange.  That makes me wonder if there is a minor setting on my router/mycloud that needs to be changed and it will always work.

Checking the dashboard now, it says cloud access is connected and port forwarding connection established.  However, I cannot get remote access to work on my cell phone. Must be on network.

Under cloud access tab, it shows all of my devices are “connected.”

Here are a couple of screen shots from my router.  “remote management” is disabled as shown on one of them. Should this be enabled?

Screen Shot 2014-09-05 at 3.41.52 PM.png

[update]

This morning, the remote access was/is working beautifully. Not sure why it has been working intermittently.   It would be nice if it will continue to work consistantly.  Hopefully, it will.  Time will tell. 

What are some reasons for the intermittent service?  

Hi Vjheroes,

I just wanted to get more imformation about your issue. Have you tried to restart your WD My Cloud? If that didn’t work… then when you want to connect remotely to your drive and can’t connect, are you able to connect through your iphone?

The new version of the app shouldn’t be the problem why you aren’t able to connect. In the worst case, you may need to remove the drive and reconnect. You will need to reconnect by using a wdmycloud account or a DAC (activation code).Please let me know if any of these resolved your issue.Regards

Hi Kaliuee,

I really dont know what the problem is here… after I posted my issue I came home and logged in using the WD My Cloud Dashboard app and in it I found that my work computer which I had used to remote access the drive was registered twice under my connected devices, so I removed both entries and the next day I was able to log in just fine at work. That was on Friday last week.

Now today I tried to log in again from work thinking my issue was fixed and I got the same freaking message again. Came home and used the Dashboard app and this is what I see

cloud access.jpg

However the internet is fine, I can access the drive fine from my computer via wifi (I have it mapped directly to my computer) and the main page tells me this:

network.jpg

I assume that means that the drive does have internet access, right? I also tested it by sending a notification email from the dashboard app which I received fine. Drive has a solid blue light and the router seems fine (router is a D-Link Dualband Wireless N750 Modem Router) and I have the driver connected to ethernet port 4 in the router. 

In answer to your questions, I have not tried to restart the cloud because I dont trust it, it took me 3 days to transfer my almost 1TB of data into this thing and dont want to lose anything. Also, whenever I am joined to my home network I can access the drive fine from my iphone using the app.

What I am looking into now is this whole port forwarding thing which seems to have helped other people with the same issue I have. I have no knowledge on any of this at all but will follow the directions posted in this community and see how it goes.

http://community.wd.com/t5/WD-My-Cloud/HOW-TO-Troubleshooting-Remote-Connectivity-Issues/m-p/617261#M1130

If there’s anything else that you can tell me that might help I’ll be very grateful. 

Update.

The whole port forwarding thing is over what I feel comfortable doing unless I have no other option so instead I tried the old fashioned “turn it off and then back on”… I basically turned off the cloud access, refreshed, then turned it back on, and now it seems to be connected… however, I have a feeling this is just a momentary fix and I’ll be back here tomorrow looking for answers.

connected.jpg

By the way, I checked my router settings and it seems it does support UPnP and it is enabled

upnp.jpg

and I also checked my network map and the drive is there and appears to be recognized by the router just fine with all internet connections there… Not sure what else to do…

Did this just start happening couple days ago? Did it work in the past?