WD My Cloud not accessible remotely via internet

Hi There,

Sorry if this seems very elementary, but I have no idea what is going on or how to change this… I have had this problem for several months and have been wondering around the support site and internet for ages searching for a solution.

I am running both a windows and mac laptop and the symptoms are the same. Every attempt to try and connect to my WD from anywhere but home is futile. For some reason I can never see the drive from outside my own network - iPhone included. As long as I am on the home network, it works.

Well, not always… If I do a reset of the drive - just off and on - I can connect to my drive from ‘outside’ for about 20 minutes, then it becomes a phantom. I have tried this from my neighbors house. I can connect from home network without a problem (via wireless) and not even moving the pc, but trying to connect via my neighbors internet, I can’t see the device. I have tried looking at the firewall settings etc etc etc, but nothing helps. My wife then resets the WD device and magically I can see it when using the internet from my neighbors house. This goes well for about 20 minutes, but then it disappears.

My WD is connected to my own network via a static IP (set both on the device and on the router) and this has never changed since I had the device (I tried a different router - but it did not solve the problem). I am not really sure when this problem started, but it was fine for a long time. Now its getting quite annoying, I got the device to access files when AWAY from home !
The WD has just been updated to the new firmware… but this has not changed the problem.

Is there anyone who can point me in the direction I need to look ? At the moment I am away from home and having to keep calling my wife to reset the drive is getting a little ridiculous !

Please help,


The My Cloud Dashboard > Settings section will indicate the Remote Access/Cloud Access connection status.

Sounds like you may have to configure the My Cloud AND your router for manual port forwarding. Start with the following WD Knowledgebase articles, then see your router’s documentation (or search online) for your router port forwarding procedure.



If you don’t know how to access the My Cloud Dashboard see the following WD Knowledgebase article:


This happened to me recently. I went into NAS Settings, and Cloud Access, and it was turned off. SInce I did not do this, I assumed either a reboot or FW updated turned it off, so simple matter to turn it back on to auto connect the Cloud Access again.

Settings are:

Cloud Access
Cloud Service
Connection Status
Port forwarding connection established

I have asked my wife to do what mike27oct suggested - via Facetime… It must have been very comical to watch a married couple trying to work it out this way ! LOL !
Anyway, remote access is turned on and the system says it is connected + port forwarding connection established.
From the home network my wife can access the dashboard: However, for me the WD website still says the device is offline. Until reboot - then it is fine for about 20 minutes. My wife is able to access the drive from her laptop, but not from her ipad, or iphone ? Yes, the settings have been checked…

I am now wondering if this could be a firewall or security setting from my ISP’s side ? Modem settings ?

I am open to suggestions !


yeah, probably port forwarding.

More than likely, the MyCloud is relying on uPnP to open ports as needed on the firewall, but then the firewall closes the ports while the connections are still open after a timeout. Will likely need a static port forwarding rule put on.

Thanks for the input !
Must be what is going on !
I will have to wait until I get home to rectify that problem. Not going through that Facetime ■■■■ again to sort this one out.
Will post when I get that done - after 21st June… wont be home before then.


отправленные с моего Агат

Peter, glad you got the Remote Access configured, and “Weird” must have the clue.

BTW, I can access the NAS with my iPhone and iPad; at home and remotely, so hope you get that sorted out, too.