My cloud cannot connect

I am currently away and cannot connect to WD My Cloud either from my laptop or iPhone - current message on iphone says device is inaccessible-  When I left home power and internet all operating correctly.  Is it me or the WD links?



Unfortunately, troubleshooting remotely is difficult. There are times when specific Wi-Fi security settings may prevent remote access, and this test can be performed by accessing the device remotely using your phone’s data plan as opposed to the current Wi-Fi network.

Could be the same problem I face here:

So far, they haven’t provided me a working solution. My temporary solution is to set up a “cron job” running on WDMC to automatically reboot the device everyday.

Hope they have a fix soon.

Same problem - What do we do? I work 200 Kms from the drive - I can only reset it on weekends. This is a disaster.

Thank you all for comments and support most posative but problem still not solved.  I was home last night reset My Cloud and BT internet and all worked whilstI was at home, away this evening and cannot contact My Cloud I am beginning to think this is a total waste of money and have purchased the wrong storage system.  

What really can be done as I am back home shortly then away for an extended period do I need to burn anything I may need onto a DVD?  Self defeating!!!  Fully agree with Okakanja