Connection status failed

I know I’ve had this working in the past, but recently noticed that in the MyCloud Dashboard, it says “Connection Status Failed” in the Cloud Access section of General Settings.


I can’t access the MyCloud using WD Sync remotely as a result.
I’ve tried port forwarding 80 and 443 on my router, and even placed the WDMyCloud in the DMZ to see if that changed anything. It didn’t!

My router is an ASUS DSL-AC68U. Anybody got any ideas on how to get this going?

Thanks,

Have you tried turning off Remote Access, waiting a few minutes, then turning it back on?

Also make sure to use a static IP address for the My Cloud (set or assigned through the router or configured manually within the Dashboard).

How is everything set up in your Dashboard. See image below. Click on, tap or activate image to enlarge it.

Yes, WDMyCloud is set up with a static IP address (assigned by router, not set statically in the WDMyCloud dashboard). Also tried turning it off and on again. The Cloud Access Connections are also set up to auto, but I’ve tried manually setting ports and forwarding those ports in the router. However, if I’ve placed the WDMyCloud in a DMZ, then port forwarding will have no affect.

I do have most of the media server features switched off on the WDMyCloud - would this have any affect? I presume not?

Thanks again,

I dont think that’s a good idea. Does it not mean that your MyCloud is not protected by your firewall. and is thus much more easily visible to hackers?

Your ISP may be blocking ports 80 and 443. In which case, set up a port forwarding rule for TCP/UDP traffic on ports 8080 (http) and 8443 (https), and configure the MyCloud to connect to the internet on these ports.

It does - I just put it in the DMZ to see if the router was causing any blockage. ISP isn’t blocking 80 and 443, and I tried 8080 and 8443 as well. Wondering if there is something just basically wrong with this WDMyCloud.

It is so simple, it works every time with me.

  1. Setting >> Cloud Service >> off
  2. NTP Service >> off
  3. Primary Server time.windows.com Configure >> windows time >> apply.
  4. Reboot your device
  5. Setting >> Cloud Service >> on

This also worked for me! Maybe rebooting periodically should be part of the next firmware upgrade?

SOLVED: Cannot Access Western Digital My Cloud on Windows 10 VIDEO

I stumbled upon this forum as i too were having the same symptom being brought up here. none of the solutions here help however i was able to find a video along with e a article that seems to at least get me able to access AND download my files from my drive using the browser interface. i made an account just to pass this along to you all.

Current Date/Time:March 14 2020 / 3/14/202

Method 1: Add a Windows Credential for your WD My Cloud account
The simplest and most widely effective fix for this issue is to simply add a Windows Credential for your WD My Cloud account to the credentials list on your Windows 10 computer. To do so, you need to:

  1. Right-click on the Start Menu to open the WinX Menu.

  2. Click on Control Panel in the WinX Menu to open it.

  3. In the Control Panel, locate and click on Credential Manager.

  4. Click on Windows Credentials.

  5. Click on the Add a Windows credential link in the top right corner of the list of Windows Credentials.

  6. Type the name you gave your WD My Cloud device into the Internet or network address bar, the username of your WD My Cloud account in the Username bar and the password to your WD My Cloud account in the Password. Click on Save.

  7. Close the Control Panel.

  8. Restart your computer, and when it boots up, you will be able to seamlessly access your WD My Cloud account.

Method 2: Fix the issue using Registry Editor
If Method 1 does not work for you, which is highly unlikely, this issue can also be fixed by editing your computer’s registry and adding a certain DWORD (32-bit) value to a specific key. To successfully gain access to your WD My Cloud account on a Windows 10 computer using this method, you need to:

PRO TIP: If the issue is with your computer or a laptop/notebook you should try using Reimage Plus which can scan the repositories and replace corrupt and missing files. This works in most cases, where the issue is originated due to a system corruption. You can download Reimage by Clicking Here

  1. Press Windows Logo key + R to bring up a Run

  2. Type regedit into the Run dialog and press the Enter key to open the Registry Editor.

  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation in the left pane.

  4. Click on the LanmanWorkstation key to display its contents in the right pane.

  5. Right-click on an empty space in the right pane, hover over New and click on DWORD (32-bit) value.

  6. Name the new DWORD value AllowInsecureGuestAuth.

  7. Double-click on the new value and, in the dialog that opens up, change its value to 1 and then click on OK.

  8. Close the Registry Editor and restart your computer, and when your computer boots up, you will be able to successfully access your WD My Cloud account without any issues.

Method 3: Network Reset
This method has been widely reported by users in the comments to have worked for many on Windows 10.

Hold the Windows Key and Press I
Choose Network & Internet

Make sure Status is selected in the left pane.
Scroll down and choose Network Reset, and confirm by Clicking Reset Now.

1 Like

Hello @dumarcm,
I am facing this issue from last few weeks. The Cloud Access service is not starting on my WD cloud device itself under the Dashboard. However, the fix you haev shown above is with connection issue from Win 10. I can access WD My Cloud from intranet (LAN) but cannot access it over WAN or mycloud.com account.

Can you advise if you had same issue or thats different case.

Also anyone can you please kindly assist as I am now very frustated with this issue as I cannot access my cloud machine remotely.

@WD_Admin - Can you please assist. I had called WD support few days ago. They troubleshooted for some time and then said they will send me email for further action with detailed insturctions to fix it but no one ever responded.

I have been trying to sort this issue for the last 6 hours. I cant access any media from my WD Cloud. I am assuming it is because the “Cloud Access Status” Connection Status - Failed I have tried all of the above scenarios to try fix this but to no avail.

I am new to this WD platform. My brother gave me his WD My Cloud as he was having issues with it. I have did a system factory restore yesterday (16 hours) which is a joke in its self!! I have then set up a new account in my name etc. All seems to be working. And I have put 1 video on the Cloud using the android app from my phone which is in mp4 format. I cannot access the cloud from my smart tv. I can see that the cloud is there visibly but I cannot access any media at all. I am assuming it MUST be this. I know I never paid for this but I was with my brother when he first purchased this…now for a product that costs a ridiculous amount of money, the software is completely bollocks!! Please can someone help me fix this issue before I pull out any hair that I have left!! :smiley: haha. Thank you in advance.

I am using firmware: v04.05.00-342 if that is of any use (latest firmware)
Am I better going back to an older firmware?

I have noticed many different layouts after seeing screenshots and MANY videos and it seems as if they have done away with a lot of better options.

I have just received an email from WD Customer Service and Support saying that they are experiencing some issues with the servers, thus the remote connection is not possible. So I have replied saying I hope it is fixed soon and asked if they would have a rough idea on how long it will take to fix. So when i get a reply I will let you all know. So probably isn’t worth while messing around trying to fix it like I have for the past 7 hours…the issue is at their end. :confused:

@F23RJR Thank you so much for this. I am just frustrated from last few weeks fixing this. Was about to do a full reset as per the instructions on WD site:
https://support-en.wd.com/app/answers/detail/a_id/3945#failed -> https://support-en.wd.com/app/answers/detail/a_id/7507

@F23RJR - Can you please share the WD support email address.

That’s how i first contacted them. They were only around 1 day before I got a reply. Yeah I wouldn’t try a full reset. Think it will be a waste of your time. Lets just hope they get their servers up and running asap.

Thank you mate. Let’s hope they fix it soon as been around this issue nearly a month.

Yeah I was getting the impression you have had this issue for a while. I have only spent the last day or so setting up the device. So from what your saying, they will not have this issue fixed anytime soon!! :cry: not what i was wanting to hear. lol

Hi guys

Just reading this thread because of having the same issue as about every wd user having done a firmware update…

don’t hard reset your device, the problems will remain! i already tried.

would be good if an older firmware version could be downloadable, probably that would help until the problem will be solved. but can’t find any old firmwares, any ideas?

Regards

Sascha

Updating firmware is not going to fix an issue on a remote server that you have no access to. Only Western Digital could fix it. MyCloud.com Disruption

That being said, it seems like the issue has been fixed. I am now able to remotely access the device using the website and phone app. Not sure if it is completely fixed or just temporarily up. Western Digital updated the status page https://status.mycloud.com/os3 yerterday to reflect that there is an issue.

It was not a port forwarding issue for me; as I had mine forwarded and tried to adjust the settings already. The remote access is working for me now. My ports are forwarded still; haven’t changed them for several days…

1 Like