Cloud Access - Connection Status : Failed

Please help me to connect my Mycloud to Cloud Access. :dizzy_face::pleading_face:

FYI, did anything change with your firmware version? I pulled the latest version from the website and installed it at some point in the last few weeks, then at some point there was a reversion because of an autoupdate that actually downgraded the firmware for me. Not realizing this, I scratched my head for a week until I realized the firmware was lower than the latest available (that I loaded before). Once I updated to this, it then just worked again for the cloud connection.

Its a network issue. Either Windows 10 or your router/cable modem settings.

@Bangge27
First troubleshooting step is to disable Remote Access/Cloud Access. Then wait five to ten minutes, then re-enable the option. Sometimes it’s as simple as that to fix connection status issues.

The following assumes you have your My Cloud connected directly to the main network router (or to a switch that is directly connected to the main router). Putting the My Cloud on AP routers or onto mesh networks may introduce issues. When possible always connect to the main router to avoid any possible issues with mesh networks or double NAT if using multiple routers on the same network.

Next, check the administrator menu or web page for your router and ensure UPnP is enabled. WD typically suggests having UPnP enabled even though it is sometimes seen as a potential security risk.

Next, in certain instances one’s broadband provider may block the default ports used by the My Cloud to access the WD remote access servers. In that case one may have to select the Configure option for the Remote Access/Cloud Access, select Manual and then use alternate ports (ones that don’t conflict with other ports/services). For example: HTTP: 8080 and HTTPS: 4443. When using the manual option one also generally has to set up port forwarding rules within their router to forward those ports to the My Cloud.

Cloud Access-Error 7

Help me to setting up my router. I don’t know how and what to do.
Also my router doesn’t have UPnP.

If I select the manual connectivity which is HTTP: 8080 and HTTPS: 4443. How can I set the port forwarding rules in my router?
Can you check my port forwarding settings?

I think you may need to setup port forwarding on your router. You need to tell your router to direct port 80 and port 443 to the 192.xx.xx.xx:80 and 192.xx.xx.xx:443 ports of your WD. If you don’t tell your router to explicitedly do this, then the traffic may be going to another device on your network.

Can you teach me to do this. I dont know how to set it in my router. This is my router Port Forwarding.

That is more or less it in your post. . . you will need two entries; one for port 80 and one for port 443.

I am not familiar with your router, but the “Wan Host IP Address” would be the WAN address assigned by the ISP to your router. I would not expect you to provide that address in this window.

Is this correct?

yes.

FUnny; the wan ip will get reset regularly by the ISP. And if it is not YOUR wan IP. . . .then it isn’t coming to your router. I can’t imagine why your router is asking for this info.

This “WAN IP address” is the same with “Wan Host IP Address”?

Already added. But still not connected.


I know little about your router. . . but it looks like the second column “name” and “protocol” may be swapped? You have a name “HTTP” using TCP protocol. Shouldn’t the name “HTTP” be using HTTP protocol?

I have no idea what the “Wan connection” setting is about.

What is the make and model of your router? Those don’t look like typical port forwarding rules entries. But then again it could be a custom ISP/broadband provider interface.