Cloud Connection Failed


Sometime back I noticed that My Cloud is not connecting to the Cloud Service with following message:

Connection Status: Failed
Cannot establish remote access connection. Make sure you are connected to the internet.

I am able to access the device through LAN and TV and the internet is also working fine.

Tried few steps already suggested online but no success.

Please advise!

Haha as ever, every month their servers are down by end of the month. Nothing can be done.

Thanks. If so why does their cloud service status show as up?

Bcoz as per WD history they take 2-3 days to update on service status. They only update when they are about to fix the issue to show that the issue was resolved in 24 hours to hide their failures.

Ok thanks. Hopefully they fix it ASAP!

You MUST report this to WD. So far all the indications are they are not acknowledging the problems with their Servers / Software exist.

At this time I can connect to with both of my WD My Clouds, 1st and 2nd generation. My Dashboard shows relay connection at this time for Cloud Access.

I did a 40 sec reset because of the intermittent cloud status between failed, and relay connection. Now I can’t type in email address under admin profile, it’s error - undefined. I can’t type in my email under sign up/in to admin access. I spent the whole night reset my drive and my router mulitple times, checked the firmware version, checked time zone, deleted, reinstalled iphone mycloud app, read community comment on topics on email undefined error, played around with something called DHCP, goole DNS, and UPnP on my Fios router. (BTW, I don’t know what DHCP, DNS, UPnP stand for. I use my drive for pictures, and movies for my family.) You are telling me the problem is at their end…

I just want to be able to enter my email address back to admin profile, and mycloud access…

1 Like

i got the same problem!!!

I have 3 of these gen 2 and 2 faces the problem of input email which gives me an “undefined” error.
These 2 i reset it because of 1 due to full restore and another due to Cloud access turn failed. Now my last one which is working fine last night also faces with cloud access turn failed.

Now i am totally without cloud access. These storages are now behaving just like a NAS.

Guess i got to depend on my vpn or router port forwarding to access my data remotely

So i guess there is nothing on our end that cause it.

Just go to wait.

There is no surety about the days. However I remember that WD took almost 15-20 days on one occasion however fixed in 2-3 days on other occasion and this happens almost every month end since March. You can visit and see it yourself. and they will only update about the outage on this page once they will resolve the problem to show that they have fixed in 1-2 days.

I just manage to register the emails for my two affected MyCloud. However , the cloud access status turn to failed shortly for all mycloud drives including the earlier untouched ones. So i am still out of cloud access. Guess i just got to wait…

That’s a start. Thank you for the update. I was able to enter the admin emails too. access is back online. Fingers crossed.

Yup! Cloud service access is working now!

Still not getting the sign in page here in the UK :pensive:

Seems resolved.

able to connect to My Cloud drive remotely.