Transmission client isn't available

me too got the same issue

I think I have found out the way it works. I didn’t know what exactly vi was when @Alex_AAFD told me. After checking the link out a second time, I know it is a kinda text editor for command lines. So, the complete process is…

  1. open terminal in MAC and write “ssh sshd@192.168.1.xxx” (device IP)
  2. write ps and look for Transmission directory
  3. go to the directory: cd /mnt/HD/HD_a2/Nas_Prog/Transmission/config (in my case)
  4. write in the prompt: vi settings.json. (if you want you can use “ls” command to see the files in it)
  5. look for “rpc-bind-address”: “127.0.0.1”
  6. change the number by hitting r while the cursor is over the character to change, and then write 0. The same for. “7” and press x for “2” and “1” in order to delete them
  7. Save the file by writing at the end of the file :wq (first press escape a few times)
  8. restart the service as @iqboss suggested: pkill -HUP transmission-da
1 Like

anyone know how now i can install MC (midnight commander) on new system (5.0)?

and how to Permanently on this option https://i.imgur.com/dHZ4isF.jpg ??

I am not professional user, this too complicated for me…

WD, please fix this!

Why not working this on OS 5?

I hope WD fix and improve the problem with Transmission. However I am happy with OS5 in general terms. It improves a lot the performance of my NAS. It is much faster and I haven’t got any disconnection anymore so far. I was thinking about substitute my EX2 Ultra because of that. When you improve something, other problems emerge; it’s normal as long as WD keeps improving the firmware.
Anyway, the decision about delivering firstly the OS5 without Transmission has been a big mistake, guys. Don’t do that again :smiling_imp:

1 Like

I have noticed my torrent port is not “opening” on my router. I even tried manually setting a port forward on my router.
But after OS5, nothing is the same…

I have fix it , not the best way , is working for me.

by changing this settings see 3 print screens links



Open the port on your router

I updated the setting.json file as described and restarted transmission.
Now I get below error when I fire the url:

Any ideas?

And I agree … WD should fix these issues! Not good advertising!

Hi, has anyone found a solution to access trasmission without the mycloud GUI “config” button? I can only access from the panel after the login, is very annoing and I can’t configure any app (e.g. android app) to access it directly from my lan. Plese help!

same problem. Anyone can explain us how to solve?