There is no subtitles in movies

I have read some forums. I couldnt find any solution.
I have MyCloud 4TB and twonky Version: 7.2.9-6 and Samsung Smart TV
I cant see any srt files in Smart TV when i reach the “My Cloud” and movies plays without .srt

how can i solve this? If the answer is upgrading twonky server, how? is there any tutorial for that?

thnx,

The problem probably lies the Samsung Smart TV’s DLNA client. Seems the Samsung TV’s have a lot of problems with the My Cloud based on many past threads involving Samsung SmartTV and the My Cloud. If you do a forum search (magnifying glass icon upper right) and use the search term “samsung srt” you’ll find several previous threads detailing others having the same problem with SRT files on Samsung TV’s.

I have no problems playing subtitle SRT files with a Roku that streams from a My Cloud using DLNA (Twonky Media Server).

You may want to review the following thead to see if anything in there will help.

https://community.wd.com/t/faq-twonky-dlna-media-server-setup-use/95373

1 Like

well thnx but i need a clear answer. Some people says they solved the problem some people says its not possible… this is bullshit

Remember, this is a user forum; we’re not WD employees.

It’s difficult to give a ‘clear answer’, because there are so many places where the problem could be occurring, and so many different Samsung TVs. Which model is it, and have you checked its user manual to ensure it supports SRT files via DLNA? That’s assuming it’s accessing via DLNA, and not via a file server.

Have you checked the Twonky UI to see if your TV has registered correctly as a Samsung TV ‘media receiver’? See the FAQ for details.

1 Like

Sorry, but sometimes there is no clear answer or solution. If one does a Google search for Samsung TV SRT they’ll see that this problem is not just a My Cloud problem. It happens with other NAS (like QNAP) and DLNA servers (like Plex). People are reporting they can play SRT files with their movies when they use the USB just not when they connect to a DLNA media server.

The problem may lie with the DLNA client used by the Samsung TV and not necessarily with the DLNA server (Twonky) used on the My Cloud. As was indicated previously check the Twonky UI to see what ‘media receiver’ is being used by the Twonky Media Server for your Samsung TV. It is not recommended, but if one attempts to manually update just the Twonky Media Server within the My Cloud firmware, via SSH, it may potentially cause other problems, like bricking (rendering useless) the My Cloud entirely.

Do you have another DLNA client that supports SRT files that you can use to test the media on your My Cloud?

Other things to try. One should ensure their SRT file is properly formatted by checking the movie/SRT file using a media player on their PC that is capable of playing SRT files. VLC is one such media player that can play SRT files. Sometimes the SRT file one gets from the internet may not have the required formatting which causes the SRT file not to play.

One possible workaround, that is not elegant or simple or even desirable, is to hardcode the SRT subtitles into the movie (or TV show) by re-encoding the media to include the subtitles on screen. Programs such as Handbrake (which is free) are capable of “burning in” (or “hard burn”) the subtitle track so its visible on screen and embedded directly into the media file rather than appearing as a separate SRT file. The downside is one cannot disable or turn off the subtitles that are hard coded/burned in to the video. The following link gives general directions on how to use Handbrake to burn in subtitles: How to Add Soft or Hard Subtitles to Movie Videos with Handbrake

1 Like

Make sure that the Subtitle function has been enabled and the video and subtitle files have been renamed properly with the same name and put in the same folder. If it’s not work, you can try this way: http://www.videoconverterfactory.com/tips/samsung-tv-subtitles-problem.html
Burning the subtitle in videos. That could be work.

1 Like