WD My Cloud doesn't supprt srt file


(sorry in advance for my bad English)

I have WD my cloud 3tb and it works fine except that when i am connected to my smart tv (LG) it doesn’t show me the subtitle.

I already checked that both of the file are the same name.

I be happy if anyone help me with this situation.

Thank a lot


Standard DLNA doesn’t support SRT, that means you won’t be able to watch movie+SRT with My Cloud.

I watch avi/mkv/mp4+srt on an Samsung tv (2011) from WD My Cloud.

  1. Make sure the srt file has the same name as the avi file.

  2. if you want to watch it immediately after copying and renaming the srt file, rescan media content from dashboard.

If doesn’t work, try to configure your tv model on twonky options (http://wdmycloud:9000).

Good luck !

Do you know if any time soon the DLNA will support srt subs?

maybe on the next update…

thanks for the answer

Well I just tested, and I knew wrong.

My Cloud’s Twonky DLNA server DOES support SRT. It works perfectly with my Samsung 50F6640 TV over DLNA. SRT has the same name as the MKV file.

Might depend on your TV

How will i know which DLNA server do i have?

And if you have a guide that show me what to do I’ll be granted :slight_smile:

To manage twonky server (DLNA) go to:


Some help: