WD My Cloud Mirror : DLNA + Samsung UHD 55 and subtitles: not working

Hello,

I am new and just bought the WD My Cloud Mirror (Jan 16) and updated the firmware to the last version when I installed it.

I also have a Samsung UHD TV 55 inches bought in 2015 with the latest options. I was able to successfully trigger the DLNA mode and I can view videos on my TV. However subtitles do not work. I know how this works (both files must have the same names) but it does not work. I realized it only happens in DLNA mode because when I put a USB stick, content with subtitles work perfectly.

Does that mean that DLNA only streams videos itself without the SRT files ?

Please help :slightly_smiling:

Hello,

I used to have the same issue.

Right now, whenever I copy some movie to mycloud mirror, I have to rebuild the database so that I can see the subtitles (.srt file)

Go to dashboard -> Settings ->Media -> Rebuild

Unfortunately I never made it with Plex, so I am using twonky
Not the most practical, but it has worked for some time now… :frowning:

Thanks for your reply but I don’t understand what you mean with Plex. I’ve only used the Samsung file browsing interface so far, should I use somethign else ?

Twonky is the “media server” installed by default on “my cloud mirror”, but you can install plexmedia server also, which is another dlna server.

So, long story short, forget the plex, try this:
put your movies in your mycloud and Go to dashboard -> Settings ->Media -> Rebuild
Try to see the movie on your TV through your browser interface and give some feedback

Thanks I have tried that but nothing better.

Still no subtitles.

Does the DLNA actually stream the srt files ?

Just tried with Plex, it works ! With Plex I can select the subtitle file …

Thanks for your help.

No problem.

In my case it is the opposite… :frowning:did you install plex application on mycloud? did you configure it? or just the default options?

I downloaded the .BIN from the Plex website then I installed it thanks to the configuration console (Application tab).

It allows me to select a subtitle file.