The Samba permissions again

Hi There,

I bought my EX0 a 6 weeks ago, did immediate firmware update and then put some drives in.

Silly me, I only configured them as JBOD but it shouldn’t apply to the problem I have.

I can’t say when it has started but I can’t change any permissions, either users or shares. They are all greyed out on the web interface. I was able to create a number of users though and these users seem to have correct access to the files. They can add or delete them.

I’m worried though that one day it will just cut me off because of that.

I’m aware that there were problems with permissions before (after the firmware change I’ve applied). 

Has that been resolved somehow? Is it safe to apply the newest update? 

I could easily connect from the shell side (SSH) and modify Samba files but definitelly will not want to loose my warranty.

Is there a walk-through or other more straightforward solution available to get that solved?



I’m not aware of ANY permissions problems with ay of the previous (and current) firmwares. Your permissions should show up fine on the web deashboard - if they don’t, just try rebooting andsee if that fixes it. If it still does not, you should contact WD support because what you describe is not a widespread or even a widely known issue. This is the first time I am hearing of it.

Hi Cybernut1,

Thanks for your comment.

I’ve already rebooted for a few times without success.

I’ve read this thread (for example, cause there is few more out there):

If you skip the Windows related portion on it, you’d see the screenshot from the Web panel showing all fields of Share Access to the main folders: Public, SmartWare and TimeMachineBackup greyed out.

This is exactly my problem. The same happens per share basis. Also if you approach the folders from Web Viewer application and try there changing permissions, it won’t work.

I had a quick peek through SSH on the etc/samba files (without touching anything). There supposed to be a file which is included (I guess) to the smb.conf, with definition of your shares. I found information about that in some post, which I can’t find at the moment. But that file isn’t there at all (something called overall share or similar). On the contrary, the smb.conf has all share definitions inside it.

I’d really like to avoid doing factory reset because I already have around 200GB on the drive and not too fast network to copy it out and back in afterwards. :frowning:

I’ll mpost likely contact the WD Support :frowning:



Just a couple things - when you do a factory reset all your data stays in their places - ie. the folders (shares) will still be there. But you will lose all the users you have created and will have to recreate the users and permissions on shares manually again. I think there is an export settings option in the dashboard somewhere but I don’t believe it saves the users and permissions on shares info - I believe it just saves your other settings…and you ca import that after doing a factory reset.

As for the issue about grayed out shares, hmm, I have never seen that on mine - as a admin all shares are available to me. But yes, the pic you pointed to in that other post does have some of those shares grayed out - that is quite odd, because no share should be grayed out from the admin…unless something odd happened. You can contact support about it. But I have not heard of anyone suddenly losing access to their shares (as you expressed that concern in your first post in this thread) so I think you can rest easy on that. As for Web File Viewer app, that app has certain issues right now because it does not seem to work for non-admin folks…just seems to work for admin user. This bug has been reported to WD and hopefully they will fix it soon in an upcoming firmware.

The samba permissions are all kept in /etc/smb.conf - never heard of an overall share config file for Samba. Feel free to edit the file in SSH - you won’t break anything permanently - if it breaks, you can reboot the NAS and your edited smb.conf will be automaticaly discarded and a fresh one will take its place (in fact at boot time the entire /etc directory is recreated). You can try out any change to smb.conf - samba service polls that file every few seconds and if there are any changes, it will take effect within a few seconds automatically. But any changes you make to smb.conf will only last till the next reboot. Besides, anytime you make these kinds of changes to config files, it is ALWAYS a good idea to create a backup file first with the exact same permissions, etc. before you edit it - use the cp -p command (e.g. cp -p /etc/smb.conf /etc/smb.conf.bak) and if things get too out of hand or you have problems you can simply copy the backup (.bak) file over the edited smb.conf.


Thanks for that. Good stuff.

I found the post I was reffering to in my previous message.

Look here:

I think that my problems are strongly related to the above but I’d prefere out of the box solution from WD rather than fiddling myself.

N.B. I knew the smb.conf by hart few years ago. Unfortunately (or fortunately :)) I work around different technologies and projects now a days so I became a bit rusty in Linux admin stuff. Ocasionally now a days I work with Zentyal (Ubuntu distro) which sort of behaves simillar to what you’ve described in MyCloud, so I think I’m familiar with this automacy re. etc files.

Anyway, thanks for help. I’m going to ask WD support and dependent of their answer I’ll do bad things to my MyCloud :slight_smile:



Hi ,

I tried with all possible ways to join with my linux based Acive Directory,  everytime I get welcomed by “FAILED” message.

Hello RadoVal,

unless this problem isn’t solved anyway in the meantime:

could it be that you only have “public” shares as with those the individual permissions are not editable.

there’s a switch “public” on/off in each share’s settings.