Problem with File Attributes Permission on WD My Cloud EX2

Hi. I’d like to ask for help concerning changing the file permissons in My Cloud EX2 8 TB. The problem is: under Windows I’m trying to change the file’s attributes (read-only, hidden, etc) but the changes I make are simply lost whenever I click ‘OK’ on the File Properties window.

When I open the ‘Security’ tab on the File Properties window, the My Cloud’s admin is listed only with the following attributes: 

Then, when I click on ‘Edit’ I check FULL CONTROL and MODIFY, but after clicking OK the options I checked are simply forgotten. Afterwards, I click on ‘Advanced’ to check the permission parameters; the NAS admin is listing as having “Access = Special”. So I go on and edit the admin’s permissions:

attrib2.png

HOWEVER, after clicking APPLY or OK, the parameters I changed are simply lost, as depicted below:

attrib4.png

So, that means that all the changes I do to my files are not taken into consideration. It seems that the NAS is not auhtorizing changes to permissions or even not recording the permission changes I do. I’ve even created a 2nd user to try it but in vain. 

The settings of the NAS concerning shares and user permissions are correct, there’s no problem about that (the share I’m trying to change in this example is MY_FILES). As you can see, the user ‘admin’ has R/W privileges on ‘MY_FILES’ share. Before this setting I had also tried having this share configured as ‘Public’, but nothing changed:

attrib5.png

And this thing happens also with the ‘Public’ share: I can’t change the permissions and attributes of any file or folder under this share.

Could you please try to help me out? 

Thank you so much. Best regards,

André

Andre,

I believe the drive is formatted EXT4 via the Linux OS.  This means that Windows cannot change the file permissions via SAMBA which is how you are connecting to the drive when you map it.  The only way I know to change the file permissions would be to log in via SSH, or let WinSCP log in via SSH to change the file attributes.  I personally use WinSCP because it presents a very user friendly “Commander” style interface and I dont have to remember all of those wonderful old Unix/Linux commands.  (Chmod would be the one you are looking for here.) 

However, if you set up the users and groups properly I doubt you would need to change the permissions on any files.  You can deny access to whole shares or make whole shares read only. 

If you do decide to start changing file permissions from within the EX2’s OS I cant caution you strongly enough to be very careful.  It would only take one slip while using a recursive CHMOD command to make the drive unbootable. 

1 Like

Andre,

I am not quite clear what you are trying to achieve - and why. The EX2 admin user shows that it already has full read, write and execute privs. Why do you want the admin user to have Full Control? Please clarify.

EDIT: While I was writng and revising my answer, Vertech1 already answered most of the stuff I would have said in a subsequent post :slight_smile:

1 Like

Vertech1 wrote:

 

If you do decide to start changing file permissions from within the EX2’s OS I cant caution you strongly enough to be very careful.  It would only take one slip while using a recursive CHMOD command to make the drive unbootable. 

 

 

While I heartily agree with Vertech1’s caution, I would add that changing permissions on the shares won’t make the drive unbootable - the worst it can do is make the share unavailable until the Linux permissions are changed back. But the drive’s system files resides in a different area than the data shares. But yes, if one wanders into the system area and changes permissions, it can have bad consequences. But for the most part, the good thing about EX2 is, that most of the system stuff can be brought back using the emergency reset feature. Settings will be lost but user data will be unharmed.

Thank you both for your replies.

The thing I wanted is to select some files here and there to be either hidden or read-only, just as I do very straightforward in Windows. Just for instance, the ‘desktop.ini’ of the folders inside some Share has to be set as hidden + system file in order to enable the ‘folder customization’ feature of Windows, and I can’t accomplish that through the ‘regular’ ways. Another example, in some others folders there may some less-used files that I always like to hide in order to get a clean workspace, without moving them to other directories.

The issue with this SSH approach is the big risk it envolves, as well as voiding the warranty as I’ve heard…

Sorry…the two ways to make a file or directory on an EX2 share hidden is to have:

  1. a filename beginning with a . and you can only do this via ssh…Windows doesn’t allow filenames beginning with .

OR

  1. change read permissions on the file via ssh

But yes…both options require SSH access.

Andre,

You CAN via a windows mapped drive rename a file or directory to start with a period.  SAMBA is smart enough to know that this is a valid file type and will allow it.  So, if all you are looking to do is hide a couple of files or directories within an existing share that will work.  But like everything else there are ways around it.  For instance, if I change the “View” setup of my windows explorer to show me hidden files I will still see the file and directory that has been hidden and be able to manipulate same.  When viewing hidden files or directories they appeared greyed out but you can clearly see them.

This is true on a Windows 8 and Windows 7 system.  Not sure about any other OS’s.

1 Like

Vertech1 wrote:

Andre,

You CAN via a windows mapped drive rename a file or directory to start with a period. 

Yes, Vertech1 is correct but the only way I am able to do it on my Win7 PC is to rename the file to begin with AND end in a period…Windows explorer then auto-removes the trailing period, leaving just the leading period. And then the file automatically becomes hidden (but visible if you do what Vertech mentioned about showing hidden files in Windows explorer’s Folder options from Tools menu).

1 Like

Thank you so much both of you guys!