Unable to access P2P folder

Hi, I’m having problem to access my P2P folder in EX2 when the share profile “Public” has been turned off even I have give read&write permission to admin account under User Access but my access to P2P folder are still being denied.

I went to ‘Setup User’ tab and select admin account then change the Share Access to Read&Write for P2P folder but soon after refreshing the webpage the permission has been revert back to Deny Access. I’ve been trying to set this several times but to no avail.

WD support please assist me to fix the permission issues.

Thanks

Hello,
this is another bug by the last FW, WD is ignoring us… take care and use it so :stuck_out_tongue:

Thanks for letting me know :wink: guess I have to wait for the new firmware updates.

Any news about this bug? It seems like it’s still there on my WD EX2

I have the same problem. :frowning:

Hi. Maybe I’m just too late, and even registered just for posting this, as I was having the same problem too, but anyways here it goes.

(jump to _Solution: for the actual solution)

_Description of the problem:
I could set the folder to be Public and it worked. The problem was I didn’t want the folder to be public, so I assigned it to my user only, and from that moment on, I could not access it anymore. I just kept getting windows credentials input dialog, and I was sure that I was typing my credentials correctly. In the GUI, option ‘Deny Access’ was persistent and if I chose ‘Read/Write’ option, it reverted back to ‘Deny Access’ again, after page refresh. I’ve even manually edited the ‘smb.conf’ (through ssh) samba configuration file and noticed that my username kept going to the “invalid users” flag after reboot, no matter what I did.

_Solution:
Just rename the folder. I renamed mine from “P2P” -> “storage”, and it worked like a charm.

_Thoughts:
*Well, this is not critical, but I think WD should review its firmware.
*Folder ‘Public’ should be deletable through the GUI.
*interface looks way better with dark theme, as well as the device case
*WD storage/clouds should be capable of being hidden from the networks. Windows 8+ easily expose WD’s as storage devices in the network pane. Although they are storage devices, they are still personal. In huge networks, there are always extraneous eyes keen to ‘explore’.

Regards

1 Like