Public folder changing access

The ‘Public Access" option for my Public folder is greyed out on the GUI.
I’ve got it mounted on a raspberry pi and was finding that I couldn’t change the properties on the sub folders. I was getting "chmod: changing permissions of `nas1/ABCD’: Operation not permitted". All the folders were “drwxrwxr-x”

After the latest FW update (v04.04.01-112) I SSH’d into the My Cloud and was able to ‘chmod 777 -R’ on all of Public. This fixed the problem I was having on the rPi. However the access button is still greyed out on the GUI. Is there a way to get the GUI back in sync so that the public access option is not greyed out and will work in the future?

Short answer, no. WD had decided that the public folder cannot be changed to private. If you do a forum search you’ll find several past threads on the Public Folder issue. Prior to the OS 3 firmware one could exploit a bug in the Dashboard coding by trying to change the Public Share name which would cause the Public Access option to become selectable, but that coding was “fixed” starting with the OS 3 firmware.

Two recent threads on this issue:
https://community.wd.com/t/removing-public-share-wd-mycloud/137086
https://community.wd.com/t/public-share-public-access-on/96854

I post it somewhere long ago can’t remember where so I’ll do this again. Think it should still work since the db structure seems intact. You can try below, revert with the backup copy if it doesn’t work.

WARNING: Any attempt to modify the rootfs may void our warranty :stuck_out_tongue:

Check first if it’s good (I’m still on a very old v4 firmware):
sqlite3 /usr/local/nas/orion/orion.db "select public_access from usershares where share_name='Public'";

If the result you see is “true”, you may proceed further.

BACKUP!:
cp /usr/local/nas/orion/orion.db /usr/local/nas/orion/orion.db.bak;

Update:
sqlite3 /usr/local/nas/orion/orion.db "update usershares set public_access='false' where share_name='Public' and public_access='true'";

Now run the 1st command again you should see “false”. Then “re-login” to your WD DashBoard, check if the button is still greyed out.

If it is still greyed out, then this method is no longer working (patched by WD, need to find what has changed), please revert back the backup copy above.

You’ll then need to manually change “each” user access for the Public folder either RO or RW.

1 Like

While the orion.db database exists the UserShare table is empty (on my My Cloud). Edit: Using v04.04.01-112 firmware.