Permissions Problems

On my cloud I have an assortment of user accounts with different permissions.  For the most part everything is working just fine.  However I am having problems with the public folder.  I am receiving an error whenever I try to move or delete files in the root of my shared music, video or pictures.

I receive this message. “You require permission from Unix User\root to make changes to this folder”

I have an extremely large number of files in this dirrectory at which I would like to be able to alter as I please.  However this is not the case.

I have adjusted the permissions from the web interface to the best of my ability but the problem still remains.  

I believe the solution is somewhere within the SSH interface however I am unfamiliar with the commands to make this happen.  I believe I need help using the ‘chmod’ command.

I only want to change the settings for these 3 folders [Shared Music, Shared Pictures, Shared Videos] because these are the only ones not working on their own.

As a side note.  Within the other folders in the same root there is no problem.  The tree looks like this

/Public/shared Music [gives me problems]

/Public/Movies and Seasons [Works Great]

Movies and Seasons was created by me and The shared folders were there from the beginning.

I assume this is some kind of saftey feature or something.  please help me remove it because it is very annoying now.

Hello, check if you have the latest firmware update available, if the problem continues try doing a system only factory restore.
Check the links below for more information.

How to manually or automatically update the firmware on a WD My Cloud, Mirror, EX2 or WD My Cloud EX4 Personal Cloud drive 

How to restore a WD My Cloud, Mirror, EX2, or EX4 Personal Cloud drive to factory default settings 

Solution to my orginal Question 

In order to access the cloud’s SSH interface you must enable SSH from the web
dashboard. After you have enabled it you must then tunnel in using putty or
another linux program.

Port 22 needs to be forwarded to the cloud along with the dashboard setting of
ssh needs to be enabled. This one is found at the bottom of the network tab
on the web interface.

User: sshd            (The default linux user differs from model to model)
password: **setbyyou**

chmod -R ### /directory/ (Had problems with spaces in folder names) 

the ### is the numbers for the permission levels


Owner / UserGroupOther/ Everyone

0 - no access to the file whatsoever
1 - execute permissions only
2 - write permissions only
3 - write and execute permissions
4 - read permissions only
5 - read and execute permissions
6 - read and write permissions
7 - read, write and execute permissions (full permissions)

Second solution

The problem I had can also be fixed by a web app that was within the web interface.  I am not sure if I downloaded it whenever it first came out or if it is a static app feature.  However, I do know I didnt add any app’s to my cloud that were from outside sources.  So where ever I got the app from is somewhere on the online dashboard.

The app is called “Web File Viewer”.  Under the apps tab in your web interface all of this can be accessed

All you have to do on this app is navigate to the folder through the web interface.  Rightclick the folder that is having issues and click properties. From there it will tell you who the owner is and what rights are given to everyone.

The problem I described above was caused by the owner of the folder being someone called “Root”.  I did not add this person so it must be something that is added by WD. THANKS! (not)

Both of these 2 solutions will work if you have the same problem as me.  No need for factory reset.

1 Like

You do NOT need to forward port 22 to the cloud if you are accessing from within the network (i.e. network in which the my cloud is kept). That’s an extraneous step for a local network connection.

And root user is the default admin username for any linux/unix OS. sshd user IS the root user…if you run the id command while you are logged in under sshd you can see that.

That makes sense about the port 22. thx!