SSH is not working, it is not accepting the password

This is what I am getting
I am new to Unix but I think I can manage without destroying my MyCloud

The issue I am facing is more complex than what I know
The MyCloud IP adress’s is 10.0.0.3

Chriss-MacBook-Pro:~ chriswakim$ ssh 10.0.0.3
chriswakim@10.0.0.3’s password: welc0me
Permission denied, please try again.

and keeps going in a loop for 3 tries then i get the following

Permission denied (publickey,password).

Can someone help ?

It’s because you need to be signing onto the My Cloud NAS as user: root

How do I do that ?

SSH into the NAS then type root for the user. then type welc0me for the password.

RAC

I thought that when I type
ssh 10.0.0.3
is the ssh into the NAS
How do you SSH into the NAS ?

Sorry I am very new to all this

Yes. You SSH into the ip address of the NAS. It should respond with Login as: to which you type root Then it will ask for the password. You then respond welc0me

RAC

This is how it is responding though!
Do I write root into the password?

No You should type welc0me. But are you sure that 10.0.0.3 is the IP address of the My Cloud?
What OS is your PC running. On my windows PC I need to run a program called putty. I then put the IP address of the My Cloud in the address bar and click ssh then click open.

RAC

Well this is what it says in the My Cloud Dashboard

Is there another way to find the IP of My Cloud ?

MAC OSX 10.11.1 EL CAPITAN

For Macs I don’t think I need this because Mac is Unix based

I’m going to have to defer to the MAC people. I don’t have any knowledge of the MAC system.

RAC

If you don’t know what you are doing you an easily brick your My Cloud using SSH or render it crippled. Using SSH can void the My Cloud warrantee. So use at your own risk.

To SSH from a Mac, from the “Terminal” type:
ssh root@< My Cloud IP address>

So in your case if the IP address of your My Cloud is 10.0.0.3 you would type in “ssh root@10.0.0.3”.

You will then be prompted to enter a password. The password is: welc0me
(Note: that is the number zero not the letter “O” in the password.)

On the latest firmware the My Cloud will prompt you to enter a new SSH password at the first SSH login to the device.

Edit to add: El Capitan is known to have problems with the My Cloud. See the many other thread detailing various problems using El Capitan to access the My Cloud. For example this recent thread:
https://community.wd.com/t/support-os-x-el-capitan/96744/117

A quick google for ‘SSH’ finds a tutorial as the third hit:

http://support.suso.com/supki/SSH_Tutorial_for_Linux

It shows the command syntax for logging in, and, as Bennor points out, it’s

ssh user@hostname

in your case, it should be:

ssh root@10.0.0.3

If you don’t specify a username, ssh will assume you want to log in using the account from where you are running ssh, in this case, chriswakim. Not the root user you need to use.

I have the same problem while using root,
It used to work to ssh with my mycloud but since last firmware update it don’t.
An other possibility is I reinstalled Windows/MobaXterm so maybe something with my private key…?

C:\Windows\system32>ssh root@192.168.1.8
root@192.168.1.8’s password:
Permission denied, please try again.

root@192.168.1.8’s password:
Permission denied, please try again.
root@192.168.1.8’s password:
root@192.168.1.8: Permission denied (publickey,password).

If one is using the v2.x firmware it appears WD changed the SSH user login name from root to sshd in a recent v2.x firmware release.

1 Like

WD Team… Full of surprises… In a worst way…

Thanx Bennor…

hehe Glad I found this thread. I had been trying from MacOs using root. No wonder I could not get in. I cant believe MacOS that has console and does not need additional programs to SSH

Hello,

I can`t SSH with usename root password welc0me on my MyCloudEX2Ultra firmware 2.31.204
I have a option to change the SSH password from the dashboard, i change the password and nothing happen.

Any idea how to fix this ?

Are you using the correct root user name? As indicated above WD changed the root user name from root to sshd for various My Cloud units running the v2.x firmware.

How to Access a My Cloud Using SSH (Secure Shell)
https://support-en.wd.com/app/answers/detail/a_id/26497

I am having the same issue. Tried SSHD and have checked your support link and still can’t log on.

I am on My Cloud and the firmware is v04.05.00-342. Why did Western Digital change the root id suddenly? How can I get into my system with SSH now?

WD didn’t change the SSH user name for the first gen v4.x My Cloud. the user login via SSH is: root on the v04.05.00-342 firmware. I just checked mine and root still works.

If you have forgotten the correct password then try turning off the SSH setting in the My Cloud Dashboard, then re-enabling it and see if that resets the default SSH password back to: welc0me One will be prompted to change the default SSH password to another password upon first SSH login (when using Putty or similar).

Only the second gen v2.x had the SSH login changed from root to sshd. For what ever reason WD hasn’t fixed or updated the various Knowledgebase articles on My Cloud SSH to make the distinction clear.

Edit to add: If resetting the SSH password to default (welc0me) by turning the option off then back on in the My Cloud Dashboard > Settings > Network doesn’t work. One may have to perform a 40 second reset via the reset button on the back of the My Cloud to reset the SSH password.

Option B: 40 Second Reset (Reset with Power Off)

The 40 Second Reset, also known as System Only Restore, will reset the following:

  • Admin User Name (default = “admin”)
  • Admin Password (No password by default)
  • Device Name (default = “WDMyCloud”)
  • SSH (Secure Shell) on Firmware 04.xx.xx-xxx, User Name and Password (default = “root” and “welc0me”)
  • SSH (Secure Shell) on Firmware 2.xx.xxx, User Name and Password (default = “root” no default password, new password enforced)
  • Remove all Users except Admin
  • All Share permissions (default = Public)
  • Automatic Firmware Update (default = off)
  • Network Mode (default = DHCP)
  • Remove all Alerts
  • mycloud.com account association (default = not configured)
  • Mobile app account association (default = not configured)
  • WD Sync association (default = not configured)
  • Backup jobs (default = not configured)
  • Safepoint jobs (default = not configured)

To execute the 40 Second Reset :

  1. Power down the device and remove the power cord from the device
  2. Using a paperclip or narrow tipped pen, press and hold the reset button
  3. While continuing to hold the reset button, reconnect the power cord to the device and continue to hold the reset button for at least 40 seconds
  4. After releasing the reset button the device will reboot

Note: This process may take upwards of 15 minutes. Please wait until the Power LED is solid blue, indicating the device is ready to use.