SSH Password no longer working

Tried to connect to a MyCloud 3 (WDMyCloud v04.04.04-101 : Core F/W) today, and the root password welc0me is not accepted. Did a recent firmware update change this? How can I reset it?

Initially when first activating SSH on a single bay My Cloud the SSH login is:
Login Name: root
Login Password: welc0me

One is then typically asked/instructed to enter a new SSH password. Make sure to remember/write down the new password.

If one continues to have problems one can disable then reenable SSH through the My Cloud Dashboard > Settings > Network page to see if that clears the inability to log in to SSH.

Tried that with no change.

Does the 5 second reset clear the SSH password?

Tried what with no change? Using “root” as the user name when logging into SSH? Or disabling then reenabling SSH? You probably already know this but the “0” in the default “welc0me” SSH password is a zero.

You would probably need to do a 40 second reset. Generally a 4 second reset just resets the Administrator account password to default. The 40 second reset will change most of the Dashboard options back to default values. You can read more about what is changed with each method of reset in the following link.

Yes, toggling the SSH switch did nothing. I’ll backup and try the 40 second reset

You can get the solution here

Note that the first gen v4.x firmware single bay My Cloud, which the initial poster indicated they are using, is not affected by that issue. The second generation v2.x single bay My Cloud is affected as it is using similar v2.x firmware as the multi bay My Cloud models. The older v4.x firmware used on the first gen single bay My Cloud is different than the v2.x firmware.