Not seeing all my files and folders in MyCloud

I created a new folder named ‘Projects’, then uploaded over 50 other files and folders into the Projects folder. A friend attempted to view the Projects folder remotely. Everything seems fine as the screen displays the first 18 files. However, the screen refuses to scroll or refresh to show the remaining files.

I have no problem viewing the folders on another computer. We are both using Win 7 and IE 11.

I would appreciate any help.
Thanks.

Hi,

Is this happening within the same network or your friend is accessing the files remotely?

How is the friend accessing the My Cloud remotely? Are they using the MyCloud.com portal? If so what web browser are they using to access the MyCloud.com portal?

She’s accessing MyCloud remotely using Win 7 and IE 11.

She’s accessing the MyCloud remotely from a different part of the city.

I have the same problem, but I have found that it is related to the web browser.

If I use IE, then I can only see the 30 or 45 folders/files in a share. it seems like the rest aren’t loading so that I can’t scroll down far enough to see them. If I’m very patient then they will sometimes keep loading and eventually appear after a few minutes (I mean MINUTES literally).

If I use Firefox they all load up immediately and I see the whole list from the beginning.

BTW, it is not related to internet speed since I have a very fast connection and I get all the files instantly with Firefox when using the same computer. Also it isn’t related to the specific computer since I’ve seen the behavior on three computers. I have also seen this behavior when the same computer is used in 3 different locations, so it’s not related to the geographic location nor to the ISP.

There is some problem with how mycloud is interacting with IE.

Craig

1 Like

Thanks for your reply. Since I don’t have Firefox, I tried Chrome instead and it worked! I don’t understand IE, because it worked on one machine but not another.

Michael.

Well this is very funny, because I can see only the first 30 files in any folder on mycloud when viewing via chrome. On firefox I can see all files. I sent myself a share link and still I can only view the first 30 files in chrome… So now I have had to go back to using google drive to be sure my friends can see all the pictures that I share. What is the REAL fix here?

Hi,
I have just bought this MyCloud, not finding it very user friendly. I am also having the exact problem you have described.
I am using Chrome, and also unable to see more than 30 folders. Did you ever find a solution for this?
Any help would be appreciated.

Try using a different web browser. People have reported certain issues using Chrome.

And if you haven’t done so already, read through the My Cloud User Manual (https://support.wdc.com/product.aspx?ID=904) and the My Cloud Dashboard Help. Both explain how to use the My Cloud. Also see the My Cloud Learning Center(http://mycloud.com/learn/?id=mycloud) which has information as well on how to use the My Cloud.

Still having this problems with the latest chrome version. This should be fixed ASAP as the share option (for what i bought mycloud) is useless for now.

Having this problem with ANY browser.
I have copied 100 Gb files on MyCloud Mirror.
They appear on the Dashboard.
But files are nowhere to be seen in MyCloud.
What the hell ?

Is there a fix to this.
I just bought a MyCloud but if all I can do is see the first 30 items in a folder …this thing is useless.
How has WD not fixed this?

The workaround is use a different web browser other than Chrome. Or use the My Cloud Dashboard program, or the My Cloud mobile apps for iOS or Android if using a mobile device.

For local network access one does not need to use MyCloud.com.

What is useless? The My Cloud device or the MyCloud.com website.

The My Cloud is a network attached storage device that has limited remote access capabilities. For remote access; one can try using a different web browser to access the MyCloud.com web portal, or use the My Cloud Desktop program, or use the WD mobile apps for iOS or Android. Or one can enable FTP access within the My Cloud Dashboard and use FTP (an insecure protocol) for remote access.

1 Like

As said elsewhere, the problem is with ANY browser,
no access at all to mycloudlocal. Only dashboard is accessible.
I use it only through the Mac Finder sharing access.
Under iMac 2016 and Sierra.
Solutions proposed by Bennor were useful, but don’t exonerate
WD software.

We’re not here to exonerate WD software. Most of us would probably suggest not using it unless you really have to… Were here to try to give pragmatic workarounds to known problems, or to explain how the device works and is supposed to be used.

Did you mean MyCloud.com? You say you can access the Dashboard, which is achieved via mycloudlocal.

Have you confirmed that the files you transferred are actually in the drive? i.e. can you see them with Finder?

Did you put them in one of the shares that is hidden from remote access? Smartware, TimeMachine?

Have the new MyCloud Home changes to the MyCloud.com portal caused problems for you?

I did not wrote anyone exonerates WD, I wrote IT doesn’t exonerated WD.
You and Beenor have been very helpful and knowledgeable in helping me to solve this, and did not spare your time.
Files are perfectly loaded in Smartware through Mac Finder. Dashboard is accessible.
WD Sync is not, and the mycloudmirrorlocal is not, from ANY browser.
I have no DNS error with any other website from ANY of our Mac here.
DNS address are 198.xxxx, not 169.xxxx
That said, I don’t understand if backups are transferred through local or web.
Transfer times are much slower than with my Sonnet local network.
All in all, these software deficiencies seem not to be there by accident, but by design. It reminds me infamous bugs in Microsoft Office for Mac that are there since 1998, but when you ask abysmal M$oft technical support, they seem to never know about it, 19 years after (full memory problem, repeated crashes when using dictionary and/or autocorrect and/or ortho/grammar tools, automatic file copy upon saving not working, etc., etc., that lost me dozens of hours of work no matter what precautions I could take).
“It’s in the (software) architecture, stupid.”

It should be noted thathttp://mycloudmirror.local is the My Cloud Dashboard address and the http://mycloud.com is the web portal for remote access.

[quote=“halls, post:17, topic:142558, full:true”]

[/quote]
If you are stuck at the “Signing In…” when accessing MyCloud.com then check your web browser for ad blocking. You may need to add MyCloud.com to the ad blocking white list.

https://community.wd.com/t/enter-device-code-on-my-cloud/214811/23

AdBlock doesn’t change a thing.
Finally got in My Cloud.
See that list of folders ? All empty… as before : names of my content, and no content.
Moreover, I just uploaded a new files (a DNG picture, 15 Mb).
Uploading has been confirmed with a green tick by MyCloud : “Uploading confirmed.”
After that, this DNG pic is nowhere to be found.
Really losing my time with that piece of c***p

.
I’ll try to use another third party software to upload and create cloud access to my stuff.

What you are seeing is a probable failure of the WD Sync software failing to sync files to the My Cloud and NOT a failure of the My Cloud unit itself or a failure of the remote access software/website.

If one uses forum search (magnifying glass icon upper right) they’ll find numerous past discussions on WD Sync not syncing files for what ever reason. Unless you need remote syncing there is no reason to use WD Sync. Instead one can use third party sync software including free sync software like Free File Sync (https://www.freefilesync.org/) or Microsoft Sync Toy (https://www.microsoft.com/en-us/download/details.aspx?id=15155).