Seeing only 30 rows on Firefox/Chrome


I have an issue where I am only limited to 30 rows on the page while using Firefox or Chrome.
No way to scroll down.

Using IE works OK.

Support suggested to Rebuild the Data Base through Dashboard.
The issue is still there.

Could anyone test it on Firefox/Chrome and let me know that works, please ?


Assuming you are talking about only seeing 30 rows when using web portal. If so it’s a known issue. One that has been discussed at length in various past discussions. Those discussions can be found using the forum search feature, magnifying glass icon upper right. The workaround is to use Edge or IE if you are having trouble with Firefox. The problem is most prevalent with Chrome. A few past discussions:

Thanks !

That is right, this is the issue I am facing.

I find it weird that CS is insisting the problem is on my end although they should know I am not the only one trying to find a fix.

@Juste As already posted here this has been discussed before. I have never had this problem. I just tried chrome again logging into and I had no problem. I have Windows 10 with all updates, using Chrome with latest updates and I have a scroll bar on the far right to move down my list.

1 Like


It is puzzling me more and more.

I was able to make Chrome work as it should on work computer.

Yet, I am unable to see Chrome (updated) work on home laptop, Windows 10 with latest updates.

@Juste In another topic about this yesterday we discovered that checking the zoom on Chrome for the page that you need to make sure it is set to 100%.

Same problem: Can only view 30 folders. Zoom is at 100% but also tried 90% and 110%. No difference. Have used Chrome and FireFox. Cleared Cache. Trying to access Public folders using Windows 10 on a laptop PR2100 firmware is up-to-date (updated a few days ago).
Makes the PR2100 My Cloud worthless as a Cloud. Can’t believe this is still unresolved! Deserves a one star rating on Amazon.

To clarify, the 30 row problem is cloud access to a PR2100 via the Internet on a Windows 10 laptop using either Chrome or FireFox. LAN access works fine. LAN access isn’t Cloud access so maybe should not advertise as a personal cloud. Or maybe a partial cloud (partly cloudy?).