Not seeing all my files and folders in MyCloud

Agreed.
The unit itself of cloud access is not impaired.
But if the issue is well documented, it should be addressed and solved.

P.S. SyncToy is .exe only. I’m on Mac.

Those views show you are looking at the WD Sync folder.

Your WD Sync isn’t working. It is creating the folder structure, but not copying files. This appears to be a regular problem

As I said above, I would suggest not using WD software unless you really have to.

FreeFileSync is multi-platform.

In fact, no need : Apple Sharing (WiFi or Ethernet) is recognizing WD Mirror.
News for WD : Apple software works.

WD Support is a JOKE.
One week to reply.
Another 4 days to reply to the reply.
Give a link to upload logs files, but link is nowhere to be found.
Ridiculous.

The log files will probably be too big to get to them, anyway…

No. They’re zipped, following procedure. 2.9 Mb.

My zipped log files were about 50MB… Maybe their ‘procedure’ has been updated to tell users to rip out all the unnecessary stuff. That’s good…

Maybe. But their link to upload is inoperant.
Sloppy.

Hi,
I bought a WD My Cloud Ex2 Ultra 3 days ago… and very disappointed as I discover a lot of issues with it !
Isn’t the first purpose of WD mycloud items to be available from external network ?
I am using Chrome and have the same issue… I only see about 30 documents in a folder (instead of about 3000 !) ==> How can we rely on this kind of bullshit application ?? It is not even able to give you the total number of files and size of a folder.

Don’t understand why WD support does not consider this as priority !
I have a synology and I understand now why I paid more for it

Sadly, it’s a well-known problem that the mycloud.com portal doesn’t work well with a number of browsers. See these threads:

https://community.wd.com/search?q=mycloud.com%20files%20category:105

No. the primary purpose of the MyCloud family of network attached storage devices is to be a local NAS: a file server and media server. The ‘Cloud’ bit is something of a bolt-on afterthought.

Whilst your comment has general application to the MyCloud family, in future, you might want to direct EX2-specific questions to the EX2 sub-forum:

Us users on this sub-forum won’t generally own EX2 devices. Those on the EX2 forum are more likely to have experience with them.

1 Like

I am having the same problem with Chrome. For awhile Firefox would allow me to view all the files on the drive but now that has stopped working as well. I disagree with the replies saying this is not a major issue if the device still functions on the network, because I am unable to delete any files from the device, I can only add. Please fix this!!!

For LOCAL network access one does not need to use a web browser to upload/download files. One can use Windows File Explorer, Mac Finder or any other file manager. For REMOTE access to the My Cloud is where using a web browser to access the MyCloud.com web portal using Chrome may be an issue. One can try using the My Cloud Desktop software, or use the My Cloud mobile apps for iOS and Android.

One troubleshooting step to try, if one hasn’t done so already, is to ensure all plug-ins are disabled. Certain plug-ins like ad block plug-ins like uBlock may cause certain problems with the MyCloud.com web portal interface.

Can you use Windows File Explorer if you have MySync turned off? That software wreaked havoc when I had it activated.

MySync? Do you mean WD Sync or is MySync something different?

WD Sync is independent of Windows File Explorer. For local network access to the My Cloud one does not need to use any WD software. One can use third party programs to perform backup or syncing. One can map the My Cloud to their local network computer for easier access in Windows File Explorer or Mac Finder.

https://support.wdc.com/knowledgebase/answer.aspx?ID=2676

https://support.wdc.com/knowledgebase/answer.aspx?ID=2686

For local network syncing one can use Sync Toy (https://www.microsoft.com/en-us/download/details.aspx?id=15155) or Free File Sync (https://www.freefilesync.org/). For local backup there are a number of free programs like the following.

EaseUS Todo Backup Free: http://www.easeus.com/
Macrium Reflect Free: http://www.macrium.com/reflectfree.aspx
Paragon Backup and Recovery 14 Free: http://www.paragon-software.com/home/br-free/download.html

Yes I meant WD Sync, sorry. I don’t really like to use sync programs, I prefer to manually manage the files on my drive. But I will try to map the drive to Windows and see if I can get that to work. Thank you!

Well my goodness, that turned out to be the solution I needed. Wish I had posted in here a year ago, thank you!

Well do that then…

You do not need to use ANY software (WD or third party) to transfer files between computer and NAS. You just use your favourite file manager on a share mapped as a network drive. Read the manual or Google for instructions on how to map MyCloud Shares as network drives.

[edit] I see you have now successfully mapped shares. You might find other useful insights into using the device by reading the user manual…

Hi, just trying to decrypt the various threads on the subject of ‘limited file viewing from a PC browser’ - bear with me on this.

So far: I’ve just installed 2TB MyCloud for home use, photo sharing etc. We have iphones, Ipads and Windows laptops.
The issue: From a laptop browser we can see no more than 30 files.

Having downloaded 24Gb of files to the drive, we can see and access all the files from the iphone’s and ipads using MyCloud app’s, however not from the laptop browser. Tested both with IE and Chrome. Mapping a drive is not an option for us, as we would like remote access. I’ve tried rebuilding the database…no change. In summary, if I have read this thread correctly, there potentially is no way round this, with a PC browser based access to the files, by a user.

Thanks for any comments (polite or otherwise :wink: )

On a side note, I notice the date format on the browser is different to the Dashboard/ADMIN and IOS APP (laptop: MM/DD/YY…Admin setup / IOS view: DD/MM/YY)

1 Like

Have you downloaded and read the User Manual…?

For access local to your network, drive mapping is by far the best method.

For remote access, you will need to create a mycloud.com account, and send an authorisation code to the accessing device.

US date format on laptop (probably taken from your windows system settings). More sane date format on Dashboard/iOS.