New Release Firmware Release 04.04.02-105 (1/27/2016)


#84

AZagnit, check the Dashboard to ensure LED is set to On. See Dashboard > Settings > Energy Saver > LED = On.

Edit to add: Also when the drive is in sleep mode (another setting within the Dashboard) the Blue LED will slowly pulse in intensity and may appear to be off.


#85

Hi Bennor,

Thanks for your quick reply.

Removing the old share en renaming the new “elements_2” to “elements” as described in the reply of davies0121 seems to do the job.

This solution saves me a lot of time, rather than the time I would have spent on reformatting the USB backup disk and making a new safepoint :wink:

Kind regards,

Marco


#86

From the various posts, it appears as if there are variation in the errors caused by this latest firmware.

1/. I have 4 re-entries of my Backup HDD which once deleted and the remaining (that with the data) entry returned to the original name - my Safe[point reappeared after a re launch of the Dashboard.

2/. The auto update was turned off and my settings were deleted. I had foolishly only checked Notifations and no updates had run. A manual start appears to be working. People out there are probably thinking their Safepoint are still working, until they check properly.
WHAT I FAIL TO UNDERSTAND IS HOW WD ARE SO COMPLACENT ABOUT THIS


#87

PLEASE NOTE:- THAT THE MANUAL SAFEPOINT IN MY EARLIER POSTING, WHICH APPEARED TO WORK, HAS FAILED.WITH A NOTIFICATION AFTER APPROXIMATELY 5 HOURS.
For some reason I keep getting a refusal to post because I have been too brief so I added this rubbish


My experience with a WD My Cloud Gen 2 (RMA)
#88

Same problems here after latest firmware. I ended up doing the full restore took 20 hours on my 4tb. After setting everything back up and copying files back…another 3 days over wireless. Everything is working again except my auto safe point to an external my passport ultra drive. If I manually update the save point it works but setting an auto backup time it never goes. Regardless of what time set.
WD response is they know of the problem and they’re working on it.


#89

I came from a super old firmware (04.00.00-607) and I’d like to share my experiences on the new firmware so far.

First of all, I have applied the same amount of tweaks that I have applied when I was still on the 607 firmware, just to make the testing fair. The tweaks I have applied are simply disabling thumbnail caching and Netatalk, as well as disabling Twonky which I don’t use. I’ve turned off media scanning and DLNA completely. I’ve done all my tests on a Windows 10 running on 512GB SSD and the copies are always a single large file that is 3GB in size.

On the old firmware, I remember I used to get write speeds of up to 60MB/s (note, it’s megaBYTE here) and read speeds of up to 80MB/s. This is when I connect my PC to my router directly via a Cat6 ethernet cable. If I use WiFi AC (while sitting next to the router), I get about 30MB/s even though Windows tells me my speed is 890Mb/s (which is 111.25 MB). The performance was OK.

Now, I’ve updated to the latest 105 firmware and the performance dropped quite heavily. Everything works, SafePoint, MyCloud.com etc, but the performance has been poor. Now I get about 35MB/s write and 60MB/s read while connected via ethernet (same setup, same router etc). On WiFi AC, I get about 19MB/s read and 7MB/s write (again, I’m sitting next to the router and Windows shows my speed as 890Mb/s).

What I know:

  • It’s not because WD My Cloud is caching or doing content scans. I’ve disabled that via the tweaks and can see it says IDLE on the dashboard. It goes to sleep perfectly well when it’s not in use and it doesn’t overheat or run hot. It’s not an issue with the CPU etc.

  • Ethernet cables are fine, I’ve tested a copy from one PC to another over SMB and it’s around 90MB/s. 1 gigabit connection gives you about 125MB/s so while it could be higher, at least it’s acceptable and I know there are some variances to take into account anyway.

  • I’ve tested the transfer (read & write) to my WD My Cloud several times via SMB and FTP. Generally, FTP gives me slightly faster speeds (by about 1~2MB/s) but it’s roughly the same.

  • My PC is not the bottleneck here. I know there’s a lot of CPU utilization using Windows Explorer to copy the files, but my CPU averages about 7% utilization during the transfer and I have killed all background/foreground processes during my tests. I’ve got a decent i7 CPU and plenty of RAM (16GB) so nothing is bottlenecking on my PC.

  • No other users accessing shares other than me during all testings. In fact, I’m the only one that uses WDMyCloud and I only use it for storage.

Other than that, I’m happy with the rest of the firmware. Safepoints work well and MyCloud.com works for me again (since WD2go got replaced). On the old firmware (607), I didn’t have issues with anything, but I chose to upgrade just so I can get the latest security fixes and features.

I’ll probably stay on this firmware but just thought I’d share my results.

********************** Update **********************

Seeing as someone posted a few Crystal Diskmark screenshots, I thought I’d do the same. I’ve done my tests using Cat6 ethernet 1Gb connection. Surprisingly, my results on my 3TB WD My Cloud seems to have higher read speeds than when I get copying from WD My Cloud (as mentioned above).

While the read speed looks better on Crystal Diskmark, the actual speed I get when copying via SMB (either network location or mapped drive) to/from the WD MyCloud is slow. Even on FTP it’s still the same.

********************** Update 1.5 **********************

Did a few more tests and it seems CrystalDiskMark reports the proper actual real-life results this time, so ignore the one above:

And here’s my usage on WiFi AC (890Mbits/s sitting right next to my router:

The write speeds as you can see in all screenshots, are terrible. Read speed is bad too but not as terrible as write.

What’s interesting is I found these articles here which has similar results to mine, so I’m unsure whether this is NORMAL or not:

Link1
Link2
Link3


Furthermore, this thread here says he got 90MB/s read and 80MB/s write on a gigabit network:

My write speed is half of what he got and that’s just terrible. My Safepoints are not running and everything is idle. WD My Cloud is nice and cool so nothing is using its resources (CPU, memory etc).

My router is an AC router and the LAN ports are definitely gigabit ports. I can see the connection showing as 1Gb on Windows and it’s full duplex.

Obviously like I said, I’ve had much better speeds before on an older firmware. But having read those articles, it seems like the results I got are within the acceptable variance range? I want to think it’s normal, but at the same time I can’t just ignore the fact that I’ve had much better performance on the same device in the past.

********************** Update 2 **********************

Ok, did some more tests just now and I can confirm the bottleneck / issue is definitely on my WD My Cloud. I wanted to make sure the issue wasn’t with my router or my cables, so I took out my old AC router (Netgear D6300) and did all the same tests I’ve done above on there. Tested both gigabit ethernet and WiFi, same results.

I’ve then done the same test but this time connecting directly from my laptop to my WD My Cloud via ethernet. So basically, no routers or switches in between, just a direct connection with a 169.x.x.x address. Same result, the performance speed is the same.

This shows that after the firmware upgrade, my WD My Cloud dropped its write performance by almost half. The read performance shows 109 MB/s in CrystalDisk Mark, which looks good on paper, but the actual performance I got by copying via either SMB or FTP was no where near that.

********************** Update 3 **********************

So, I ended filing through a RMA and have just received my replacement unit yesterday. I’m now very very happy with it!

First off, I have made no changes to all the testing methods and equipment. Still the same gigabit router, same ethernet cat6 cable that I’ve used, etc. Software wise, all the same version and build, including Windows (I’ve tested on WIndows 10 build 10586 btw).

Here are the results, both CrystalDisk Mark, native SMB copy and also using TeraCopy v2.3:

This is tested multiple times and the speed stays consistent.

Now, what’s really generous of WD is that they actually sent me the WD MyCloud 3TB Gen2. It’s using firmware v2 rather than v4 for Gen1s, and I can see this on the dashboard as well:

Also, I’m updated to the latest Gen2 firmware as of this writing:

One thing I must stress is all testing were done with the factory, out of the box settings. I have not disabled Twonky, have not enabled FTP or even tested FTP (I probably should and will at some point), and most importantly I have not applied any tweaks. The device goes to sleep well and doesn’t have any issues so far, so I think compared to my crappy Gen1, I don’t really have to apply many tweaks to make it run smoothly.

More importantly, the actual performance stats I’ve got here is quite impressive. I’m really happy with the results. Many thanks to WD for providing me a Gen2 as they didn’t have to do that.


My Cloud Gen 2 vs Gen 1
Firmware upgrade overwrites or upgrades on top?
Performance Benchmark Results
Debating on a Second MyCloud
Wich is the max link speed between my router and macbook pro 2013 can i get, 80/100mbps?
Getting about 230mbps when copying from my PC hard drive to the My Cloud drive via router, is this slow or fast?
#90

What OS are you running on your PC?

Paul


#91

Here is what I have PC running Windows 7 on a gig Ethernet with many Raspberry Pi’s for watching TV
WD MYCloud 4tb v04.04.02-105 with a MYbook 4tb 1230 hooked up to the USB of MYCloud everything has been running smooth until I updated to the latest firmware on mycloud :frowning: When the firmware finished and after the reboot the USB drive got re-assigned to a new location so I remapped it to a drive letter “W”. That was a pain ! had to go around an update all my systems… Well as of today ! I can no longer see the USB drive on my PC or any machines. Come to find out Mycloud corrupted the drive. When I plugged it in to the P.C. with USB cable it needed scanned and repair, so I did.
Plugged it back into Mycloud used the UI it shows the USB drive installed but still not showing up on my PC

  1. did a reboot of the cloud
  2. 40 second reset
    And it still shows up on the MYCloud UI but not on my PC…HELP !! The drive is fine when I plug it directly to my PC. Both Drives are less then a year old …Hoping someone has the solution

I copy pasted this from my thread. Since basically I have the same problem ! What is the solution Ive tried the renaming and that didn’t work. Has anyone tried to roll back the Firmware successfully ? And if so which version ?


#92

AND WHY DOESNT WD stop this new firmware !


#93

Not sure why you would say that. After the initial issues with old safe points, I’ve had no issues.


#94

Well just tried to manually to go back to older firmware sq-040401-112-20151013.deb and I get a Error •Device does not have enough space for upgrade. !

Its a 4tb drive with 148 gig left on it ! Now what do I do…


#95

The amount of free space (148GB) in your case for your data files generally has nothing to do with the space the My Cloud OS needs to perform a firmware upgrade (or downgrade). To properly downgrade there are several ways to do so. See the following thread for one such method. See the thread following that one for links to prior/current firmware to ensure your using the appropriate firmware for your My Cloud.

https://community.wd.com/t/easy-method-to-downgrade-to-previous-version-of-the-firmware/93489

https://community.wd.com/t/wd-my-cloud-v4-x-and-v2-x-firmware-versions-download-links/148533


#96

Well I followed the instructions how to roll back and Mycloud is now rolled back UI can see the USB drive all the settings are correct and my PC can not see the drive !


#97

Interesting analysis with drive performance. I used Crystal Disk Mark to benchmark my My Cloud Mirror Gen 2. Here are my stats after 24 hours of uptime. I’d be curious to see your numbers. I put my defective My Cloud 4TB for reference.

Windows 7 Ultimate x64

My Cloud Mirror 8TB Gen 2
2.11.133
Device Uptime 0 day 23 hours 17 minutes

My Cloud 4TB


#98

Snakedoctorunit, interesting numbers. However it should be noted that the My Cloud Mirror Gen 2 does not use v04.04.02-105 firmware (the topic of this thread), it uses v2.x firmware (2.11.133). And the hardware may be different than the hardware on the v4.x single bay My Cloud units which are loaded with the v04.04.02-105 firmware.

You may want to post that information, if you haven’t done so already, to the dedicated My Cloud Mirror subforum so others there can comment.

https://community.wd.com/c/personal-cloud-storage/wd-my-cloud-mirror


#99

True @Bennor - I wanted to see if using the disk benchmark utility if performance stats can be reported by multiple owners to see if a trend presents itself. I did include the benchmark for the 4.x version from the defect My Cloud 4TB single bay.


#100

What trend are you looking? Because the hardware is probably different between the Mirror and first gen My Clouds the performance stats will in all likelihood be an apples to oranges comparison. At best people can compare your faulty 4T My Cloud to theirs to have an apples to apples comparison.


#101

if we correlate by model and generation when capturing the statistics, then we can present the data back to WD for analysis. Yes, the base hardware between Gen 1 and 2 is different and the underlying OS changed too. What hasn’t changed that much is the auxiliary daemons. Orion, apache httpd, twonky, RESTful API are prime examples.


#102

What are you hoping WD would/will do with those statistics and analysis?


#103

if people are experiencing performance issues after a certain threshold (e.g. uptime), the benchmarks in aggregate can help with the analysis or prove there is a problem. Yes, we would have to look at apples to apples, then oranges to oranges.