My experience with a WD My Cloud Gen 2 (RMA)

Hi all,

A few days ago, I’ve received my replacement unit for my WD MyCloud 3TB Gen1. To my surprise, WD gave me a Gen2 MyCloud instead and that was really generous of them. Anyway, I thought I’d share my experiences with the Gen2 so far.

Overall, I’m really happy with it. I’m getting an average of 90MB+/s read and write, for more detail please read here:

I was also able to create a backup (it’s not called SafePoints anymore) with ease, and it actually backed up a lot faster than on the Gen1. I backed up about 500GB in less than 15 minutes or so.

The ONLY issue I have is that it doesn’t seem to recognize a lot of my external HDDs. I’ve tested the following:

  • 1TB Adata (works)
  • 1TB Samsung (doesn’t work)
  • 750GB Samsung (doesn’t work)
  • 1TB WD (works)
  • 1TB WD Blue (works)
  • 1TB Seagate (doesn’t work)

I’ve also tested a Transcend and SanDisk 16GB and 32GB USB flashdrive, both work OK.

I’ve tested both NTFS, ext4 and extFat for the none working drives. It just doesn’t detect it in MyCloud (shows up fine in Windows). I’ve always wiped the entire partition for all my testings.

What scared me a few times is that when I plugged in the non-working drives, the led on the MyCloud turned red after scanning it for a few seconds. I thought the actual unit is dead, but after unplugging the USB cable it turned blue again.

Restarting MyCloud with the USB plugged in doesn’t help either. I’ve tried a lot of stuff and it just won’t recognize them. However, those were recognizable by my old Gen1 MyCloud.

So I would say, get either an AData or WD external HDD if you want to use backups/SafePoint.

The other issue is that on the Gen2 firmware (I’m on the latest one btw), there is only a reboot option, not power off. On Gen1, you can power off from the dashboard, so I’m not sure why this is removed from Gen2. What’s annoying about this is if I powered off the unit and then power it back on, it’ll do a consistency scan/check on the drive. If you then take a look at the logs/alerts, you’ll see that it says it was powered off unexpectedly or something about losing power, which makes sense. I’d rather power off the device gracefully from the dashboard but there doesn’t seem to be an option.

Other than that, the performance is really good and stable, I’ve gotten high read/write rates that are even better than some of the review sites out there, so I’m happy with this.

Did you try re-partitioning and then reformatting the drives that were not recognized by the My Cloud? I found that one drive, a Toshiba 1T external USB 3.0 drive wouldn’t be mounted by the OS 3 firmware. I re-partitioned and reformatted the drive in a Windows 7 PC and it was suddenly recognized and properly mounted by teh My Cloud OS 3 firmware.

There is a lot more on my experiences, including lots of logging information, in another thread starting with this post:

Bottom line in my case was the default out of the box partition and formatting the drive came with, while it was mountable under the v3.x My Cloud firmware, and worked in all other computers (Windows Vista, 7, 10 and Linux), simply wouldn’t’ mount properly under the OS 3 v4.x version My Cloud firmware. Re-partitioning and reformatting of the external drive fixed the issue.

Yup, I did all that.

I’ve tried diskpart and using different disk allocation sizes. Also tried MiniTool Partition Wizard and also diskmgmt.msc. Nothing worked.

I’m glad I have tons of hardrives to test with though (I work in IT and networking), so at least I got it working.

500GB in 15 minutes? That would be about 555MB a second. If I did my math


Your maths is correct. Well, technically that would be 499500MB, which is 499.5GB. But it’s more or less correct.

USB 3.0 can copy up to 625MB/s (theorectically), so it’s pretty amazing that it did it at 555MB/s. It’s definitely faster compared to my Gen1.

If WD could fix their firmware and update it to support more external HDD models, and add the “Power Off” option back to the dashboard, that’d be great. So far, Gen2 is worth the purchase, it’s definitely offering a lot more than the competitors.

I recommend that anyone with a faulty Gen1 should get it RMA’d. You never know, you might get lucky and receive a Gen2 like I did. At the very least, you’ll get a replacement unit, don’t wait.