Firmware 04.04.04-101 (9/20/2016) Discussion

Apparently a new firmware version, 4.04.04.101 has been been released for the older generation single bay My Cloud units.

Release notes: http://support.wdc.com/download/notes/WD_My_Cloud_Firmware_Release_Notes_04.04.04-101.pdf

Firmware Version 04.04.04-101 (09/20/2016)
Resolved Issues:
Resolved issue where macOS-10.12 user is unable to create a new Time Machine backup.

Direct firmware link: http://download.wdc.com/nas/sq-040404-101-20160902.zip

Link for firmware not valid yet.

RAC

Its busted on WD’s end. If one does the automatic upgrade within the Dashboard the OS will download the correct firmware and update to 4.4.4.101 (did mine this morning). The link for the updated 2.21.119 firmware is working.

Still no announcement post (as of this post) to the Latest News& Announcements section for both these firmware versions.

Just went to my Dashboard and did ‘check for updates’. Yes, it’s showing update is available.

Do I want to download, with all the pain that involves to get things running again? I’ll check the release notes…

This popped up a “MyCloud will now download the new firmware and reboot” dialogue.

DON’T YOU DARE. There’s a reason I have auto-update turned off, and I tried to check the release notes before manually updating. LET ME READ THE RELEASE NOTES AND THEN DECIDE IF I WANT TO UPDATE. That’s why i hit ‘Release notes’ and not ‘Update now’.

‘Cancel’. It’s a good job that’s there, otherwise I would have been furious, rather than merely angry…

Thanks for reporting the issue with the 4.4.4.101 manual download link.
We’ll get it fix ASAP

The link worked just fine for me just after 9AM EST this morning.

Yeah, I see it’s busted right now!

Still destroys my Twonky settings !! :rage:

You can get around that by modifying user-start to sort out the mess after a reboot (only needed after firmware upgrade, but it does no harm to do it every re-boot.

Choose the bits you need from here:

The link is now working.

RAC

any bugs we’d like to know about ?
will it break safepoint backups ?

I installed the 04.04.04-101 firmware version this morning before the scheduled time of a safepoint update. It appears the safepoint ran as expected. I got the normal “successful” email notice and a quick peek at the share showed files that had been created since the firmware was installed. FWIW, I ran the manual installation. I like to have a copy of the deb file for several versions just as a precaution.

thanks for the feedback.
i’ll prepare to upgrade the firmware soon, going to do some final backups and save config files before i do it.

Cheers thanks for the help, but we shouldn’t really need to dlo this sort of thing.

Updated and so far no issues. My MC runs 24/7 so sleeping problems are not an issue. And shares now show more or less properly broken down into pics, music etc. Were xxxGB of “other” for the past few f/w updates.

Seems WD hires script kiddies, still. Sorry WD.

No, we shouldn’t; see my opening comment in the FAQ…

I am still running firmware 4.01.04.422 What is the problem with Twonky after the updating ?

Thanks

Certain Changes made to Twonky, either through the Twonky administration page, or using SSH to tweak the Twonky settings are destroyed/erased when one upgrades the single bay My Cloud firmware.

See the unofficial Twonky FAQ at the following link which has a list of user suggested “best practices” with the Twonky media server.

https://community.wd.com/t/faq-twonky-dlna-media-server-setup-use/95373

After update to sierra and latest firmware TimeMachine does not backup. I can mount the shares via finder fine but seems likes TimeMachine has issues. Also tried several accounts with same results.

The network backup disk could not be accessed because there was a problem with the network username or password. You may need to re-select the backup disk and enter the correct username and password.

For clarification, It finds and adds TM share properly. The issue actually occurs when it tries to start the backup.

@Bill_S

Still no official notification thread…