Firmware 04.04.04-101 (9/20/2016) Discussion

I’m sorry, cpt, I’m not understanding what you’re referring to.

https://community.wd.com/c/personal-cloud-storage/wd-my-cloud



Previous new firmware releases have been announced with sticky threads on the relevant forum.

Three of these obsolete notifications are still extant in the ‘latest threads’ list.

But there are no notifications for the newly-released v2 & v4 software, barring these discussion threads that Bennor was good enough to post.

Have you decided not to publish firmware upgrade notifications, or have you decided to leave it up to your customers to do it?

Aaahh, I’m sorry. This was a bad decision on our part. You’re right. I should always post an update to the threads to prevent confusion. I will from now on. Thanks for calling me on it.

Does the Scanning ever stop? I have DLNA and iTunes turned off and the home screen shows Scanning. Its why my drive never sleeps.

After upgrading to this firmware my ssh doesn’t work anymore. No matter how many times I’ve changed my password through the webgui but ssh simply refuses to let me in. I had set up ssh keys so I could login without password but now even with password I cannot login. I have also tried with root and admin accounts!

Is there a way to reset ssh configuration from the gui? I have tried to stop and start ssh service but that didn’t help as well.

HI,

After 9/20/2016 update my cloud access has stopped working. Is anyone experiencing the same issue??

When did you do the update? As of right now the WD My Cloud web service is having some issues. You can find more information at http://status.mycloud.com/

I’m having also the same issues

Connection Status Connecting
Trying to establish a remote access connection…

This is very very very frustrating

My router is connected

even now wdmycloud status is connected

but cannot access from outside my local network…

from iPhone using app

and from the web:

1 Like

I’m really excited to try this firmware. Now, the trick is to get the stupid thing working long enough to update it. Great product.

I usually find that after mycloud or router reboot, I need to toggle the cloud access control to re-establish the remote connection.

The ‘connection status’ does not reflect the real-time state: it appears to be a historical marker that port forwarding was established at some point in the past, and not that it is currently connected.

You must have a very low threshold of excitement…

No, no, my MyCloud has been unreliable for awhile now since updating to the last firmware. Before that, it was… good. Hopefully this gets it back up to that.

I have changed cloud access from automatic to manual, then disabled access and re enabled and status changed from connecting to connected (ja ja )
I can access from lan and ssh, so the problem seems to be in WD servers access control.

Is it possible to rollback to previous firmware?


Now Web access is working and app (IOS ) NOT

In the app, use ‘manage devices’ to remove the mycloud, then re-connect. If you do this local to your network, you will only need your mycloud user password, not your mycloud.com account details.

Yes I already did that and generated a new access code. Only in local network the NAS is discovered.

But If I use 3G-> access from outside I can’t access the NAS.
Using wifi it works.

I’m feeling like a WD beta tester

Yes one can roll back but it may depend on your version. Most if not all roll back methods are for the older first gen v4.x My Clouds. Unknown if those methods will work on the newer second gen v2.x My Cloud. See the following link:

https://community.wd.com/t/wd-my-cloud-v4-x-and-v2-x-firmware-versions-download-links/148533

On the iOS app problem. As indicated at the WD status link lluna posted earlier there were some problems with MyCloud Account Logins. While that status update claimed remote apps were not affected its possible they might have been.

If the iOS WD App worked in the past but doesn’t today did the iOS device get updated recently? Sometimes removing the app and reinstalling it may fix some issues.

Okay,

I didn’t change anything on my MyCloud drive, and I just got time to check and my cloud access is working fine using WD sync, iOS and Android app.

So it must be something on WD end that was causing issue.