Suppoted devices for macOS 10.12 Sierra

Hello,
my question is simple: Is/will be there any list of WD myCloud compatible devices with macOS 10.12 Sierra.

Precisely: Will by my device MyCloud (1st gen) compatible with TimeMachine backup on macOS 10.12 Sierra?

Thank you

This is a User Support Group … basically users helping other users … not WD Support. Your question should probably be best directed to WD Support. We have no control over what WD plans are. You can contact them Here

You should be more concerned with Apple changing something within the OS 10.12 that makes the OS work poorly with NAS devices like the My Cloud. As we’ve seen in the past in these forums OS makers at times make changes to their OS that erroneously gets blamed on the My Cloud. Currently people are having problems with El Capitan (and Time Machine on El Capitan) and the My Cloud.

2 Likes

I will test it out today(about 6PM GMT) and I will let you know if it works in the 1st beta… also please keep in mind that this is beta until fall so even if its working/not working it might be completely different when its released in fall :slight_smile:

EDIT: both afp and smb works just fine :slight_smile:

And what about TimeMachine backup functionality?

-Thank you

oh sorry… forgot about that…:smiley: tried it and it didnt work… well it didnt find my NAS… dont know If I was supposed to restart the nas after turning the feature on but it just didnt show up… not even after I mapped the share I needed in Finder… as mentioned before its beta… might get fixed by the time its public

Anyone tried to see if the new beta enables us to use time machine with My Cloud?

TimeMachine still doesn’t work with macOS Sierra Public Beta 6 :confused:

1 Like

There is the reason, why TimeMachine stops work in macOS Sierra: https://developer.apple.com/library/prerelease/content/releasenotes/NetworkingInternetWeb/Time_Machine_SMB_Spec/index.html#//apple_ref/doc/uid/TP40017496

Can you elaborate on the reason ?

Apple abandon AppleTalk protocol for TimeMachine Backup function in macOS 10.12.
So if you want to use TimeMachine on network storage, you have to use SMB2 protocol.
AFAIK WD MyCloud (1bay, FW:4.x) use AppleTalk&Bonjour technologies for TimeMachine feature only.

Now (OS X 10.11 and earlier) it look that you enable TimeMachine feature on WD device and it appear in macOS System Preferences->TimeMachine automatically and if you use TimeMachine Backup this way you don’t see any new drive (disk icon) on Finder’s Desktop. Even you cannot care about lost connection to WD MyCloud TimeMachine - reconnection is auotomatical.

Because I haven’t installed any macOS 10.12 Sierra on my computer I cannot better describe where is the core of problem – but user “mefistos” wrote about problems with TimeMachine here.

All devices from My Book Live are gonna be supported by Sierra. I guess within today or tomorrow they will release a firmware to fix this change with Time Machine.

Actually I found already a KB with the fix for the My Book Live devices.

And My Cloud.

1 Like

hello all,

i do not use time machine - rather i choose to image my entire macbook pro using clonezilla --> external usb drive.

about sierra:

i do want to upgrade, however i need to clear on a few points with regards to how the mac interacts with my cloud:

i have been using for a long time now an app from the app store called drive mounter. i paid for it, because at the time i did not see a way to consistently auto-mount my nas drives when i boot in or wake from sleep.
first of all, can i get away from using this app ? how to do that … and will sierra reliably auto mount the drive again ?

which network protocol to use, smb or afp ?

is it better to do a time machine backup now, and instead of upgrading - wipe clean and install sierra from internet recovery ? afterwards restore the time machine backup ?

04.04.04.101 and 2.21.119 went live today.
Stay tuned for 2.11.153 for Mirror, EX2 and EX4

I see no announcement in the sticky threads.

Yeah, LOL at that. :slight_smile:

Started the usual discussion threads anyway: