Firmware 04.04.04-101 nightmare


I have a 4TB my cloud and have been very happy with it.

I upgraded the firmware yesterday and now my video playback is all over the place.

In general I access cloud media content through my iPhone and iPad. My iTunes library has been living happily in the cloud for some time.

However since yesterday’s firmware update the following files are apparently not playable:


I get bumped to a safari window where nothing happens or am told the file format isn’t supported in the app.

Have I missed something? Has anyone else had this problem? Does anyone know a fix.

Apologies in advance if this is a stupid question.


You may want to read through the Firmware 04.04.04-101 (9/20/2016) Discussion thread, if you haven’t already, as some are reporting issues with iOS and the latest v4.x update:


Thanks for the tip. I thought I had, but I read through again. Tried deleting the app from my phone and reinstalling it but still got the same result.

It’s been brilliant up until this firmware update…


Have also discovered that some music purchases won’t play as well.

Apple is the common factor but logically an Apple file should play on an Apple product and this only started after the firmware update…hmm very confused.