MyCloud remote access using Linksys router

For many years I have successfully accessed my MyCloud NAS remotely. I have just moved to a new Linksys router (WHW0301GC). On the router, I have reserved a specific IP address for MyCloud, set up Single Port Forwarding for ports 80 and 443, disabled UPnP Express Forwarding, Client Steering and Node Steering. MyCloud looks fine with Connection Status “Connected” and "Port forwarding connection established”. However, I can’t access MyCloud remotely getting “Something went wrong” message on the IOS App.

Has anyone else experienced similar – help appreciated?

@omeganet1

What My Cloud NAS device do you own? What OS/firmware? What is set up in the Dashboard for remote access (Cloud Access)? Click on, tap, or activate image to enlarge it.

Hi cat0w

I have the original My Cloud device. Firmware - WDMyCloud v04.05.00-342 : Core F/W.

Couple of suggestions. First, make sure you are not using the OS5 My Cloud app on your iOS device. Make sure to use the older WD My Cloud app (https://apps.apple.com/us/app/wd-my-cloud/id450655672).

Make sure you can really access the My Cloud remotely by accessing it through the MyCloud.com web portal.

One may have to delete the existing entry in the My Cloud App for the My Cloud device then create a new entry (or re-associate the My Cloud) in the app. This may involve having to generate a new mobile app “code” using the My Cloud Dashboard > Cloud Access tab.

Hi Bennor

I confirm I have the correct app and can successfully access my device through MyCloud.com.

I have:

  • deleted and reinstalled the app
  • deleted all my cloud devices using the web interface
  • connected from the app to the device both through mycloud.com and using code activation. In both cases I can see the device while on wifi but on dropping off wifi and using the 3G network I get the following:

Regards

Further information. Accessing my device using mycloud.com using a 4G (non-wifi) connection does on work either.

Looks like a problem with your cellphone or the cellular provider’s data connection if you can access on WiFi but not on the cellular data connection. Try contacting the cellular provider to see if they are blocking anything (DNS servers, whitelisting/blacklisting websites, etc.) Also check the phone (or mobile app) settings to see if there is a block on the app using cellular data.

Hi Bennor

It’s not the phone or celluar provider - it all worked just fine ysterday when the Mycloud device was connected to my old router. The app has Mobile Data enabled.

Regards

Have tried just about all I can think of:

On the router, I have:

  • disabled IPv6
  • unchecked Application Layered Gateway SIP
  • checked/unchecked Internet Filters, Filter multicast

On the MyCloud device deleted connections and recreated them.

Rebooted everything mutliple times.

All to no avail.

It seems that these days there is problem with the remote access. Maybe it is coincidence that you have problem with the connection. Try the old router, if it works, it is a matter of tuning the new one, if it is not working, you will have to wait till WD fix the problem.

I have the same problem here in italy.
Everything works fine for years but starting from 2-3 week ago i have the same problem.
Everything work on my home network but when i’m outside home using IOS app i cannot connect to my cloud device.
This is really strange

Sto bestemmiando in 8 lingue diverse. Il WD mi risulta connesso e la “Connessione port forwarding è stabilita” ma non riesco ad accedere da remoto…

Vedo che non sono l’unico che sta impazzendo con questo problema.
Ieri ho avuto una chat a dir poco “scandalosa” con il supporto tecnico della WD.
Il loro tecnico sosteneva che fosse un problema di rete 4g.
peccato che non funziona nemmeno dall’ufficio con connessione wifi.
L’accesso remoto non funziona! C’è qualcosa che blocca l’utilizzo dell’app da remoto.
Anche l’accesso da interfaccia WEB con PC funziona solo se sono dentro casa collegato con la rete domestica, da remoto non funziona.
WD dovrà rilasciare un firmware o un agg delle APP a breve perchè qui se no diventiamo matti!

Write in English, so everybody can understand you! This is international forum, not Italian one!

I see that I’m not the only one who is going crazy with this problem.
Yesterday I had a “scandalous” chat with technical support from WD.
Their technician claimed it was a 4g network problem.
But it doesn’t even work from the office with wifi connection.
Remote access doesn’t work! There is something that blocks access to disk remotely.
Even access from the WEB interface with a PC only works if I am inside my home network, it does not work remotely.
WD will have to release a firmware or an APP update shortly because otherwise we will go crazy here!

No remote access for three days here. Everything is fine on my PC at home.

Just to update: as a test I reconnected by the MyCloud device to my old router / DSL service. I can successfully access the MyCloud device remotely as previously - i.e., using my mobile over the internet (not WIFI). So, this confirms that the problem I’m experiencing is to do with the combination of my new fibre service / Linksys Velop router and MyCloud device when even with a port forwarding connection established, I cannot access MyCloud remotely. The problem has nothing to do with my mobile, the app, or cellular provider.

WD Community,

  1. Reboot your My Cloud device
  2. Logout of MyCloud.com
  3. Check your remote access connection again

Still failing?

  1. Collect the system logs
  2. Send to support
  3. Let me know your case numbers

Hi S Brown

Thanks - case number #210716-000222.

Gerard

Need the system logs attached please