My Cloud OS5 - Only connection type relay possible

Hi,

I updated my “My Cloud EX2 Ultra” to OS 5 and I have noticed that only a relay connection is possible.

grafik

Before with the OS3 it was a direct connection.

UPNP is activated in the router settings and also the independent port release for the My Cloud device.

With OS3 the My Cloud ports were activated but with OS5 it no longer works.

I have an AVM Fritz! Box 7490 router with FRITZ!OS: 07.21.

Does anyone have any idea why port forwarding via UPNP no longer works?

Same configuration same issue here. WD support please!

1 Like

Interesting,

I dont even see where you can tell if you are using port relay or port forwarding any longer.

In OS3 I remember seeing it but in OS5 I cant locate it.

Please help.

Disregard, I located the information on the Android App, mine says direct, however if you are using the web based console, it should be there also.

WD, if you are listening, you need to put full functionality on either the web or the app. BUT you have to put full administrative functionality in ONE place. Right now, you have some on the app and some on the web console.

Same for me

Same problem here. I can ONLY connect to NAS by WD relay with OS 5. On my browser, I type in the local IP address, and WD changes it to a WD relay address. According to WD documentation a few days ago, NAS login can be by local network IP address, WD relay, or Port Forwarding. Today, I went to look for that documentation on the WD website – all the User Manual is there EXCEPT all the related sections to this problem have been removed. I’m guessing they are fixing / updating?

I disconnected my NAS (PR2100) from the network, then using my browser, tried to connect to the same IP address. My desktop still changed that IP address to the WD relay address. That means that the capture and change of IP address is done in my desktop, not in the NAS.

In a chat with WD, who also were confused with this, they noted that if a NAS login is detected as being insecure (e.g., no certificate), that WD/NAS automatically switches to a secure WD relay. I don’t get it, everything in my local network is secure to me (barring a serious break in).

Combine the above together – WD installs a modification to the call by IP address for the NAS – in my desktop. I haven’t been able to find it. There is a cookie for the WD relay, but I don’t think that deleting that will help.

@alaz0 the following article will help understand the HTTPS redirect in My Cloud OS 5 and connection modes. The Connection Type is how the client (mobile and web app) is connected to the My Cloud OS 5 device itself.

@SBrown Please give us an option to change the connection type back to Local in the next firmware update and remove any instance of OS 5 connections (unique domain name) to the device. It is unacceptable to force us to use Relay or Direct or the unique domain name, especially for those of us who have no interest in using the My Cloud OS 5 app.

1 Like

Thank you! I now understand better what is connected to what and why. Progress! Looking into port forwarding, the WD instructions show that I should get two FTP options, one HTTP option and one HTTPS option. On my PR2100, I get the two FTP options, but the HTTP ones are blank, and the port option fails. I suspect that’s due to the NAS wanting one of the HTTP options?

I haven’t yet found the key to fixing this in my router settings (Cisco RV-320). Working on it.

  • Andy

Now it’s ok for “Direct” connection

When I enter the IP address of my “My Cloud EX2 Ultra” than I get an unsecure http connection.

When I enter the hostname with https://mycloudex2ultra/, I get the following warning:

When using hostname or ip address there is no redirect to the devices unique domain name like device-local-012345678-123456789-1234-123456789012.remotewd.com.

I still have a relay connection.

Hello, I also use a fritzbox 7490 and can`t also establish a port fowarding connection. The ports are opened via upnp for ftp, http and https in the router (21, 20 443 and 80), but there is still the relay connection type.

@jumbo333 how did you fix this

Using https for the login leads to the http connection, do I have to import the NAS certificate to the browser (it is marked as “not valid” when trying to use the https way. The Dns resolving is o.k.
With kind regards

1 Like

@foert nothing done …

Okay - thanks.

The original question by @Holger81 is NOT about connecting with desktop browsers from within a LAN, it’s about the mobile app connecting via type “relay” while in a LAN (at least the original post shows a screenshot from the app). In my case, the app starts with “local” and then switches to “relay” which is slow and not necessary because I’m in my LAN. Actually, having installed the app for one week, I was never able to get a satisfying user experience because it connects via relay.

@SBrown could you please address this issue? Thanks.

This is the default behaviour from within a LAN and correct. The https connection secured by certificate is meant for remote connections via OS5 (type “relay”).

It’s a shame that WD devices are so complicated and unacessible for average users.

@totoff : Can you check what is the connection status from the mycloud.com? , For the mobile and web app to have a local connection, you will need to be on the same network as the My Cloud device.

The screenshot isn’t from the mobile app. It is from my desktop browser.

I accessed my “My Cloud EX2 Ultra” with the desktop browser and the connection type is relay which I don’t understand because with OS 3 it was a direct connection.

UPNP is enabled in my router and with OS 3 the necessary ports were opened but with OS 5 it no longer works.
The ports are not opened in the router although upnp is activated.

@Holger81: the screenshot from your device is from the Web dashboard. The web dashboard does not use a “relay connection”. It talks directly to the NAS on the local network. when you enter http://IP address or http://devicename, the browser is redirected https:://device-local-numbers.remotewd.com

Yes the screenshot is from the web dashboard.
When I enter the https://IP adress or https://mycloudex2ultra when there is no redirect to a url like https://device-local-numbers.remotewd.com it stays at https://mycloudex2ultra.

@MJ03 Thanks for replying to this topic.

My NAS is connected via Ethernet cable to my router, my iPad and my iPhone via WIFi to the same router. In the Admin Panel of the Router I can see they share the same network, so they are in the same network, aren’t they?

However, when I click under settings in the iOS app OR login with a browser under https://os5.mycloud.com/ and check the connection type it’s “relay”, no matter that I’m in my LAN. From my understanding this is wrong and slows down the connection, It should be “local” instead.

I’m not a server admin. I just want to have a working NAS. Currently I can’t access my files via the iOS app because the connection is so slow due to the unnecessary relay connection type,

1 Like