MyCloud OS5 - How do I get a direct connection?

I seem to be one of the few lucky customers who was able to make a smooth transition from OS3 to OS5. I haven’t lost any data or functionality. I also like the new web interface of OS 5 Cloud Access.

I only have one issue which is basically a reproduction of the issue I had when I connected MyCloud EX2 Ultra to the router the first time, a few years ago: if I connect to os5.mycloud.com, my device’s connection is “Relay” instead of “Direct” (formerly Port Forwarding).

I have browsed through a couple of articles in the WD database and I am confused, because it would appear that OS 5 does not support manual port forwarding and all you need is UPnP enabled in your router. Yet, the Admin dashboard allows for Manual Port Forwarding settings.

Also, my router (provided by my ISP, proprietary) has UPnP but seems to be against automatic detection of the appropriate ports. So I am forced to add them to the Administration Dashboard – Network – Port Forwarding, to force my router to detect them.

Therefore:

  1. If I do nothing, the connection remains local (which basically means that my colleagues cannot access the device via the internet – only I can because it is connected to the LAN).

  2. If I set port 40000 (one of the ports for Cloud access mentioned by WD articles), my connection becomes relay. An improvement, but the connection speed to download files is painstakingly slow.

  3. If I add the ports I used for OS3, the connection stays relay. The ports I use are:

Cloud Access: External 8082, Internal 8443
HTTPS: External 8443, Internal 443
HTTP: External 80, Internal 80

and to be safe, I left
Cloud Access: External 40000, Internal 40000

After several reboots, I still get a relay connection when connecting to My Cloud via the web.

Any suggestions to solve this issue and get a direct connection? Anyone?

Thanks in advance.

Alessandro

1 Like

@A.Cintoli The “local” that you are seeing is working as expected when you’re on the local LAN

IE: If your web browser or mobile app are on the same LAN as the My Cloud OS 5, the client web and mobile app should say local. If you turn off WiFi on your mobile phone, the Connection Status will say “Direct” if the mobile app is connecting to the My Cloud via Port Forward mode or Relay if the mobile phone is connecting via Proxy Relay.

In short, the Connection Status is how the client app is connecting to the My Cloud OS 5.

My Cloud OS 5 uses internal port 4430 and external ports between 40000-49999.
HTTP 80 is not used for OS 5.
Other ports such as 8001-8003 are used for rest-sdk, firmware update, etc…

Hi S,

Thank you so much for your timely response and for sending a light on this.

After my first message and reading more WD literature, I also thought the connection status would be different based on where the app is located on the network. So, your confirmation comforts me.

I have changed the port forwarding settings on the AdminUI as follows:

Cloud Access: External 40000, Internal 4430, both TCP and UDP.

The router recognizes the change.

However, the app still uses the Proxy Relay connection outside the LAN.

How can I make sure it uses Port Forwarding (Direct)?

I want to allow all other users in our company, who are outside the LAN, to download and upload files quickly in their share folders.

I look forward to hearing from you.

Alessandro

1 Like

UPnP is activated in my router and the direct connection worked with OS3. With OS3 I saw that two ports were opened in the router but with OS5 no ports are opened despite activated UPnP.
A direct connection is therefore not possible.

I would check out the actual capabilities of the WD apps. . . .you might find them a bit wanting.

For this type of work; I would seriously consider establishing a VPN connection to the network that has the NAS.

First. . . even with port forwarding; you really want to use VPN to connect to your home router. ESPECIALLY if the connection is via sketchy hotel or airport wifi connections.

Second. . . using a commercial VPN is one option. . .but if you use a “roll your own” VPN (such as OpenVPN); you can establish a direct connection to your NAS. At that point, you could use FileExplorer or Finder to access your NAS. (Not clear if you address the WebUI. . .originally blocked in earlier OS5 versions; this may have changed in the most recent (yesterdays) version.)

Hi SBrown,

Thanks for the explanation, however in OS3 in order to view the connection status I went through:
Settings > General > Cloud Access > Connection Status.
Where if any, can I find in OS5
Cloud Access > Connection Status ?

Thanks,
Oded

My Cloud OS 5: Connection Status

Answer ID 29488

My Cloud OS 5: Web App or Mobile App Connection Status

Answer ID 29489

Hello SBrown,

Many thanks. That’s clear it. Just to see I got it right, the status in the device adminUI is “Connected” (without knowing with what type, as opposed to OS 3). The type itself (i.e direct, relay, local) can be seen in the Web app or mobile app.
Is it correct?

Thanks,
Oded

That’s correct
If you’re wondering if the My Cloud is in Port Forward (Direct) mode, turn Off wifi on the mobile phone and open the Mobile app. If it’s in Port Forward mode, it will say (Direct) as in directly connect through your router via port forwarding and not hitting the Proxy servers. Could also check the router UPnP table as well.

image

Hello SBrown,
Yes, that’s what I did. I checked both the mobile app (showed “Direct”) and the router port forwarding table (showed port 4430).
Most of the time it is indeed “Direct”, but from time to time I find it in “Relay” not sure why.
To bypass, a router reboot sometimes help.

Many thanks,
Oded

I managed to get Direct mode working on my PR4100 OS5 instance with the following port redirections:

TCP 4430 on WAN points to 4430 on NAS
TCP 4431 on WAN points to 443 on NAS
TCP 8001 on WAN points to 8001 on NAS
TCP 49592 on WAN points to 4430 on NAS

Reboot your NAS after applying the port forward rules.

Hope it helps someone else

Good luck

Hi!

I have tried your suggested port forwardings with my EX2 Ultra in conjunction with a Fritz Box.

I face one issue. It seems to be an issue with the double port forwarding to 4430. It looks to me, as if the fritz box only accepts only one forward rule to a specific port.

Do you have an idea or am I too stupid?

First, I have created four manual port forwardings in the Fritz box::

Port to device 4430 to 4430
Port external (desired) 4430

Port to device 443 to 443
Port external (desired) 4431

Port to device 8001 to 8001
Port external (desired) 8001

Port to device 4430 to 4430
Port external (desired) 49592

In the overview of port forwardings, Fritz Box has a warning sign and tells me, that the last forward ing rule uses another port than desired (4430 instead of 49k).

Alternatively, I have deleted the manual port forwardings in the Fritz Box and added the forwards in the Mycloud.

Result: The Mycloud still is stuck on relay access with both ways:-(

Best regards,
uwzl

Hi @uwzl

Unfortunately, I don’t know what a Fritz Box is, nor have any experience with that. However, if the ports are properly forwarded, then in theory, Direct mode should start to work for you as it did for me

This seems strange, as the warning message does not explicitly state that the Fritz Box is only accepting one forward rule to the target port. It’s just letting you know that the device port and desired ports are not the same… in which case it should have warned you about the 4431->443 rule, as well…

I’m not too sure exactly what you mean by this (I don’t know of any way to add port forwards in MyCloud, or how that would help the situation). In essence, the port forwarding rules need to be defined on your firewall/router, between your public WAN-facing IP/interface, and your MyCloud’s private LAN IP/interface. If the Fritz Box is incapable of doing this for you, then that really doesn’t sound like a very good firewall router/platform to me at all, and I’d really recommend that you replace it with something more flexible/configurable than that which should thus also solve this problem.

Hi!

The fritz boxes are very common routers in Germany.

I could imagine, that the Fritz box stumbles, because two rules are pointing to the same port 4430 (4430 → 4430 and 49592->4430).

Is there maybe an alternative port routing for the 4430 or the 49592 rule possible?

uwzl

,

One thing I would try, is using the ssh functionality on the mycloud, to install an independent port forwarder, such as 3proxy’s tcppm, on your mycloud, which can then listen on another port (eg 44300) and forward traffic locally to port 4430. You could then forward traffic from port 49592 to 44300 and it will be transparently intercepted and redirected back to 4430. It may be possible to achieve this with an even simpler iptables firewall rule instead of going with other software to do it, although I haven’t checked. Maybe this could be a workaround. Otherwise you may need to get in touch with the manufacturer or support for the Fritz Box for further advice as there could likely be a workaround you could deploy on there too instead.