I want to disable Relay mode

Hello. I own a PR4100. I’ve upgraded to OS5. I can’t disable Relay mode. I can’t force a direct connection. I tried to forward external TCP 40000-49999 to internal 4430, 4430 to 4430, 80 to 80, 4430 to 443, port 8000 to 8000, 8001 to 8001, 8002 to 8002, etc as advised elsewhere on forums and wiki. Nothing is working. I even tried full DMZ nat / IP Passthrough. The manual mode option is missing under Cloud setup

Evidently with OS5 the device is intentionally programmed to use only Relay mode and this constitutes a major privacy concern for me and many other users also as the motive for this regress could be sinister

Please advise solution asap, otherwise I will flash third-party firmware to gain back control of a device I own as it seems I no longer have granular control over my own myCloud device since upgrading to OS5. Failure to respond with a solution to fix Relay mode will also mean it will be the last WD product that I purchase.

Thanks& Regards

I have seen OS/5 in “direct” mode.

HOWEVER. . .fundamentally - - - OS/5 is built for cloud integration. As long as you have “cloud services enabled”, I am almost certain the device phones home on a regular basis to enable that web access.

Frankly, it is quite evident that the developers to assume privacy was a factor in their uses. This is a primary reason that I only ever upgraded ONE NAS to OS/5. . . and have since reverted it back to OS/3.