Cannot manage MyCloud Home Duo

I have a totally reset MyCloud Home Duo freshly connected to my WD account via the app. The device is in the same subnet as my PC.

I can access the device via but I cannot manage it because the connection type is “Relay”. Clicking the “Manage device” links informs me that I should be connected to the local network (which I am). Downloading the Debug logs from http://LocalIP:33284/cgi-bin/ works, though.

I can also access the web interface of the device directly with its IP address in my local network. Though, after login, I see only the “Admin profile” and the “Local network access” boxes.

I tried several things:

  • total 60s reset and starting over
  • connecting the WD MyCloud Home Duo directly to the router fully exposed to the internet and trying to access it from my laptop that was also connected to the router

Software version is 9.5.0-186.

I am somewhat desperate now. Can please someone help me to get on track?

Best regards

You should try to read the Knowledge base and the forum before doing 60s resets.

Either your router has UPnP that is incompatible with the My Cloud Home, or Windows is disabling UPnP from its services and the webapp could only see the MCH temporarily or through relay.

You could try

  • Assuming you are using Windows, enable Windows UPnP service as shown below

  • Enable UPnP in your router or try a different router. Ask your friends or neighbor if you could plug in your MCH in their internet to test.

  • Uninstall any VPN services

  • Uninstall any third party antivirus, at least temporarily

Thank you, NoPlex, for the swift reply.

Actually, I did consult the documentation on the WD support pages. I should provide more information first:

  • I mostly use Linux but also tried it from Windows 11 on two devices.
  • No VPN involved.
  • No antivirus software involved. Ad-blocker temporarily deactivated in the browser.
  • A router of the same brand as I have (AVM) was listed as incompatible but not mine.

I hoped that I could reach the device if I fully expose it to the internet (for testing only!), i.e. turning the firewall in the router completely off for the device. But this did not work either.

I think I am missing some very basic understanding of how administration of the WD MyCloud Home Duo actually works. I need to better understand the inner workings before trying this and that.

My expectation is: if I have the device right in front of me on my desk, connected to same network segment, the web frontend of the device can be reached and I can log in, then it should be possible to just configure the device locally in the frontend. No router, UPnP, WD services involved. But what I see is what I have shown in the screenshot.

Is it mandatory for the device to have an internet connection, open ports and so on to be administrated even if I only want to use the device from the local network?

I searched but did not find documentation to learn about the mechanism how the device connects and reacts and can be reached. Some hints are very appreciated. That would help my troubleshooting.

Best regards

That is not the same as enabling UPnP on a router. You are going to have to try a different router, at least long enough to activate the ‘Local Access’ permission.

The new firmware after 8.12 allowed ‘Local Access’ without internet authentication. So once you have local access enabled, you shouldn’t need to have UPnP enabled on the router if you don’t need the cloud access functionality. The complication is when you need to reset or ‘Clear Device Settings’, then internet authentication is once again required.

Thank you for your support.

I tried to follow the recommendations as closely as possible:

  • UPnP is enabled on the router.
  • UPnP device host is enabled on the Windows laptop.
  • WD MyCloud Home Duo and Windows laptop are both directly plugged into the router.
  • Router additionally configured to allow the device to create its own port forwardings via UPnP.
  • Rebooted the device.
  • Restarted the web app (closed tab, logged out, logged in; on different computers)

The web app still indicates connection type “Relay”.
The android mobile app indicated connection type “Local”. This is even more surprising since the smartphone is a different network segment behind my private firewall appliance.

It would be nice if the android mobile app would allow me to configure NFS, SMB shares etc. and not only switching from RAID1 to JBOD and changing the device’s nickname.

The issue with trying another router is that AVM FritzBox is the quasi-standard router in Germany and it’s hard to find someone who uses another model to connect to the internet :frowning_face:

I duefully searched the WD documentation and the internet but I did not find helpful information: wouldn’t it work to add port forwardings in the router manually? If so, which external ports need to be forwarded to the internal ports of the WD MyCloud Home Duo?

Are you aware of the dangers of enabling UPnP (Universal Plug and Play) at the router?

Thank you for pointing that out. Router is so nice and informs me about any changes in the network by email, including port forwardings and open ports. Plus, my firewall appliance with certain blocking capabilities adds additional protection from threats emerging from the local home network. I feel sufficiently safe to keep UPnP on for the duration of my efforts to get the WD device going. I will disable UPnP on the router after I have managed that.

1 Like

Why don’t you just plug the MCH into this ‘private firewall appliance’ and see what happens?

Yes, you can try port forward and you will see ‘Direct’ connection instead of ‘Relay’ or ‘Local’. The problem is that the stupid webapp may only accept ‘Local’ status and not ‘Direct’ when dealing with ‘settings’ and ‘enable local access’, at least that was what happened when I tried one time to do that. You should try it nevertheless.

The private firewall appliance is an OPNSense. My computers and my smartphone are directly connected to the OPNSense. The overall situation is as follows:

Internet (DSL) ------- Router (FritzBox) ---- ---- Firewall (OPNSense) ---- ----

I tried the following combinations:

  • MCH in network, PC in network: Connection type “Relay” in web app on PC.
  • MCH in network, PC in network: Connection type “Relay” in web app.
  • MCH in network, PC in network: Connection type “Relay” in web app.
  • MCH in network, Smartphone in network: Connection type “Local” in smartphone app.
  • MCH in network, Smartphone in network: Connection type “Local” in smartphone app.

The strange thing is that the smartphone app shows connection type local no matter in what network the MCH is. Unfortunately, it lacks to possibility to configure NFS.

I can access the web interface of the MCH by direct HTTP connection to the MCH’s IP address and log in, turn on local network connectivity, but cannot manage the settings to enable NFS on the MCH.

I took the MCH to my parents’ home who have the most simple setup: a PC plugged into the router. I connected the MCH to their router. Web app on PC show connection type “Relay”. It is frustrating that managing the MCH even in the simplest setup does not work.

They and I have a FritzBox as router which is listed as not working in the WD support docs.

The Fritzbox can only forward blocks of 255 ports at once. Adding 40 blocks for the 40000 - 49999 port range is a pain.

I now either give up or buy a cheap used Speedport router (Huawei technology inside) and give it a try.

I noticed now that you kept mentioning NFS which seems to be the what you are after.

I have never seen anyone used NFS on the My Cloud Home or the MCH Duo running OS4. There is NFS support on the My Cloud OS5 but that is a completely different OS.

This is a link from SBrownWDStaff


Oh no! I was misled by this support page

My Cloud: Configure NFS Service

It lists the devices that do not support NFS and the MyCloud Home Duo is not among them.

What a waste of time and money :sob:

Now at least it’s clear that I will not spend more time on it and throw good money after bad for a router for test purposes.

I will see if I can put it to any use with SMB/CIFS protocol only.

Or hack it and put a decent Unix system on it. Although WD seems to have blocked the road to booting another OS. But that would be a question for another thread.

Thank you for your time and support!

Kind regards