My Cloud OS5 - Only connection type relay possible

Sorry, it looks the same under the iOS app. But it should be “local” anyway within your LAN (see my post below).

@totoff : based on your description, it should be a local connection. You should see this on your mobile for local connection. Are you able to access the web dashboard from the same device or PC ? As dashboard access is allowed only on the local network.

@MJ03

That’s what I’m saying. :wink:

And yes, I can access the admin panel (the place where you administer users, shares, etc.; same as web dashboard?) from the same device(s). I’m in the local network.

IMHO connection type “relay” from within the same local network shouldn’t happen. Is this a bug or a feature?

1 Like

I have just noticed that mine is doing the same - am logged in on the same network and it’s coming up as relay.
Am still having many other difficulties - so this is not the most obvious of the issues, but I wonder if it is part of the problem

@totoff :

  1. When you access the web dashboard either using http://ipaddress or http://devicename, does it redirect to a similar URL ? //https://device-local-d101ca31-0aea-4817-822a-81ecd7d1613d.remotewd.com/
  2. If your are being redirected to https, can you try “nslookup device-local-d101ca31-0aea-4817-822a-81ecd7d1613d.remotewd.com”. (replace the device ID with your device ID)
  3. you should see a response with your device name and local IP address. Can you confirm if the local IP address is the same as your NAS ip address?
  4. If the http://ipaddress or http://devicename does not redirect, can you private message your system logs please.
1 Like

@MJ03:

When I access the web dashboard either using http://ipaddress or http://devicename, it doesn’t redirect to a URL like //https://device-local-d101ca31-0aea-4817-822a-81ecd7d1613d.remotewd.com/

@MJ03
Thanks for getting back to me and sorry for the late reply.

  1. no
  2. n. a.
  3. n. a.
  4. please instruct on where to find the log and how to send a pm

Thanks again.

@Holger81, @totoff - sent you a message

Yep. Same issue here. The new OS update has been and continues to be a nightmare for end users. It is clear that WD has no resolutions for the problems caused by the system. From continued indexing, no cloud access, connection type problems, and, most importantly, an inability to be effective in using OUR data.

To everybody here, I make my private communication with WD support public. They really tried to be helpfull and communication was quick and smooth, so thumbs up, but I doubt the suggested solution is acceptable from a security standpoint. If somebody more skilled with server administration thinks different, I’m happy to hear your opinion.

WD Support:
Thanks for checking these. I researched on the **FRITZ!Box 7530 ** router and looks like they have DNS rebind protection. Here is an articleI found regarding this: https://en.avm.de/service/fritzbox/fritzbox-7360/knowledge-base/publication/show/663_No-DNS-resolution-of-private-IP-addresses/

With the DNS rebind protection, the device will not be able to establish a local connection from the client app(web app). You can follow the configuring exceptions from this article to add this domain to the accepted list.

Thanks,
My Cloud Team

My reply:
Thanks for your reply and your support, really appreciate your teams effort. However, I’m pretty much concerned about the suggested solution, as there is a reason for rebind protection and AVM is by far not the only manufacturer impementing it (see https://support.google.com/googlenest/answer/9144137?hl=en). In addition, how does your answer explains the fact, that the iOS app establishes a local connection first, displays the contents of the server and than switches to connection type relay? Actually it establishes a local connection but is unable to keep it alive.

Frankly, I switched from Synology to WD because I liked the sleak approach without zillions of apps already installed. But in terms of usability – not to speak about joy of use – OS3 and the related online service mycloud.com already was a nightmare and OS5 turns out to go the same route. I invested dozens of unproductive hours with debugging, finding out why it’s not working and so on. I never had the same trouble with Synology, it was just working.

For the moment I’ll deactivate cloud access completely, use the device as kind of “intelligent” HD in my local network and try to forget about it. Fortunately with iCloud drive there is a working alternative to keep my machines in sync.

Best regards

My Cloud OS 3 Remote Access used the following ports and allowed the user to manually configure port forward on the device itself.

Internal HTTP	80
Internal HTTPS	443

External HTTP	9000 - 9999
External HTTPS	9000 - 9999

My Cloud OS 5 only uses HTTPS and does not allow the user to manually configure port forward on the device itself.
OS 5 depends on UPnP to manage the forwarding of the ports.

Internal HTTPS	4430
External HTTPS  40000 - 49999

fritzbox-7490 Setting up automatic port sharing

Based on the information listed above I would suggest:

  • Toggle off and on Automatic Port Sharing / UPnP
  • Check the firewall is not blocking all ports between 40000 - 49999
  • Reboot the router
  • Reboot the My Cloud
1 Like

Thanks for posting this port information.

I really appreciate this stuff.

UPnP is activated in my fritzbox 7490 and the option Permit independent port sharing for this device is also enabled but in the android app when I turn off WiFi on my phone, the connection type is still Relay and not Direct.

Direct connection worked with OS3. With OS3 I saw that two ports were opened in the router but with OS5 no ports are opened despite activated UPnP.

Hello,
thanks for the reply; does’nt work, I tried it that way: Went to “Einstellungen” on the device’s dashboard (local); then went to network; went to prot forwarding (last item on the side), then clicked “add”:
when I tried select the default service scan - there was no service; enabling ftp leads to the ftp service on ports 21 and 20. But there is not HTTPS Service listed. So I went to “customize a port forwarding service” choose HTTPS and set the Ports You sugested; I enabled the UPNP in the fritz box AND added the Ports manually. Now I have two FTP Ports and one HTTPS Port opened and marked “green” in the fritzbox; and on the Device also three Ports HTTPS; Two FTP - wich are marked as ok.

I found also this article " Configuring port forwarding on a My Cloud EX2 device
Answer ID 22971" on Your websides.
With kind regards and thanks for Your answers

Update 20:15:
Still on relay connection

I have exactly the same problem. I tinkered around with port forwarding, DNS Rebind protection and so on. Nothing worked.
Connection stays Relay.

Additionally i can not see shares in the WEB or APP.
Problem seems to be that when activating mobile and web access in the dashboard i get an error message that something went wrong and if i have an internet connection.

I checked logs which are written at this point in time and it seems to be a software bug?
analytivprivate.log gives:

2021-05-23T00:01:17.170958+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:c43b1c6d-51eb-4d86-bf07-4d1b95a89a2b”,“function”:“get_sdk_status”,“message”:“sdk status is [idle]”}
2021-05-23T00:01:18.787753+02:00 di=gjkKSfr4dO debug adminUI: {“msgid”:“dashboard_page”,“corid”:“AUI:d2efc881-28c9-4343-b909-5072cdaf3627”,“function”:“check_fw”,“message”:{“method”:“POST”,“url”:“http://localhost:8002/ota/v1/firmware/check",“sendData”:null,“response”:{“statusCode”:204,“error”:{“message”:"”}}}}
2021-05-23T00:01:19.031708+02:00 di=gjkKSfr4dO debug adminUI: {“msgid”:“dashboard_page”,“corid”:“AUI:d2efc881-28c9-4343-b909-5072cdaf3627”,“function”:“get_fw_update_configuration”,“message”:{“method”:“GET”,“url”:“http://localhost:8002/ota/v1/firmware",“sendData”:"",“response”:{“updatePolicy”:{“mode”:“enabled”},“version”:“5.13.115”,“updateStatus”:“noUpdate”,"statusCode”:200}}}
2021-05-23T00:01:31.865853+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:3fbda738-3b15-4510-95c6-2f2b72c1943b”,“function”:“delete_share”,“message”:“Doesn\'t find the matched [Test] in the restsdk filesystem”}
2021-05-23T00:01:35.884699+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:b9fd9c2f-831a-44e9-8073-d9dadd3c4b50”,“function”:“create_fs”,“message”:"Error: Create [Test] filesystem fail. "}
2021-05-23T00:01:35.893688+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:b9fd9c2f-831a-44e9-8073-d9dadd3c4b50”,“function”:“create_fs”,“message”:“GET - [mountPoint] API - path:[/mnt/HD/HD_a2/Test], mount point:[/mnt/HD/HD_a2]”}
2021-05-23T00:01:35.903141+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:b9fd9c2f-831a-44e9-8073-d9dadd3c4b50”,“function”:“create_fs”,“message”:404}
2021-05-23T00:01:35.912251+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:b9fd9c2f-831a-44e9-8073-d9dadd3c4b50”,“function”:“create_fs”,“message”:{“key”:“notFound”,“message”:“Not Found”}}
2021-05-23T00:02:16.509952+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:1f9b68a8-1861-46ba-b3af-f94ac0d625d6”,“function”:“get_sdk_activity”,“message”:“http://localhost:8001/sdk/v1/device/activityStats”}
2021-05-23T00:02:16.524428+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:1f9b68a8-1861-46ba-b3af-f94ac0d625d6”,“function”:“get_sdk_status”,“message”:“activityStats lastUpdate time is NULL”}
2021-05-23T00:02:16.544565+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:1f9b68a8-1861-46ba-b3af-f94ac0d625d6”,“function”:“get_sdk_status”,“message”:“sdk status is [idle]”}
2021-05-23T00:03:18.928541+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:cc8b34ff-0635-4805-a02e-b9cc6e637add”,“function”:“get_sdk_activity”,“message”:“http://localhost:8001/sdk/v1/device/activityStats”}
2021-05-23T00:03:18.939966+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:cc8b34ff-0635-4805-a02e-b9cc6e637add”,“function”:“get_sdk_status”,“message”:“activityStats lastUpdate time is NULL”}
2021-05-23T00:03:18.961516+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:cc8b34ff-0635-4805-a02e-b9cc6e637add”,“function”:“get_sdk_status”,“message”:“sdk status is [idle]”}
2021-05-23T00:04:02.938789+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:483f0aed-6bc7-42ff-b2f2-c0c3e302d9ed”,“function”:“delete_share”,“message”:“Doesn\'t find the matched [Test] in the restsdk filesystem”}
2021-05-23T00:04:14.643200+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:f5314a94-a5e4-4921-beb0-a2bc7744c191”,“function”:“create_fs”,“message”:"Error: Create [Test] filesystem fail. "}
2021-05-23T00:04:14.653176+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:f5314a94-a5e4-4921-beb0-a2bc7744c191”,“function”:“create_fs”,“message”:“GET - [mountPoint] API - path:[/mnt/HD/HD_a2/Test], mount point:[/mnt/HD/HD_a2]”}
2021-05-23T00:04:14.663592+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:f5314a94-a5e4-4921-beb0-a2bc7744c191”,“function”:“create_fs”,“message”:404}
2021-05-23T00:04:14.673973+02:00 di=gjkKSfr4dO err RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:f5314a94-a5e4-4921-beb0-a2bc7744c191”,“function”:“create_fs”,“message”:{“key”:“notFound”,“message”:“Not Found”}}
2021-05-23T00:04:16.330054+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:e7480ff6-8d78-4222-b3c9-0052ccd43e56”,“function”:“get_sdk_activity”,“message”:“http://localhost:8001/sdk/v1/device/activityStats”}
2021-05-23T00:04:16.342892+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:e7480ff6-8d78-4222-b3c9-0052ccd43e56”,“function”:“get_sdk_status”,“message”:“activityStats lastUpdate time is NULL”}
2021-05-23T00:04:16.383865+02:00 di=gjkKSfr4dO info RestSDK_AdminUI: {“msgid”:“RestSDK_AdminUI”,“corid”:“AUI:e7480ff6-8d78-4222-b3c9-0052ccd43e56”,“function”:“get_sdk_status”,“message”:“sdk status is [idle]”}

Perhaps someone can help me to get at least access to my files in Web and mobile App.

It is really frustrating figuring around and not getting it to work, even if trying all things which are described. This should work out of the box. :frowning:

Router is Fritz.Box UPNP is enabled. But even exposing the complete host to the internet does not solve the problem.

Best regards,
Stefan

Hi!

Same here, Connection only relay.

Fritzbox 7590, UPnP active.

Is there meanwhile a solution?

uwzl

1 Like

Its the only relay connection type which will already be mentioned in its specifications . Best regards from Viva TV Apk TQ.