My Cloud. goes to Device offline after OS 5 update

Yesterday, I updated My Cloud 4TB NAS firmware (OS 3?) to (OS 5).
After this, I shared some directory as ‘public’, it seems not open to actually to public, but only to my accounts or approved accounts. And this, My Cloud start to scan pictures/movies by itself, which expect to takes a long time. It also said, I can use(access) the shared public folders on web browser.
And I used My Cloud for an hour.

And then, it suddenly go the status of ‘Device is Offline’, and I cannot see My Cloud address on my router, it acutally go offline. I cannot access this completely. But when I touched the body of My Cloud NAS by my hands, its HDD is still operating in busy. And this ‘Device is Offline’ status still on-going, a day passed now.

How can I fix this problem, or how can I save my data at least?


My Cloud Personal Storage User Manual ( See LEDs

My Cloud OS 5 Online User Manual (

(1) Reboot the My Cloud and then access the dashboard and Collect the System Logs
(2) Open a support case and send the system logs to support
(3) Let me know your case number

Hi Brown

I coudn’t do your instruction for traveling out side. During my trip I’ve check mobile phone app, it’s still ‘Device is Offline’ status. And I returned home today, I found the HDDs are still operating and offline status. (I didn’t mentioned that I have attached another USB drive 8TB.) And initially I ordered to My cloud that to index pictures and movies by sharing commend.

(Backgound information) Initially, I ordered (automatically, when I update OS 5 and shared,) My Cloud 4TB and attached 8TB USB external HDD to index picture and Movie.

  1. The HDDs(4TB MyCloud + 8TB usb) are still operating for 5days until now. Will indexing time takes so long time (many many days)? and also it can go automatically ‘offline’ status during indexing, maybe to protec user disturbance? If so, I should wait until the indexing is finished, and it will return to ‘online’?
  2. If this my status will not be returned to normal, then I should do anything. I cannot access My Cloud via network, so I only can press reset botton or pull power plug(off). How should I do? (I cannot access the NAS to collect system logs)
    2-1) Actually, once I pull the power plug right after offline status at the begining. And power plug in, I cannot found any improvement still same ‘offline’ status and both HDDs are running.
  3. If I should press reset botton, does it need to press for over 40 seconds? And I hope the data will be OK.

FYI: current MyCloud LED color is steady ‘blue’.

Best regards

Please do the following

(1) Power OFF the My Cloud and Detach the USB drive
(2) Boot the My Cloud and then access the dashboard and Collect the System Logs . Do a 40 sec pin reset if your must as it will not delete any data.
(3) Open a support case and send the system logs to support
(4) Let me know your case number

Hi Brwon


Thanks, Eddy

Hi - there I am having exactly the same symptoms as this case - has there been any progress is solving this problem - I see in some user forums that people are putting intelligent plugs onto their device to be able to power off and then power up to get around this problem - ok as a short term fix - but not a long term.
Before OS5 install - the My Cloud unit never dropped offline at all - so is a bit sad that now the OS5 front end on the phone is so nice - that the unit stability on line has disappeared.
Also the unit has been indexing since upgrade - and only 10% of the volume has been used - and in about 12 hours of indexing about 5% progress on the progress bar in the phone App.
Also the Blue light is constant and teh disc is busy even when it drops off-line.
Hope there is a solution coming - as the OS5 looked to be a step change in usability
Best of Luck - Sean

Same problem here. Mine updated Aug 12th and I have had nothing but problems. I did the 40 second reset, but if I move files larger than a pdf, like 30 minutes mp4 it looses network connection. This never happened before the update. Unplugging the power every two minutes is not an option. also you cannot back it up because you loose connection. Hoping someone has some answers or the fix it with another firmware update. Need to keep this thread open so they know we want help.

You should open a support case with WD. See SBrown’s post above.

Boot the My Cloud and then access the dashboard and Collect the System Logs . Do a 40 sec pin reset if your must as it will not delete any data.

Open a support case and send the system logs to support

UPDATE: Turns out it was bad file on one of the shared folders.As long as I did not transfer that file, the nas drive works as it has.

@Lori329 Is there anyway you can share the “problem file” so that we can provide to our engineering team for analysis?

WD Privacy Statement

I copied some mp4 video files from one shared folder to another on the same nas drive. Everything was ok. I had been backing up different folders to external mybook. Everything was going ok until I tried to backup one sub folder. After posting and realizing it was not update to firmware but on video file. I deleted that file and copied it back over from the original folder. I no longer have the file. It might be that my internal hard drive in the nas is starting to go bad. I have been in the computer repair business since 1997 and hard drives do go bad.

Hi Brown

I am facing the same error since I upgraded to OS5.
Worst part is that even the reboot seems to be not working and the Blue light continues to blink fast as soon as power is plugged in.

P.s. Done with 40s reset as well but received same result.


My only problem seemed to be one bad file. Too bad that was not the case. Tried to put some large files over and I lost communication with the drive again… This has happened a lot in the past two weeks. Unplugging the power and letting it sit would bring it back. Only this time unplugging did not now I only have flashing blue light. Pulling the drive accessing it with Linux, I am back to my first thought that firmware timestamp Fri Aug 13, 2021 is the cause of problems.

@Lori329 (1) Collect the system logs once you have access to the dashboard again (2) open a support case and attach the system logs along with any sample files that are causing the issue.

My drive has developed bad sectors. Bought a new WD NAS drive 4tb red. Having trouble setting the new drive up to be used in the original NAS case. Found community page for Gen 2, but still not working.
I must be missing something in the procedure. I have successfully put a new hard drive in another brand NAS that uses similar format. I have the WDBCTL0040HWT-10. So my problem is not the OS 5 update. Any help would be appreciated. Thanks

My drive is unresponsive next day after updating to My Cloud 5. I have to unplug it every morning. I opened a support case # 210915-003960. I added to system log and dmesg up to where there is no more connection.

Hi SBrown, I have the same problem described by others here. I cannot collect system logs because I cannot access the drive at all - have rebooted endless times, including 40 second pin reset, nothing works. The disk has vanished from my network, even though it shows itself rebooting (blue light flashes quickly) and then coming up (blue light steady).

I have opened a support ticket 210920-004162

Thanks if you can help

Same problem here, my unit (Gen2 -10) goes offline after xxx minutes ever since the OS5 update. Opened a support ticket, followed instructions per below:

I have performed the 40 second reset process and the device remained online for approximately 20-30 minutes, then went offline again. So basically, it behaved the same way it had been behaving prior to performing the reset. I did not turn on cloud access and the only changes I made during the setup process were to the username and password.

The only way to regain access is to power cycle the device.

Final response from WD:

As per drive’s behaviour, it indicates that drive is malfunctioning and unfortunately your drive with serial number # WCCxxxxxxx is Out Of Warranty and is not eligible for replacement as per WD warranty policy.

If the issue persists, we request you to recover the data from the drive by contacting any 3rd party data recovery vendor.

TOTAL BS, it was working fine on OS3! Anyone found a solution?


Since I have been facing this issue for more than 5 months now and still could not find a solution. I have started to believe it was a deliberate effort of WD to crash older devices so people go and buy the new ones.

I have been asking WD SUPPORT team and every time they come back with same template based questions asking about how my device is bahaving.

Really hopeless WD team. OS5 ruined home cloud device.