Problems using MyCloud OS5

Several days ago I installed MyCloud OS5 on a PR4100 system. Since this update I experience several problems:

  • The system is indexing the data – now for several days.
  • Sometimes I cannot access the dashboard (time out).
  • When I am able to log in I can see that values for CPU and memory usage are constantly high.
  • Goodsync can access the MyCloud OS5, but whenever I sync data the data transfer rate goes down until the process stopps. The error message is that that PR4100 is not longer accessible. After waiting for a while, goodsync can access the device again.
  • I was unable to re-install the existing users on the device.

The OS5 does not seem to be stable. Everything got worse. I destroyed a good working system.

Did anybody else experience the problems mentioned above, too?

Did anybody else experience the problems mentioned above, too?
Um have you looked at this board???

@Thorsten_Frenzel Please check this article for best practices for indexing and ensure your My Cloud is on 05.05.111 firmware

Thanks a lot for your advice! I upgraded now to OS 5.05.111 what improved the situation a little bit. But the indexing program is still running.

My PR4100 is a 32 TB NAS which was bought to store pictures and video material so that I cannot exclude data from the indexing process.

What I also learned is that the software GoodSync was a part of the problem, too. I updated to the latest version what also improved the heavy workload to CPU and memory.

I do not try to re-activate the users which had an account for OS 3 but do need an OS 5 account now.

What I experienced is that one user can login through the WD homepage but gets the message that no device is assigned to the account. When sending a new invitation email, the same WD homepage software tells me that the user is already logged in so that I cannot re-assign the device.

I also tried to remove this user via dashboard. This also fails without any specific reason. So this user is trapped somehow and I do not know how to solve this problem.

Kind regards

Thorsten Frenzel

Just installed latest firmware having simlar issues regarding server indexing data.Its been just under 24 hrs now only at 33% .Some of the picture albums are missing from indexted data.Am I foolish in thinking if the data is already on hard drives indexing should not take so long.Secondly has anyone tried connecting external hard drive and transferring data any quicker?

@nevetseel Please share the My Cloud Logs and Screenshot thru Private Message.

Same problem for me with MyCloud Mirror Gen2.
It worked fine with OS3, after the update to OS5 the cloud is unusable. it’s been like this for 3 weeks or so.
The dashboard is slow and, when i manage to enter, the cpu usage is always almost at 80%.
Yesterday, after an automatic restart (i did nothing) overnight, it started the indexing: yesterday evening was at 6%, this morning is still blocked at 6%. It’s strange to me, there are a lot of files in the storage, but on 4TB it’s just used for less then 400GB.
I found some guides to stop the indexing with SSH, as well a guide to revert to OS3, but i’m afraid to lose all my data.

Try turning off Mobile and Web app access option of the shares you do not need indexing. Or, if you do not need cloud access, you can just turn that off and it will stop the indexing process.

Here is an KB that may help:

So far it has taken my 2Tb unit which has about 240 gb of info on it 3 days to get to 81% still indexing. Seems to be gettting a bit quicker responding hopefully when its fifnished might be usable again.

Yep I have, its terrible, ever since I upgraded to v5 its just got worse and very flaky. Example here, I also have a single MyCloud drive, today I gave up at one point copying over a file which was 3.7Gb to my Mirror, in fact it crashed and fell off the network, o I copied said file to my single drive, it did it in about 2 minutes, I then ( having re-connected my Mirror to the network ) did the same thing , it took over 5 minutes just to copy the same file. I have a very good network and latest router so I know its not that. Everything was just fine and working well ‘before’ this dam new update which does not work. Its not fit for purpose. I want to go back to the previous Firmware version because I know it works.

Who ever designed the new OS5 has not done their job properly, not even due diligence.

And yes I agree its destroyed a good working system, but no-doubt they will come up with excuse after excuse because they don’t like being criticised or told that their system is rubbish.

Steve ( UK )

I’ve had terrible response since upgrading my MyCloudMirror Gen2 to OS5. Been back and forth with a Sr. Manager of Technical Support who finally said after looking at system logs:

Thank you for providing the system logs.
We have confirmed the issue is with rest-sdk process not responding and have target the fix in the next firmware release.
We apologize for any inconvenience this issue may have caused.

Support keeps saying to turn off the shares you don’t want to use, or turn off Cloud Access entirely, when the whole point of using the drive is to use it on the web or via mobile.

I then asked “When, may I ask, can I expect the next firmware release?”

Crickets since then other than how did support or feedback do in responding to your incident.

You can probably guess my ratings and comments.

@Lildschwarz 5.06.115 firmware was released on 11/19/2020 and announced on the WD Community.

5.06.115 Firmware Release https://community.wd.com/t/my-cloud-os-5-firmware-release-note-v5-06-115
My Cloud OS 5 Release Notes

1 Like

Good evening:

Thanks so much for providing me an answer.

I just returned back to the forum today as I’ve been at my witts end.

The manual update worked just as advertised. Drive is indexing, but much quicker and able to access via web/mobile.

May I suggest this be pinned at the top of the forum if it’s not already and any OS5 problems first be directed to this post?

I’ll catch up with you.

Have a great day.

Finally finished indexing!!!

1 Like

Update
Since the latest firmware update indexing does no longer seem to be a problem on my PR4100. The process became faster and I could access the dashboard while the indexing was running. It finished on my drive after a few days.

But:
All the user-related problems have not been resolved so far:

  • One user cannot get cloud access: “No drive assigned” vs. " User is already logged in."
  • Cloud access cannot be deleted (deleting process terminated with an error message).
  • Users cannot be deleted (deleting process terminated with an error message).
  • Existing users do not get an email-invitation when this message is send via dashboard.
  • Access is possible via admin only.

Did anybody experience the same problems? How can I reset the users without deleting the data on my PR4100?

Thanks a lot in advance for all of your answers!
Thorsten Frenzel

@Thorsten_Frenzel A 'System Only Restore" would delete all users currently on the device and will not delete any data.