My Cloud. goes to Device offline after OS 5 update

I have the same problem. Someone could fix it???

it’s unbelievable that this happens.

I had the same issue for couple of months and eventually I managed to solve it.
After I upgraded it to OS5 the device was super slow and irresponsive. Couldn’t really use it.

Here’s what I did:

  1. I logged to the dashboard (which took forever… you might need to do soft reset to be able to log-in)
  2. Click on “Cloud Access” on the top (then wait for the users list to appear on the left panel…)
  3. Click “Admin” from the users list (wait again…)
  4. Disable “Cloud Service” - toggle it off
  5. I deleted all other users under Cloud Access
  6. Reboot the device. And then… it started to work faster
  7. I deleted the old folder of Smartware since it’s no longer supported by OS5
  8. Reboot the device again
  9. Wait a bit to let it index
  10. Once indexing was done I turned “Cloud Access” back on
  11. Recreated my other users accounts under Cloud Access

Once I completed the above procedure everything started to work smoothly. The device works fast and I don’t experience any of the previous issues. It works smoothly like it did before the OS5 upgrade. I’m even able to use to mobile app and access my files remotely.

I hope you’ll find this useful.

p.s. My device current Firmware Version is 5.17.107

1 Like

Thanks Yoshi… But…

The story ends at trying to login as all the people complaining here facing the issue of device not appearing online.
It always appears offline.
So none of the other steps are possible at all.

It all started post OS5 update and we never had a single issue until we updated it to OS5.

Thanks for the illustrations anyway mate


In order to log in to the dashboard I had to:

  • Do a soft reset
    (Learn how by going to YouTube and look for “How to soft reset WD my cloud”)
  • Access the dashboard by typing the device explicit IP address on the browser address bar
    (Something like HTTP://
  • Be patient. It took the page few minutes to load. And then few more minutes to pass the login page after I entered my credentials

I am able to login to dashboard following a power cycle (wait for LED to stop blinking, refresh login page a few times and it eventually allows me to login). All settings and my files are accessible then. So I am able to go in and turn off cloud access, etc. Can access my files from any device on my home network.

My issue is that the device will only stay accessible (“online”) for some number of minutes before becoming inaccessible (“offline”). Completely loses connection and the ability to access dashboard or any files at that point. The drive keeps running, solid blue light, and looks normal from a physical standpoint. I can only regain access by power cycling again and repeating the process…

To complicate, I can actually still ping the drive from the command prompt, even when the drive is inaccessible (“offline”).

Well it appears the OS5 is unstable. I had same problems with my syste, Worked fine under OS3 and nothing but issues and unresponsiveness when I upgraded to OS5. Spoke to customer support and they got it going, but only for a couple hours, then bvack to super slow, slow access to dashboard and no remote access. I purchased a Buffalo NAS device and it has been up and running for 5 days no issues. Bye Bye WD

Did anyone find a solution? I am experiencing the same thing with WT-10

No solution so far. Soft reset or hard reset nothing worked for me. The blue light just blinks continues to blink fast.
I think it’s time to just reteive my data somehow and get another brand cloud storage where the tech really works as promised.

@mashists and @sumitsingh

The more information you provide, the more we have to work with. What computer and OS are you using?

Below are some images from my Desktop computer, Windows 11 Pro. I have a WDMYCLOUD 2nd generation with OS5.

Image One: When I open File Explorer I can see my device. Click on, tap, or activate images to enlarge them.

Image Two: When I open my Dashboard and look at Cloud Access it shows I have been logged out.

Image Three: I have signed into Cloud Access.

In my original post I provided links to the User Manuals. Have you looked at and read those?


Please note that setup is already done to access my cloud on OS 5. I can only communicate with my cloud online for few minutes, and it disconnects and remain offline until I do reboot the device. I just rebooted to show that I can access for a few minutes. My indexing stopped at 65% before the device disconnect

Who is your Internet Service Provider and what plan do you have with them? What are your download and upload speeds? How many other devices are on your network? What type of modem/router do you have and how many devices can be connected?

What Is a Good Internet Speed? |

25/25 DL/UP. The issue here has nothing to do with the questions you are asking but has to do with OS 5 upgrade. I never had issue before OS Upgrade

What do you mean by WT-10? I did a search and this is what I found.
WT-10 - Search (

If you are using Windows, my suggestion is to use Steps Recorder to show what is happening. Save the results and send it to WD.

Warranty Status | WD Support Click on, My Support Portal.

Is this the device you own?

I mean part no of device.

I will try to get support but I see some people did not get support needed and that’s why I was following up to check how far they went

There are clues in the screen shots:

  1. Indexing 22%
  2. MyCloud (single bay) Gen2

The issue is that (unfortunately) the MyCloud Gen 2’s are really quite, almost, but not quite, capable of performing the indexing task.

When the indexing task is running flat out on one of these devices (especially when indexing first happens after loading OS/5). . . . .the dang thing doesn’t quite have enough spare processing power/ram to communicate across the network.

So: Possible solutions;

  1. Let it run. Seriously. . . .let it run for DAYS to let the indexing task to complete. For larger (4TB+) drives, it will take MULTIPLE DAYS to complete indexing.

  2. If you don’t really need cloud access (Don’t need the OS/5 phone app; don’t need to access across the internet. . . . .go in and turn OFF cloud services.

If I was in your shoes. . .I would turn off cloud access, and use the device locally (on your home network) to make sure it is working ok. . .then turn on cloud access. . .and let it sit and churn the index.

Ok. . .not really. What I would do is a version of the following;

  1. Recognize that you are rolling the dice with “pulling the plug” during indexing .
  2. Pull the plug, restart, get to the dashboard asap and stop cloud services.
  3. Pray I can access the device.
  4. Make sure I have a good backup. . . .refresh as necessary.
  5. sit for a day to make sure it keeps working
  6. Get a small fan to keep the unit cool as you get ready for the next step
  7. Turn on cloud services.
  8. Start shopping for a new NAS
  9. Wait a week while indexing runs.
  10. Hope that Indexing is sorted. . .and then log to see if everything is working.

I switched OFF cloud access and can access locally for long period. I will switch ON cloud access after 24 hours to see if the NAS will still be accessible for a long period.