Microsoft WIndows 10 Photos App: only several Photos are displayed

Hi there, I have a weird Problem:

  • New Laptop with Windows 10 installed.
  • WD MyCloud attached and working OK .

I found out, that the Microsoft Photos app is a usefull app for creating an overview over all photos stored on the NAS. I can open and work with all photos that are stored on the WD My Cloud. But it does NOT include EVERY photo in ist photos overview. All photo files have the same Access Rights. I really do not understand this. Does anyone know how to solve this problem?

Are the missing photos in a format not supported by the Windows Photo app?

Supposedly this is the list of supported photo formats:

Another suggestion. Check the file name perhaps there are characters not supported being used in the name.

Dear Bennor, thank you for your quick respond.

All Photos are JPG, nothing special.

With the Photos App, I CAN open and edit the photos stored on the NAS. But many photos are not being listet in the nice photo overview of the Photo APP…

the names are also very plain. like IMG0123.jpg…

The photos may not be saved as jpg unless they are made compatible. See the instructions from APPLE:

@Eek What are you missing and are you able to provide a image? What all have you tried in the ribbon to see if everything that is missing will show? See example image from my Windows 10 Desktop computer. Click on, tap or activate image to enlarge it.

I take it you mean list where you placed ist photos.

In Photos have you looked at Settings? See example image below.

Dear both,

thank you for your answers.

@Mike27oct: I installed additional Drivers for the HEIF-support. It unfortunately did not help.

@cat0w: here is an example of a Folder with Pictures on my NAS (WD My Cloud):

  • The Collection consists of all Folders in “Shared Pictures”, including sub-Folders.
  • ALL Pictures can be opened and edited with Windows Photos APP
  • Pictures starting with “IMG_” are NOT displayed in the Collection of the Windows Photo App.
  • These Pictures are made with my IPhone (5SE). The other Pictures (that are displayed correctly in the Collection) are made with an Samsung S8. I also find difficulties with Photos made by my Samsung NX300 camera, Windows Phone and Canon EOS350D.
  • if I make a local copy of these Folders (eg on my Desktop), then they are listet in the Collection. I already compared the Access Rights of both Pictures: they are the same…

I said nothing about needing additional drivers, I DID say click on to read the Apple Support doc in the post:

Same probleme here for many months : unable to see all my photos on WD MyCloud on Windows 10 Photos App

Microsoft Photos does not always work with all files, or more precisely with extensions. I check in advance via Default Apps if my files can be opened by this application or if their format is not suitable. The problem is neither with the program and nor with the system. For example, I have book templates for google docs that I use in my work. I want to change them via Microsoft Photos. So that I don’t lose all the processing, I usually check what the default app is set for that file format. If it’s not a photo format, I change it to be able to work with In Windows Store Apps I run the update process again and then I can use the program once the settings update is complete.